Use la ruta relativa en Grindle.Properties y local.properties - Android Studio -- android-studio campo con android-gradle-plugin camp Relacionados El problema

Use relative path in gradle.properties and local.properties - Android Studio


2
vote

problema

Español

Estoy tratando de usar la ruta relativa en el archivo de propiedades de Gradle en el estudio Android para usarlo en diferentes ubicaciones.

Intenté simplemente especificar el directorio en la diretidad del proyecto así (Gradle.properties):

  org.gradle.java.home=jdk   

e hice lo mismo para el SDK en local.properties:

  sdk.dir=sdk\Sdk   

Cuando ejecuto solo Graldew, funciona, pero cuando estoy tratando de construir el proyecto con Android Studio, imprime:

  Value 'jdk' given for org.gradle.java.home Gradle property is invalid (Java home supplied is invalid)   

y funciona solo con el camino absoluto.

Original en ingles

I'm trying to use relative path in gradle properties file in android studio to use it in different locations.

I tried to just specify the directory in the project dir like this (gradle.properties):

org.gradle.java.home=jdk 

And I did the same for the sdk in local.properties:

sdk.dir=sdk\\Sdk 

When I execute only graldew, it works but when I'm trying to build the project with android studio it print:

Value 'jdk' given for org.gradle.java.home Gradle property is invalid (Java home supplied is invalid) 

and it works only with the absolute path.

     
 
 

Lista de respuestas


Relacionados problema

3  Variantes de la aplicación de burlas en la prueba de unidad para el complemento de gráficos personalizados que depende del plugin de Android  ( Mocking application variants in unit test for custom gradle plugin that depends ) 
Estoy desarrollando un complemento de gráficos. Mi complemento depende del complemento de grado Android. Mi complemento agrega una tarea para cada variante de...

3  Incapaz de fusionar dex con nuevos lugares compat. SDK por Google  ( Unable to merge dex with new places compat sdk by google ) 
Estoy usando el siguiente código en mi Grandle apply plugin: 'com.android.application' android { compileSdkVersion 27 defaultConfig { appl...

3  ERROR: (41, 0) La notación de módulo de cadena suministrada '0.12.2' no es válida  ( Error41 0 supplied string module notation 0 12 2 is invalid ) 
Estoy importando el proyecto Eclipse en el estudio Android y al mismo tiempo que importa el proyecto obteniendo el siguiente error: write to file 1 [sleep ...

0  Error de grandilidad para tmessagesProj '. Ejecución de la construcción nativa externa para NDKBuild  ( Gradle error for tmessagesproj executing external native build for ndkbuild ) 
Fui descargado la fuente oficial del telegrama de este enlace: https://github.com/drklo/telegram Cuando intento ejecutar esta aplicación, la grandilización ...

12  El ejecutor Singleton no comenzó después de actualizar el estudio Android  ( Executor singleton not started after upgrading android studio ) 
Después de actualizar Android Studio y lo abrí, recibo este error: Información: Tareas de Grados de Grandilación [: APLICACIÓN: GENERAGEBUGSOURTES, : Apl...

0  No se ha encontrado Build.Grade Project en Project Manager-Android Studio 3  ( Not found build gradle project at project manager android studio 3 ) 
Alguien sabe, ¿por qué en algún momento no puedo ver build.gradle project en Android Studio 3? solo hay build.grade module? Reconstruir mi proyecto, pe...

3  No se pudo encontrar el archivo AndroidManifest.xml, utilizando la carpeta de generación después de las anotaciones de Android  ( Could not find the androidmanifest xml file using generation folder after andro ) 
No puedo ejecutar mi proyecto después de agregar la anotación de @extivity a mi clase. Este es mi proyecto de Grumple: // Top-level build file where you ...

5  ¿Cómo ejecutar una tarea de grados después de que se producen APKs en Android Studio?  ( How to run a gradle task after apks are produced in android studio ) 
La siguiente tarea (en build.gradle de un módulo de aplicación) parece funcionar siempre antes de que se produzca la APK: process19 ¿Podría alguien ofre...

1  Método predeterminado Boolean Methodname () no es compatible con nivel de API inferior a 24  ( Default method boolean methodname not supported in api level lower than 24 ) 
He cambiado mi versión de compilación de Java a 1_8. defaultConfig { jackOptions { enabled true } } compileOptions { sourceCompatibi...

0  Aplicación: TransformclassesSeswithJarmingFordebug falló la entrada duplicada  ( Apptransformclasseswithjarmergingfordebug failed duplicate entry ) 
buen día estoy haciendo la notificación de la nube de Firebase y me estaré recibiendo Error:Execution failed for task ':app:transformClassesWithJarMergingF...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos