Ningún módulo llamado imutils.pectective después de la instalación de PIP -- python campo con macos campo con opencv campo con pip camp Relacionados El problema

No module named imutils.pespective after pip installing


12
vote

problema

Español

Estoy tratando de seguir este tutorial que requiere imtools . Parece que tengo el paquete instalado, pero el compilador de Python no puede encontrarlo. ¿Qué está pasando aquí?

Tutorial: http://www.pyimagesearch.com/2016/10/03/2016/10/03/2016/10/03/bubble-seet-multiple-choice-scanner-and-test-grader-using-omr-python-and-opencv /

  ~/py:. cat test_grader.py from imutils.perspective import four_point_transform~  ~/py:. python test_grader.py Traceback (most recent call last):   File "test_grader.py", line 1, in <module>     from imutils.perspective import four_point_transform ImportError: No module named imutils.perspective  ~/py:pip install imtools Requirement already satisfied: imtools in /usr/local/lib/python2.7/site-packages Requirement already satisfied: matplotlib in /usr/local/lib/python2.7/site-packages (from imtools) Requirement already satisfied: pyyaml in /usr/local/lib/python2.7/site-packages (from imtools) Requirement already satisfied: numpy in /usr/local/lib/python2.7/site-packages (from imtools) Requirement already satisfied: scipy in /usr/local/lib/python2.7/site-packages (from imtools) Requirement already satisfied: python-dateutil in /usr/local/lib/python2.7/site-packages (from matplotlib->imtools) Requirement already satisfied: pyparsing!=2.0.0,!=2.0.4,>=1.5.6 in /usr/local/lib/python2.7/site-packages (from matplotlib->imtools) Requirement already satisfied: cycler in /usr/local/lib/python2.7/site-packages (from matplotlib->imtools) Requirement already satisfied: pytz in /usr/local/lib/python2.7/site-packages (from matplotlib->imtools) Requirement already satisfied: six>=1.5 in /usr/local/lib/python2.7/site-packages (from python-dateutil->matplotlib->imtools) ~/py:.   
Original en ingles

I am trying to follow this tutorial which requires imtools. It looks like I have the package installed, but the Python compiler cannot find it. What's going on here?

Tutorial: http://www.pyimagesearch.com/2016/10/03/bubble-sheet-multiple-choice-scanner-and-test-grader-using-omr-python-and-opencv/

~/py:. cat test_grader.py from imutils.perspective import four_point_transform~  ~/py:. python test_grader.py Traceback (most recent call last):   File "test_grader.py", line 1, in <module>     from imutils.perspective import four_point_transform ImportError: No module named imutils.perspective  ~/py:pip install imtools Requirement already satisfied: imtools in /usr/local/lib/python2.7/site-packages Requirement already satisfied: matplotlib in /usr/local/lib/python2.7/site-packages (from imtools) Requirement already satisfied: pyyaml in /usr/local/lib/python2.7/site-packages (from imtools) Requirement already satisfied: numpy in /usr/local/lib/python2.7/site-packages (from imtools) Requirement already satisfied: scipy in /usr/local/lib/python2.7/site-packages (from imtools) Requirement already satisfied: python-dateutil in /usr/local/lib/python2.7/site-packages (from matplotlib->imtools) Requirement already satisfied: pyparsing!=2.0.0,!=2.0.4,>=1.5.6 in /usr/local/lib/python2.7/site-packages (from matplotlib->imtools) Requirement already satisfied: cycler in /usr/local/lib/python2.7/site-packages (from matplotlib->imtools) Requirement already satisfied: pytz in /usr/local/lib/python2.7/site-packages (from matplotlib->imtools) Requirement already satisfied: six>=1.5 in /usr/local/lib/python2.7/site-packages (from python-dateutil->matplotlib->imtools) ~/py:. 
           
 
 

Lista de respuestas

17
 
vote
vote
La mejor respuesta
 

Parece que acabas de instalar un paquete incorrecto. El tutorial dice que necesita imutils, pero instaló Imtools en su lugar. Intenta instalar Imutils:

  pip install --upgrade imutils   
 

Seems like you just installed wrong package. The tutorial says you need imutils but you installed imtools instead. Try to install imutils:

pip install --upgrade imutils 
 
 
 
 
7
 
vote

1) Instale imutils

  DownloadAndSaveImage()0  

2) Si Imutils ya está instalado, marque la ruta de instalación.

  DownloadAndSaveImage()111  

3) Cuando corrí el programa Python, corrí al siguiente error:

  DownloadAndSaveImage()2  

En mi caso, Imutils solo se instaló bajo /USR/LOCAL/LIB/PYTHON3.5/dist-packages Ruta, una vez que copié esta carpeta en /usr/local/lib/python2.7/dist- Paquetes , funcionó! Espero que esto sea útil.

 

1) Install imutils

pip install imutils 

2) If imutils is already installed, check the installation path.

Requirement already satisfied: imutils in /usr/local/lib/python3.5/dist-packages 

3) When I ran python program, I ran into following error:

ImportError: No module named imutils.video 

In my case, imutils was only installed under /usr/local/lib/python3.5/dist-packages path, once I copied this folder to /usr/local/lib/python2.7/dist-packages, it worked! Hope this is helpful.

 
 
1
 
vote

Pruebe DownloadAndSaveImage()3

He resuelto este problema en Raspberry Pi 3 B usando DownloadAndSaveImage()4

 

Try sudo pip2 install imutils

I have solved this issue in Raspberry Pi 3 B using sudo pip2 install imutils

 
 
0
 
vote

Está instalando DownloadAndSaveImage()5 que es completamente diferente a DownloadAndSaveImage()6616

ejecutar

DownloadAndSaveImage()7

o

DownloadAndSaveImage()8

Si está en un entorno de Conde.

 

You are installing imtools which is completely different than imutils

Run

pip install imutils

or

conda install -c conda-forge imutils

if you are in a conda environment.

 
 
0
 
vote

Instalé Imutils con "PIP Instale Packagename --Target PathofDirectorty" en la carpeta Python 3.5 y todo salió a la derecha

 

I installed imutils with "pip install packageName --target pathOfDirectorty" in to the python 3.5 folder and everything went right

 
 
 
 
0
 
vote

Lo más probable es que se esté instalando en Global y no en Local. Compruebe si Imutils está en esta carpeta c: Archivos de programa PETHON37 LIB Site-Packages

Copiar Pegar Imutils e imutils-0.5.2.dist-info carpeta en su local c: usuariosid appdata roaming python python37 site-paquekes

nb: la carpeta appdata está oculta

o DownloadAndSaveImage()9

 

most probably it is getting installed in global and not in local. Check if imutils is in this folder C:\Program Files\Python37\Lib\site-packages

copy paste imutils and imutils-0.5.2.dist-info folder in your local C:\usersid\AppData\Roaming\Python\Python37\site-packages

NB:AppData folder is hidden

or pip install --user imutils

 
 
0
 
vote

En mi entorno de condena de base predeterminada (usando Anaconda Preguntar), hizo ETag0 y accediendo al mismo por ETag1 desde el interior ETag2 creado por VirtualEnv .... Funciona bien ..

 

In my default base conda environment (using Anaconda prompt), did pip install --user imutils and accessing the same by import imutils from inside my_env created by virtualenv.... works fine..

 
 
0
 
vote

No sé sobre Python, pero necesitaba ejecutar un guión de Python, que necesitaba esta parte Imutils.Perspective.

aquí cómo funcionó para mí.

He instalado todas las últimas versiones de uso PIP3:

  • Python-opencv (4.4.0)
  • imutils (0.5.3)
  • numero (1.19.2)

Todavía no pude encontrar ninguna perspectiva después de importar imutils e intentar la pestaña completa después de "Imutils".

ingrese la descripción de la imagen aquí

Intenté desinstalar y reinstalar todos los paquetes, pero todavía no tengo suerte. Pero de alguna manera logré hacerlo intentando diferentes códigos.

Instalé Scipy (1.5.3) usando sudo pip3 install scipy primero. Luego usando import imutils y from imutils import perspective Pude usarlo. No es necesario importar Scipy, solo instale.

ingrese la descripción de la imagen aquí

 

I don't know about python but I needed to run a python script which needed this imutils.perspective part.

Here how it worked for me.

I installed all latest versions of using pip3 :

  • python-opencv (4.4.0)
  • imutils (0.5.3)
  • numpy (1.19.2)

Still I could not find any perspective after importing imutils and trying tab complete after "imutils."

enter image description here

I tried uninstalling and reinstaling all packages but still no luck. But I somehow managed to do it trying different codes.

I installed scipy(1.5.3) using sudo pip3 install scipy first. Then using import imutils and from imutils import perspective I was able to use it. No need to import scipy, just install it.

enter image description here

 
 

Relacionados problema

0  No puedo instalar módulos PIP  ( Cant install pip modules ) 
ERROR: Exception: Traceback (most recent call last): File "C:UsersLenovoAppDataLocalTemp mpj3_890qppip.zippip_internalcliase_command. py", line 216, in _m...

0  Instale Mercurial 3.4.2 para Mac  ( Install mercurial 3 4 2 for mac ) 
Estoy tratando de instalar Mercurial 3.4.2 para Mac con código: database3 pero tiene un error: database4 ¿Puede alguien ayudarme con esa cosa? ...

1  Error: no se pudo construir ruedas para adormecer que use PEP 517 y no se puede instalar directamente  ( Error could not build wheels for numpy which use pep 517 and cannot be installe ) 
He estado tratando de instalar adormecidos en mi configuración de Python en una junta de Galileo durante aproximadamente una semana, y este es el último error...

11  Error al instalar Scrapy en Ubuntu 13.04  ( Error when installing scrapy on ubuntu 13 04 ) 
Cuando intento instalar Scrapy en Ubuntu 13.04 con el comando sudo easy_install -U Scrapy , obtengo el siguiente error: Searching for Scrapy Reading pypi....

2  ImportError: no se puede importar el nombre httpshandler instalar get-pip.py  ( Importerror cannot import name httpshandler installing get pip py ) 
Estoy recibiendo este error cuando intento instalar PIP2.7. Tengo Python 2.7 como mi predeterminado, pero no estoy seguro de por qué estoy obteniendo esto. ...

3  ¿Qué significa do = y == etc. al especificar números de versión de PAILES DE CONDA y PIP en archivos YAML  ( What do and etc mean when specifying conda and pip package version numbers ) 
Utilizamos archivos YAML para especificar nuestros entornos de Conda y PIP. En ellos podemos especificar qué números de versión necesitamos usar, por ejemplo,...

129  PIP Instale Fallating con: OSERROR: [ERRNO 13] Permiso denegado en el directorio  ( Pip install failing with oserror errno 13 permission denied on directory ) 
pip install -r requirements.txt falla con la excepción a continuación OSError: [Errno 13] Permission denied: '/usr/local/lib/... . ¿Qué pasa y cómo arreglo...

14  Cómo arreglar "ImportError: DLL Cargar Falló" Mientras se importan Win32api  ( How to fix importerror dll load failed while importing win32api ) 
Estoy configurando un autoclicker en Python 3.8 y necesito Win32api para GetaSynckeyState, pero siempre me da este error: >>> import win32api Traceback (mo...

6  ¿Implementando Django con VirtualEnv dentro de un paquete de distribución?  ( Deploying django with virtualenv inside a distribution package ) 
Tengo que implementar una aplicación DJANGO en un sistema SUSE Linux Enterprise 11. Las reglas corporativas dicen que necesito desplegar solo usando RPMS. Si ...

63  ImportError: no se puede importar el nombre HttpShandler usando PIP  ( Importerror cannot import name httpshandler using pip ) 
FUTAR UN ERROR HTTPSHANDLER Al instalar Paquetes de Python usando PIP, la siguiente es la traza de la pila, --------desktop:~$ pip install Django==1.3 Trac...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos