Pantalla en blanco con cursor en Hyper-V después de agregar escritorio a la instalación del servidor -- 16.04 campo con server campo con xubuntu campo con hyper-v camp askubuntu Relacionados El problema

Blank screen with cursor on Hyper-V after adding desktop to server install


0
vote

problema

Español

Uso de Hyper-V, instalé Ubuntu Server 16.04.3 LTS usando la opción HWE. Luego siguió los dos pasos de instalación aplicables enumerados en la Nota 5 en esta página . Luego ejecuto la actualización y actualizo.

Luego he corrido apt-get --no-install-recommends ubuntu-desktop . Reiniciando la computadora y luego resultó en una bota exitosa hasta que vi la pantalla de inicio de sesión de la línea de comando normal, que se convierte en una pantalla negra con un cursor parpadeante en la parte superior izquierda. Puedo usar Ctrl + Alt + F1 para obtener la interfaz de línea de comandos regular. He intentado iniciar sesión y luego iniciar el servicio LightDM, que resultó en la misma pantalla negra con un cursor parpadeante.

Secure Boot está habilitado y este es un Gen 2 VM. La configuración de VM es muy básica, prácticamente todo tiene configuraciones predeterminadas, excepto la plantilla de inicio segura y la memoria se ha establecido duro a 3000 MB. Estoy corriendo en una máquina de Windows 10.

Además, todo funciona correctamente si me instalo usando la ISO de escritorio en lugar del servidor ISO. Tengo un inicio de sesión de GUI de trabajo y puedo usar el escritorio normalmente. Entonces, mientras entiendo que puedo comenzar con el escritorio y la tira, estoy interesada principalmente en saber por qué está fallando (si es posible).

Me he vuelto a rehacer con varios cambios sin éxito. He intentado usar el I386 Server ISO, he intentado instalar el escritorio sin realizar actualizaciones o instalar los paquetes relacionados con VM, he intentado usar un Gen 1 VM, he intentado desordenar el adaptador de video RemoteFX 3D, I ' Se ha asegurado de que no se instalaran los controladores relacionados con NVIDIA de alguna manera, y lo intenté dejarlo durante más de 10 minutos para ver si algo era simplemente lento.

No tengo una comprensión completa de las sugerencias que he encontrado con respecto a startx , pero al ejecutar ese comando falla con un listado mencionado para Fatal Error no screens found . Al ejecutarlo de nuevo, en cambio me consigo

  unable to connect to X server: connection refused   

USO ABCDEFGHIJKLMNABCDEFGHIJKLMN4 ABCDEFGHIJKLMNABCDEFGHIJKLMN5 Resultados en

  blk_update_request: I/O error, dev sr0, sector 0   

Cualquier ayuda apreciada, gracias.

Original en ingles

Using Hyper-V, I installed Ubuntu Server 16.04.3 LTS using the HWE option. I then followed the two applicable install steps listed in Note 5 on this page. Afterwards I run update and upgrade.

Then I ran apt-get --no-install-recommends ubuntu-desktop. Restarting the computer then resulted in a successful boot until I saw the normal command line login screen which immediately turns into a black screen with a blinking cursor in the top left. I can use ctrl+alt+F1 to get the regular command line interface. I've tried logging in and then starting the lightdm service which resulted in the same black screen with a blinking cursor.

Secure boot is enabled and this is a gen 2 vm. The VM setup is very basic, pretty much everything has default settings except the secure boot template and the memory has been hard set to 3000MB. I'm running on a Windows 10 machine.

Additionally everything works correctly if I install using the desktop ISO instead of the server ISO. I have a working GUI login and can use the desktop normally. So while I understand that I can start with the desktop and strip stuff out, I'm primarily interested in knowing why it is failing (if possible).

I've retried with various changes unsuccessfully. I've tried using the i386 server iso, I've tried installing the desktop without performing upgrades or installing the VM related packages, I've tried using a Gen 1 VM, I've tried messing with RemoteFX 3D video adapter, I've made sure no nVidia related drivers were installed somehow, and I've tried leaving it for 10+ minutes to see if something was just slow.

I don't have a full understanding of the suggestions I've found regarding startx but when running that command it fails with a listing mentioned for Fatal Error no screens found. When running it again I instead get

unable to connect to X server: connection refused 

Using lspci -vnn | grep -i VGA sudo lshw -C dislay results in

blk_update_request: I/O error, dev sr0, sector 0 

Any help appreciated, thank you.

           

Lista de respuestas


Relacionados problema

1  Ubuntu 13.04 Corriendo dentro de la red Hyper-V Muy escamosa  ( Ubuntu 13 04 running within hyper v networking very flaky ) 
Estoy ejecutando Ubuntu 13.04 (había comenzado con 12.10) dentro de Hyper-V (Windows 8 Pro) en una computadora portátil Samsung Series 9. Tengo las interfaces...

0  Ubuntu 16.04 Hyper-V y eth1  ( Ubuntu 16 04 hyper v and eth1 ) 
Estoy ejecutando Ubuntu 16.04.1 LTS bajo Hyper-V. Al agregar una segunda NIC (eth1), al iniciar el host, el host toma la puerta de enlace de ETH1 como predete...

2  Conexión perdida cuando está habilitada IPv6 y accediendo a Apache  ( Connection lost when enabled ipv6 and accessing apache ) 
Estoy ejecutando Ubuntu Server 14.04.3 LTS en Hyper-V Server 2012 R2 con paquetes necesarios instalados apt-get install hv-kvp-daemon-init linux-tools-`una...

0  Ubuntu 18.04 LTS no puede obtener la dirección IP cuando está conectada directamente a Internet  ( Ubuntu 18 04 lts cannot get ip address when directly connected to the internet ) 
He estado jugando con Windows Hyper-V Server 2019 y básicamente tratando de crear mi propia nube. Lo extraño es que no puedo obtener Ubuntu 18.04 LTS & AMP;...

26  Resolución de visualización de huéspedes de Ubuntu Hyper-V Win 10 + 15.04  ( Ubuntu hyper v guest display resolution win 10 15 04 ) 
Tengo un Hyper-V en una superficie de Windows 10 y estoy usando Ubuntu 15.04 como un sistema operativo invitado. He cambiado con éxito la pantalla Ubuntu en u...

0  Conectividad a Internet para Ubuntu 14 en Hyper-V (Actualizado)  ( Internet connectivity for ubuntu 14 in hyper vupdated ) 
actualizado Estoy teniendo problemas de conectividad a Internet en mi máquina Virtual Ubuntu 14 Hyper-V Máquina virtual Mensaje de error de Internet ...

1  Hyper-V y Ubuntu 10.04 Apt-Get Update  ( Hyper v and ubuntu 10 04 apt get update ) 
Tengo problemas con los servidores 10.04 y 10.10. Estoy tratando de hacer apt-get update command , pero está atascado en conseguir . Hay algunas soluciones ...

14  Ubuntu 14.04 Desktop en Windows 8.1 Hyper-V  ( Ubuntu 14 04 desktop under windows 8 1 hyper v ) 
¿Es posiblemente acelerar los gráficos de Ubuntu 14.04 Desktop en Windows 8.1 Hyper-V AnyHow? Ya he disminuido la resolución de la pantalla y he deshabilita...

1  HV-KVP-DAEMON falla en Ubuntu 16.04 en Hyper-V  ( Hv kvp daemon fails in ubuntu 16 04 on hyper v ) 
Estoy tratando de automatizar el despliegue de Ubuntu 16.04 VMS en Hyper-V con Packer y PRESEED. En mi archivo PRESEED i instalo todas las dependencias requ...

0  Problema de red con Ubuntu 14.04.3 en Medio Ambiente Hyper V / No se está estable  ( Network issue with ubuntu 14 04 3 in hyper v environment not running stable ) 
Creo que tengo problemas con mi conexión de red en mis servidores 14.04.3 x64. ¿Qué pasó hasta ahora? Hace unos meses, instalé Ubuntu Server 14.04.1 en una ...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos