Actualización de la imagen Scikit de 0.10 a 0.13 -- 16.04 campo con scikit-learn camp askubuntu Relacionados El problema

upgradation of scikit image from 0.10 to 0.13


1
vote

problema

Español

Estoy trabajando en Ubuntu 16.04 con la versión de Python 2.7.

Paquete de imagen Scikit, así que está instalado es 0.10,

Quiero actualizar esto a 0.13.

¿Cómo puedo hacerlo?

Original en ingles

I am working on Ubuntu 16.04 with python 2.7 version.

Scikit image package so installed is 0.10,

I want to upgrade this to 0.13.

How can I do it?

     

Lista de respuestas

1
 
vote

Tienes dos opciones principales:

  1. Use Conda / anaconda

Uso de Conda / Anaconda podría ser la forma más fácil, si necesita trabajar con varios paquetes de Python.

  1. use PIP Instale

PIP le permite instalar un paquete específico, y también si lo desea, para elegir qué versión debe estar instalada.

Para verificar qué versión ya está instalada, debe ejecutarse:

  pip search scikit-learn   

En mi caso, la búsqueda devolvió mucha información, parte de ella es:

  scikit-learn (0.19.0)           - A set of python modules for machine learning and data mining   INSTALLED: 0.17.1   LATEST:    0.19.0   

Puede instalar la última versión de Scikit-Learn usando el siguiente comando:

  pip install -U scikit-learn   

Para instalar una versión específica del paquete, puede usar:

  pip install -Iv scikit-learn==0.13   

Scikit Site Instruction oficial de instalación

instalando la última versión

Scikit-Learn requiere:

  Python (>= 2.7 or >= 3.3), NumPy (>= 1.8.2), SciPy (>= 0.13.3).   

Si ya tiene una instalación de trabajo de NOMPY y SCIPY, la La forma más fácil de instalar Scikit-Learn es usar PIP

  ABCDEFGHIJKLMNABCDEFGHIJKLMN5   

o condA:

  conda install scikit-learn   

Si aún no ha instalado NOMPY o SCIPY, también puede instalar Estos usan condA o PIP. Al usar PIP, asegúrese de que Binary Se utilizan ruedas, y adormecidas y escapadas no están recompiladas de la fuente, lo que puede suceder cuando se utiliza configuraciones particulares de operación Sistema y hardware (como Linux en un PI de frambuesa). Amortiguador y Scipy de la fuente puede ser complejo (especialmente en Windows) y requiere una configuración cuidadosa para asegurarse de que vinculen contra un Implementación optimizada de rutinas de álgebra lineal. En su lugar, use un Distribución de terceros como se describe a continuación.

Si debe instalar Scikit-Learn y sus dependencias con PIP, usted Puede instalarlo como Scikit-Learn [ALDEPS]. El caso de uso más común para Esto está en un archivo requisitos.txt utilizado como parte de una compilación automatizada Proceso para una aplicación de PAA o una imagen de Docker. Esta opción no es destinado a la instalación manual de la línea de comandos.

 

You have two major options:

  1. Use conda/anaconda

Using conda/anaconda might be the easiest way, if you need to work with several python packages.

  1. Use pip install

pip allows you to install a specific package, and also if you like, to choose which version should be installed.

To check which version is already install you should run:

pip search scikit-learn 

In my case, the search returned a lot of info, part of it is:

scikit-learn (0.19.0)           - A set of python modules for machine learning and data mining   INSTALLED: 0.17.1   LATEST:    0.19.0 

You can install the latest version of scikit-learn using the following command:

pip install -U scikit-learn 

In order to install a specific version of the package, you can use:

pip install -Iv scikit-learn==0.13 

scikit site official install instructions

Installing the latest release

Scikit-learn requires:

Python (>= 2.7 or >= 3.3), NumPy (>= 1.8.2), SciPy (>= 0.13.3). 

If you already have a working installation of numpy and scipy, the easiest way to install scikit-learn is using pip

pip install -U scikit-learn 

or conda:

conda install scikit-learn 

If you have not installed NumPy or SciPy yet, you can also install these using conda or pip. When using pip, please ensure that binary wheels are used, and NumPy and SciPy are not recompiled from source, which can happen when using particular configurations of operating system and hardware (such as Linux on a Raspberry Pi). Building numpy and scipy from source can be complex (especially on Windows) and requires careful configuration to ensure that they link against an optimized implementation of linear algebra routines. Instead, use a third-party distribution as described below.

If you must install scikit-learn and its dependencies with pip, you can install it as scikit-learn[alldeps]. The most common use case for this is in a requirements.txt file used as part of an automated build process for a PaaS application or a Docker image. This option is not intended for manual installation from the command line.

 
 
   
   
0
 
vote

Probé el siguiente comando:

  pip install --user --upgrade scikit-learn==0.15.1   (my required version)   

Pero esto puede resultar en un error si está utilizando cualquier entorno virtual por Python como venv o abcdefhijklmnabcdefghijklmn9 o abcdefhijklmnabcdefghijklmn10 . Para evitar el error, use el comando a continuación:

  scikit-learn (0.19.0)           - A set of python modules for machine learning and data mining   INSTALLED: 0.17.1   LATEST:    0.19.0 1  

Me he enfrentado al mismo problema, pero se resolvió con el comando posterior. No necesita usar el comando sudo también con PIP (solo para alertarlo, espero que también haya enfrentado un error al usar sudo con PIP). Espero que mi respuesta ayude.

Instalación de una versión diferente / Última versión Actualiza su versión para este módulo en particular. No hay disponible comando de actualización / actualización diferente. Si está disponible por favor, comparte. Gracias.

 

I tried the below command:

pip install --user --upgrade scikit-learn==0.15.1   (my required version) 

But this may result in error if you are using any virtual environment by python like venv or virtualenv or conda. In order to avoid the error, use the below command:

pip install --upgrade scikit-learn==0.13            (your required version) 

I have faced the same issue but resolved using the later command. You need not use the sudo command also with pip(just for alerting you, hope you have also faced an error using sudo with pip.) Hope my answer helps.

Installing a different/latest version upgrades your version for this particular module. No different upgrade/update command is available. If available please do share. Thanks.

 
 

Relacionados problema

2  Error al instalar Scikit-Learn en Ubuntu 16.04  ( Failed to install scikit learn in ubuntu 16 04 ) 
Estoy tratando de instalar Scikit-Learn en Ubuntu 16.04, pero hay un error cuando estoy tratando de instalar. Había instalado con éxito después de los paquete...

24  ImportError: No se llamó Módulo Sklearn  ( Importerror no module named sklearn ) 
He instalado Scikit-Learn On Siguiendo estos ¿Cómo resolver esto? ...

1  Instalación de Anaconda en la parte superior de otras versiones de software  ( Installing anaconda on top of other versions of software ) 
Puse una cantidad decente de trabajo en la instalación de un conjunto de aplicaciones relacionadas con la Ciencia de los Datos, como Ipython, Spyder, NOMPY y ...

1  Actualización de la imagen Scikit de 0.10 a 0.13  ( Upgradation of scikit image from 0 10 to 0 13 ) 
Estoy trabajando en Ubuntu 16.04 con la versión de Python 2.7. Paquete de imagen Scikit, así que está instalado es 0.10, Quiero actualizar esto a 0.13. ...

0  Error al instalar Scikitlearn  ( Error installing scikitlearn ) 
Estoy tratando de instalar Scikit Learning usando ABCDEFGHIJKLMNABCDEFGHIJKLMN5 Pero no se instala. Intenté instalar al principio Nombrado y Scipy, pero...

0  Instalación de Scikit-Learn con Python3, _superlu.cpython-34m.so: símbolo no definido: DTRSM_  ( Installing scikit learn with python3 superlu cpython 34m so undefined symbol ) 
Estoy usando Ubuntu 14.04 e intentando instalar scikit-learn usando python 3. y me encuentro con el siguiente error: In [4]: import sklearn Produce: ...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos