Git: depende: liberror-perl pero no está instalable -- xubuntu campo con repository camp askubuntu Relacionados El problema

git : Depends: liberror-perl but it is not installable


2
vote

problema

Español

mientras instala git usando:

  sudo apt-get install git   

obtuve los siguientes errores:

  Reading package lists... Done Building dependency tree        Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:  The following packages have unmet dependencies:  git : Depends: liberror-perl but it is not installable E: Unable to correct problems, you have held broken packages.   
Original en ingles

While installing git using:

sudo apt-get install git 

I got the below errors:

Reading package lists... Done Building dependency tree        Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:  The following packages have unmet dependencies:  git : Depends: liberror-perl but it is not installable E: Unable to correct problems, you have held broken packages. 
     
   
   

Lista de respuestas

2
 
vote

Pregunta antigua con una nueva respuesta.

El problema no siempre está relacionado con unsupported releases NOR ABCDEFGHIJKLMNABCDEFGHIJKLMNABCDEFGHIJKLMN5 Artículos. De hecho, la lista de fuentes incompletas está disponible en su sistema. Actualice el ABCDEFGHIJKLMNABCDEFGHIJKLMN6 , en mi caso usando stretch to:

  ABCDEFGHIJKLMNABCDEFGHIJKLMN8   

Puede comentar la ABCDEFGHIJKLMNABCDEFGHIJKLMN9 LÍNEAS Si no es necesario, luego haga el estándar ABCDEFGHIJKLMNABCDEFGHIJKLMN10 y Go!

 

Old question with a new answer.

The problem is not always related to unsupported releases nor non installable items. Indeed is incomplete source list available on your system. Update the /etc/apt/sources.list, in my case using stretch to:

deb http://deb.debian.org/debian stretch main contrib non-free deb-src http://deb.debian.org/debian stretch main contrib non-free  deb http://deb.debian.org/debian-security/ stretch/updates main contrib non-free deb-src http://deb.debian.org/debian-security/ stretch/updates main contrib non-free  deb http://deb.debian.org/debian stretch-updates main contrib non-free deb-src http://deb.debian.org/debian stretch-updates main contrib non-free 

You can comment the deb-src lines if not needed, then do the standard apt update and go!

 
 

Relacionados problema

2  Paquete más nuevo del repositorio de otra versión de Ubuntu [Duplicar]  ( Newer package from repository of other ubuntu version ) 
Esta pregunta ya tiene una respuesta aquí : Paquetes de instalación de la versión más reciente sin e...

4  ¿Cómo configurar Apt para acceder a un repositorio de DEB sobre SSH?  ( How to configure apt to access a deb repository over ssh ) 
Tengo un repositorio de DEB accesible con SSH (siguiendo las instrucciones de este sitio ). Utilizo la autenticación basada en la clave pública SSH para acce...

5  ¿Es el universo revisado por el equipo de seguridad de Ubuntu?  ( Is universe checked by the ubuntu security team ) 
Tengo una pregunta general con respecto al repositorio del Universo de Ubuntu. ¿Alguien sabe si está revisado por el equipo de seguridad de Ubuntu? ¿Moverán o...

2  Error agregando un repositorio a /etc/apt/sources.list  ( Error adding a repository to etc apt sources list ) 
en Ubuntu 14.04, seguí http: //mirror.its. dal.ca/cran/bin/linux/ubuntu/README que dice ABCDEFGHIJKLMNABCDEFGHIJKLMN8 así en https://launchpad.net/ub...

5  Fuentes específicas del país. ¿Archivo de la lista?  ( Country specific sources list file ) 
Estaba tratando de configurar el repositorio local, así que hice algunas entradas que comentan y algunas de ellas eliminadas. Ahora no quiero crear un reposit...

1  ¿Cómo solucionar el error de GPG / BADSIG mientras ejecuta APT-Get Update? [duplicar]  ( How to fix gpg error badsig while running apt get update ) 
Esta pregunta ya tiene respuestas aquí : Cerrado hace 9 años . posible duplicado: ¿Cuál es...

213  ¿Cómo puedo obtener apto para usar un espejo cerca de mí, o elegir un espejo más rápido?  ( How can i get apt to use a mirror close to me or choose a faster mirror ) 
Descarga del Archivo principal de Ubuntu es lento incluso cuando no es día de lanzamiento, ¿cómo puedo obtener apt-get, para usar automáticamente un espejo qu...

11  Límite apt repo a un cierto arco?  ( Limit apt repo to a certain arch ) 
Tengo varios repositorios que no tienen binarios ARBHF (para el compilador cruzado RPI), por lo que ABCDEFGHIJKLMNABCDEFGHIJKLMN0 siempre me da una tonelada...

158  ¿Cómo restaño los repositorios predeterminados?  ( How do i restore the default repositories ) 
Ahora hay errores al actualizar y no puedo instalar la mayoría de los software debido a un corrupto /etc/apt/sources.list archivo. ¿Hay una copia que p...

25  ¿Son las listas de repositorios seguras? ¿Hay una versión HTTPS?  ( Are repository lists secure is there an https version ) 
¿Son seguros las actualizaciones del repositorio? Como un oso de poco cerebro del lado del desarrollador, no puedo entender por qué la lista del repositorio...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos