Autoralma e instale el bucle en paquetes -- apt camp askubuntu Relacionados El problema

Autoremove and Install loop on packages


0
vote

problema

Español

Estoy viendo a Ubuntu que requiere instalar y luego desinstalar 4 paquetes como un bucle. Aquí hay algunos resultados de la consola:

  Failed to start gunicorn.service:  Unit gunicorn.service failed to load: No such file or directory. 0  

ignorar los paquetes Kodi, no tengo prisa por pasar de 16.1 a 17.0.

Notas: No estoy listando ABCDEFGHIJKLMNABCDEFGHIJKLMN11 Es lo que usted esperaría. Si hago clic para instalar dichos paquetes, luego eliminar automáticamente me pedirá que los elimine. Creo que este problema apoyó después de desinstalar el paquete NexCloud-Client en el PPA anterior y lo reinstaló desde SiguienteCloud-Dev PPA, pero no estoy seguro.

¿Alguna idea sobre lo que debería hacer para arreglar esto?

Editar - Actualizar:

Con respecto al 1er comentario, en el mismo terminal que dio los resultados anteriores:

  Failed to start gunicorn.service:  Unit gunicorn.service failed to load: No such file or directory. 2  

también:

  Failed to start gunicorn.service:  Unit gunicorn.service failed to load: No such file or directory. 3  

hm, esto parece estar relacionado con Kodi, tal vez esos paquetes son necesarios para 17.0?

Original en ingles

I am seeing ubuntu requiring to install and then uninstall 4 packages as a loop. Here is some output from the console:

$ sudo apt autoremove Reading package lists... Done Building dependency tree        Reading state information... Done 0 to upgrade, 0 to newly install, 0 to remove and 2 not to upgrade. $ sudo apt upgrade Reading package lists... Done Building dependency tree        Reading state information... Done Calculating upgrade... Done The following packages were automatically installed and are no longer required: libcec4 libp8-platform2 libva-drm1 Use 'sudo apt autoremove' to remove them. The following NEW packages will be installed   libcec4 libp8-platform2 libva-drm1 The following packages have been kept back:   kodi kodi-bin 0 to upgrade, 3 to newly install, 0 to remove and 2 not to upgrade. Need to get 229 kB of archives. After this operation, 777 kB of additional disk space will be used. Do you want to continue? [Y/n] n Abort. 

Ignore Kodi packages, I m not in a hurry to go from 16.1 to 17.0.

Notes: I m not listing sudo apt update It's what you would expect. If I click to install said packages, then auto remove will ask me to delete them. I think this issue propped up after I uninstalled nexcloud-client package from the previous ppa and re-installed it from nextcloud-dev ppa but I'm not sure.

Any thoughts on what I should do to fix this?

edit - update:

Regarding the 1st comment, on the same terminal that gave the above results:

sudo apt-mark manual libcec4 libcec4 can not be marked as it is not installed. 

Also:

$ apt-cache policy libcec4 libcec4:   Installed: (none)   Candidate: 4.0.1.1~xenial   Version table:      4.0.1.1~xenial 500         500 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial/main amd64 Packages 

Hm, This appears to be related to kodi, maybe those packages are required for 17.0?

  
         
         

Lista de respuestas

0
 
vote
vote
La mejor respuesta
 

Siguiendo la sugerencia de @ User535733 I Configure los paquetes ofensivos para manual escribiendo

  sudo apt-mark manual libcec4 libp8-platform2 libva-drm1   

P.s. Podría mejorar a Kodi17 para ver qué pasaría entonces, pero no tengo tiempo para aprender la nueva interfaz y reconfigurarlo para mi uso de mi uso.

 

Following @user535733 's suggestion I set the offending packages to manual by typing

sudo apt-mark manual libcec4 libp8-platform2 libva-drm1 

P.S. I could dist-upgrade to kodi17 to see what would happen then but I don't have the time to learn the new interface and reconfigure it for my use-case yet.

 
 

Relacionados problema

2  Error agregando un repositorio a /etc/apt/sources.list  ( Error adding a repository to etc apt sources list ) 
en Ubuntu 14.04, seguí http: //mirror.its. dal.ca/cran/bin/linux/ubuntu/README que dice ABCDEFGHIJKLMNABCDEFGHIJKLMN8 así en https://launchpad.net/ub...

1  El sistema se ha bloqueado, el terminal que muestra 'configuración de la caja de inicio segura'  ( System has crashed terminal showing configuring secure boot box ) 
Intenté actualizar XFCE Desktop con - sudo apt-get upgrade xfce4 Por razones desconocidas, el proceso no se completó. Después de eso cuando intenté emi...

1  / usr / local / bin / Bower: No hay dicho archivo o directorio después de reinstalar node.js y Bower  ( Usr local bin bower no such file or directory after reinstalling node js and b ) 
Reinstalé nodejs ( node , abcdefhijklmnabcdefghijklmn6 ) Debido a una antigua configuración corruptida. De lo que instalé bower ABCDEFGHIJKLMNABCDEFGH...

0  APT "Falló la conexión"  ( Apt connection failed ) 
Desde la instalación de Ubuntu, no he podido instalar nuevos paquetes, incluso se ha podido actualizar. A continuación se muestra un volcado de error de conex...

5  ¿Equivalente a la historia de Yum?  ( Equivalent to yum history ) 
¿Hay un equivalente a yum history en Ubuntu? Soy consciente de que puedo mirar los registros de Apt, pero estoy buscando algo que lo enumere a todos en la l...

9  Fusionar múltiples archivos MP4 en un solo video a través del terminal [duplicado]  ( Merge multiple mp4 files into a single video via the terminal ) 
Esta pregunta ya tiene respuestas aquí : ¿Qué software puede unirse a los videos? ...

1  No se puede instalar Lázarus IDE en Ubuntu 10.04  ( Cannot install lazarus ide on ubuntu 10 04 ) 
He descargado archivos * .DEB de la página de inicio de Lázaro y usé sudo dpkg -i *.deb en la carpeta Lázarus. Se instaló, pero no se pudo correr debid...

3  No se pueden instalar controladores para mi tarjeta WiFi Realtek RTL8723BE en Ubuntu 16.10  ( Cannot install drivers for my realtek rtl8723be wifi card in ubuntu 16 10 ) 
intentado $ sudo add-apt-repository ppa:hanipouspilot/rtlwifi $ sudo apt-get update $ sudo apt-get install rtlwifi-new-dkms linux-firmware pero dand...

1  GNOME-Software Manager permaneciendo en RAM cuando se cerró Xubuntu 16.04  ( Gnome software manager staying in ram when closed xubuntu 16 04 ) 
Voy a ejecutar ABCDEFGHIJKLMNABCDEFGHIJKLMN0 3.20.1 A continuación, cierre el programa. Sin embargo, el proceso del programa no se cierra, y toma un trozo d...

1  ¿Cuáles son los distintos 'anuncios' o 'ANTICIOS' para las actualizaciones de los paquetes?  ( What are the various announcements or notices for package updates ) 
Recientemente, me encontré con USN - Ubuntu Security Notices y DSA - Debian Security anuncian y descubrí que estas son las listas de correo para las actualiza...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos