¿Listar dependencias de todos los paquetes instalados en Ubuntu 16.04? [duplicar] -- dependencies camp askubuntu Relacionados El problema

list dependencies of all packages installed in ubuntu 16.04? [duplicate]


0
vote

problema

Español
Esta pregunta ya tiene respuestas aquí :
Cómo enumerar todos los paquetes instalados como dependencias En la terminal, ¿y qué los instaló? (3 respuestas)
cerrado hace 3 años .

He leído que Apt-Cache depende enumera las dependencias en Package_Name, sin embargo, ¿es una forma en que puedo enumerar todas las dependencias de todos los paquetes en un solo comando (algo así como, apt-cache depende de todos)? Gracias de antemano.

Original en ingles

I have read that apt-cache depends lists out the dependencies on package_name,however, is there a way I can list out all the dependencies of all the packages in a single command ( something like, apt-cache depends all ) ? Thanks in advance.

  

Lista de respuestas

2
 
vote

ABCDEFGHIJKLMNABCDEFGHIJKLMN3 . Tenga cuidado, tardará mucho y usará toda su CPU. Lo terminé a un archivo porque es una lista muy larga. La primera parte de la tubería proporciona todos los paquetes instalados, la segunda parte se toma cada uno de ellos y busca sus dependencias.

 

apt list --installed | xargs apt-cache showpkg > dependencies.txt. Beware it will take long and use all your cpu. I piped it to a file because it is a very long list. The first part of the pipe provides all installed packages, the second part takes each one of them and looks for their dependencies.

 
 
1
 
vote

Encontré un Publicación del blog tratando de lograr lo que pediste y explicando cómo hacerlo.

Obviamente, no es un árbol trivial, pero más una galaxia de los nodos con malla:

Imagen de ejemplo de la dependencia del paquete

 

I found a blog post trying to achieve what you asked for and explaining how to do it.

It is obviously not a trivial tree but more a galaxy of meshed nodes:

example image of package dependency

 
 

Relacionados problema

0  Sudo apt-get -f Instale error GCC-6-Base  ( Sudo apt get f install error gcc 6 base ) 
No puedo instalar anualmente en mi compuerta, obteniendo este error, incluso si intento instalar sudo apt-get -f. Utilizando Ubuntu 17.04 64 bits dpkg: dep...

2  Dependencia rota libgcrypt11  ( Broken libgcrypt11 dependency ) 
He ejecutado un comando apt-get update && apt-get upgradeDefghijklmn8Defghijklmn8. El proceso completado (con un error): ABCDEFGHIJKLMNABCDEFGHIJKLMN9 a...

0  ¿Cómo instalar las dependencias de WebSocket ++?  ( How to install websocket dependencies ) 
Estoy tratando de desarrollar aplicaciones websocket en C ++. He elegido usar WebSocket ++ ya que es un ABCDEFGHIJKLMNABCDEFGHIJKLMN5 que no intenta retro...

2  12.04 Actualización MI SISTEMA  ( 12 04 upgrade hosed my system ) 
Desearía poder ser más específico. Instalé la actualización del administrador de actualizaciones y después de reiniciar la computadora, encontré que no podía ...

592  ¿Cómo resuelvo las dependencias no satisfechas después de agregar un PPA?  ( How do i resolve unmet dependencies after adding a ppa ) 
Ocasionalmente, cuando estoy instalando cosas, recibo un error como lo siguiente: Some packages could not be installed. This may mean that you have request...

3  No se puede instalar la oficina de WPS [duplicar]  ( Cannot install wps office ) 
Esta pregunta ya tiene respuestas aquí : e: paquete 'libpng12-0' no tiene Candidato de la instalació...

0  Las dependencias del paquete no se pueden resolver Ayuda [DUPLICADO]  ( Package dependencies cannot be resolved help ) 
Esta pregunta ya tiene respuestas aquí : ¿Cómo resuelvo las dependencias no satisfechas después de a...

2  LIBETPAN15 no está instalable al intentar instalar el Dock de El Cairo  ( Libetpan15 not installable when trying to install cairo dock ) 
Al agregar el Dock Cairo a Ubuntu 12.04, recibo este mensaje que me dice que necesito una dependencia. ¿Qué hago ahora para continuar con la instalación? T...

0  No se puede instalar nada debido al problema de dependencia  ( Unable to install anything due to dependency problem ) 
Este mensaje se muestra cada vez que intento instalar cualquier cosa. Por favor, buenas personas, cuento con Ubuntu. No puedo volver a Windows. Por favor ayu...

1  Instale Python2.7 Problemas de dependencias insatisfechas - Ubuntu 18.04  ( Install python2 7 unmet dependencies problems ubuntu 18 04 ) 
Recientemente limpio, reinstaló Ubuntu 18.04 y ahora quería instalar Python2.7 para varias otras dependencias, sin embargo, no puedo hacerlo. Correr sudo apt...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos