La compilación del kernel de CUDA falló -- vidia campo con cuda campo con 16.10 campo con blender camp askubuntu Relacionados El problema

CUDA kernel compilation failed


3
vote

problema

Español

Tengo GeForce 1070, Ubuntu-Studio 16.10 e instaló CUDA 8 (desde aquí: https: // desarrollador .nvidia.com / CudA-Toolkit ). También instalo g ++ 5 y hago simlink

LN -S / USR / BIN / GCC-5 / USR / LOCAL / CUDA / BIN / GCC

Pero cuando intento hacer modelo en Blender, obtuve una pila de mensajes después de "Compilar Cuda Kernel". Todos los registros (Ejecutar desde la consola)

  crystal@ustudio:~$ blender connect failed: No such file or directory Read new prefs: /home/crystal/.config/blender/2.77/config/userpref.blend Cannot connect to server socket err = No such file or directory Cannot connect to server request channel jack server is not running or cannot be started JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock AL lib: (WW) ALCjackBackendFactory_init: jack_client_open() failed, 0x11 AL lib: (WW) alc_initconfig: Failed to initialize backend "jack" read blend: /home/crystal/Downloads/BMW27.blend skipping driver '-90*brake', automatic scripts are disabled skipping driver '100*power', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '100*power', automatic scripts are disabled skipping driver '-90*brake', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '-90*brake', automatic scripts are disabled skipping driver '100*power', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '100*power', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '-90*brake', automatic scripts are disabled skipping driver '100*power', automatic scripts are disabled skipping driver '-90*brake', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '100*power', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '-90*brake', automatic scripts are disabled CUDA version 8.0 detected, build may succeed but only CUDA 7.5 is officially supported. Compiling CUDA kernel ... "/usr/local/cuda/bin/nvcc" -arch=sm_61 -m64 --cubin "/usr/share/blender/scripts/addons/cycles/kernel/kernels/cuda/kernel.cu" -o "/home/crystal/.config/blender/2.77/cache/cycles_kernel_sm61_19BAB894867FFAFF2ADC00F401D5E4EB.cubin" --ptxas-options="-v" --use_fast_math -I"/usr/share/blender/scripts/addons/cycles/kernel" -DNVCC -D__KERNEL_CUDA_VERSION__=80 /usr/share/blender/scripts/addons/cycles/kernel/kernels/cuda/kernel.cu:94:2: error: #error "Unknown or unsupported CUDA architecture, can't determine launch bounds"  #error "Unknown or unsupported CUDA architecture, can't determine launch bounds"   ^ /usr/share/blender/scripts/addons/cycles/kernel/kernels/cuda/kernel.cu:112:87: error: division by zero in #if  #if CUDA_MULTIPRESSOR_MAX_REGISTERS/(CUDA_THREADS_BLOCK_WIDTH*CUDA_THREADS_BLOCK_WIDTH*CUDA_KERNEL_MAX_REGISTERS) > CUDA_MULTIPROCESSOR_MAX_BLOCKS                                                                                        ^ CUDA kernel compilation failed, see console for details.  Refer to the Cycles GPU rendering documentation for possible solutions: http://www.blender.org/manual/render/cycles/gpu_rendering.html  skipping driver '100*power', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '-90*brake', automatic scripts are disabled Error: CUDA kernel compilation failed, see console for details.   

Blender --version
Blender 2.77 (Sub 0)

¿Cómo arreglarlo? Gracias de antemano.

Original en ingles

I have geforce 1070, ubuntu-studio 16.10 and installed CUDA 8 (from here: https://developer.nvidia.com/cuda-toolkit). I also install g++ 5 and make symlink

ln -s /usr/bin/gcc-5 /usr/local/cuda/bin/gcc

but when i try to render model in blender, i got a stack of messages after "Compile CUDA kernel". All log (run from console)

crystal@ustudio:~$ blender connect failed: No such file or directory Read new prefs: /home/crystal/.config/blender/2.77/config/userpref.blend Cannot connect to server socket err = No such file or directory Cannot connect to server request channel jack server is not running or cannot be started JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock AL lib: (WW) ALCjackBackendFactory_init: jack_client_open() failed, 0x11 AL lib: (WW) alc_initconfig: Failed to initialize backend "jack" read blend: /home/crystal/Downloads/BMW27.blend skipping driver '-90*brake', automatic scripts are disabled skipping driver '100*power', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '100*power', automatic scripts are disabled skipping driver '-90*brake', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '-90*brake', automatic scripts are disabled skipping driver '100*power', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '100*power', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '-90*brake', automatic scripts are disabled skipping driver '100*power', automatic scripts are disabled skipping driver '-90*brake', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '100*power', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '-90*brake', automatic scripts are disabled CUDA version 8.0 detected, build may succeed but only CUDA 7.5 is officially supported. Compiling CUDA kernel ... "/usr/local/cuda/bin/nvcc" -arch=sm_61 -m64 --cubin "/usr/share/blender/scripts/addons/cycles/kernel/kernels/cuda/kernel.cu" -o "/home/crystal/.config/blender/2.77/cache/cycles_kernel_sm61_19BAB894867FFAFF2ADC00F401D5E4EB.cubin" --ptxas-options="-v" --use_fast_math -I"/usr/share/blender/scripts/addons/cycles/kernel" -DNVCC -D__KERNEL_CUDA_VERSION__=80 /usr/share/blender/scripts/addons/cycles/kernel/kernels/cuda/kernel.cu:94:2: error: #error "Unknown or unsupported CUDA architecture, can't determine launch bounds"  #error "Unknown or unsupported CUDA architecture, can't determine launch bounds"   ^ /usr/share/blender/scripts/addons/cycles/kernel/kernels/cuda/kernel.cu:112:87: error: division by zero in #if  #if CUDA_MULTIPRESSOR_MAX_REGISTERS/(CUDA_THREADS_BLOCK_WIDTH*CUDA_THREADS_BLOCK_WIDTH*CUDA_KERNEL_MAX_REGISTERS) > CUDA_MULTIPROCESSOR_MAX_BLOCKS                                                                                        ^ CUDA kernel compilation failed, see console for details.  Refer to the Cycles GPU rendering documentation for possible solutions: http://www.blender.org/manual/render/cycles/gpu_rendering.html  skipping driver '100*power', automatic scripts are disabled skipping driver '90*brake', automatic scripts are disabled skipping driver '-100*power', automatic scripts are disabled skipping driver '-90*brake', automatic scripts are disabled Error: CUDA kernel compilation failed, see console for details. 

blender --version
Blender 2.77 (sub 0)

How to fix it? Thanks in advance.

           
       
       

Lista de respuestas

0
 
vote
vote
La mejor respuesta
 

Esto funcionó para mí en Blender 2.76B (Ubuntu 16.04)

  1. abre kernel.cu

ABCDEFGHIJKLMNABCDEFGHIJKLMN5

  1. Encuentra la línea que se parece a esto:

ABCDEFGHIJKLMNABCDEFGHIJKLMN6

ABCDEFGHIJKLMNABCDEFGHIJKLMN7

Puede ser ligeramente diferente, pero debe comenzar con #elif __CUDA_ARCH___ ==

  1. Cambia esa línea a: ABCDEFGHIJKLMNABCDEFGHIJKLMN9

Esto permitirá que Blender compile las nuevas arquitecturas de CUDA. Puede que no funcione como se esperaba, y probablemente obtendrá advertencias la primera vez que lo ejecute (a medida que compila), pero ya no obtendrá el error de compilación. Además, esto está funcionando para mí en Ubuntu 16.04 con Blender 2.76b y CUDA 8.0

 

This worked for me on Blender 2.76b (Ubuntu 16.04)

  1. Open kernel.cu

sudo gedit /usr/share/blender/scripts/addons/cycles/kernel/kernels/cuda/kernel.cu

  1. Find the line that looks something like this:

/* 5.0 and 5.2 */

#elif __CUDA_ARCH__ == 500 || __CUDA_ARCH__ == 520

It may be slightly different, but should start with #elif __CUDA_ARCH___ ==

  1. Change that line to: #elif __CUDA_ARCH__ >= 500

This will allow Blender to compile for newer CUDA architectures. It may not work as expected, and you'll probably get warnings the first time you run it (as it compiles), but you won't get the compile error any more. Also, this is working for me on Ubuntu 16.04 with Blender 2.76b and CUDA 8.0

 
 
   
   
0
 
vote

Instalar G ++ 5 resuelve el problema. Por favor, use el siguiente comando:

  xinput set-prop 'Name Of Your Mouse' 'Coordinate Transformation Matrix' 3 0 0 0 3 0 0 0 10  
 

Install G++ 5 solves the problem. Please use the following command:

sudo apt install g++-5 
 
 
0
 
vote

Estoy usando Blender 2.78 con Ubuntu 17.04 y CUDA 8.0:

  • Instalación de G ++ 5 no funcionó
  • Cambiar Kernel.cu no funcionó (Blender 2.78 ya tiene el cambio)

Pero esto funcionó:

  1. Run Blender en modo sudo con "sudo blender". La representación con GPU cargó los núcleos y la representación trabajada
  2. Luego, ejecute la licuadora normalmente (no sudo) y la representación de GPU ahora funciona
 

I'm using Blender 2.78 with Ubuntu 17.04 and CUDA 8.0:

  • installing g++ 5 didn't work
  • change kernel.cu didn't work (Blender 2.78 already has the change)

But this worked:

  1. Run Blender in sudo mode with "sudo blender". Rendering with GPU loaded the kernels and the rendering worked
  2. Then run Blender normally (no sudo) and GPU rendering now works
 
 
0
 
vote

Según la página web de Blender a partir del 07-ABRIL-2020, Blender no es compatible con GCC 4.7 o superior ( https://docs.blender.org/manual/en/latest/render/cycles/gpu_rendering.html )

con * Bunutu 20.04, modifique el lanzador Blender.desktop a:

  xinput set-prop 'Name Of Your Mouse' 'Coordinate Transformation Matrix' 3 0 0 0 3 0 0 0 11  

El comando anterior iniciará la licuadora la configuración del compilador compatible con 20.04. La 1ª GPU renderiza unos minutos para compilar el Renderizador de CUDA, pero los rendimientos posteriores se ejecutarán de inmediato. La representación de NVIDIA 1080 CUDA fue de 6X más rápido que mi antigua CPU 4771 solo.

 

As per the blender web page as of 07-April-2020, blender is not compatible with gcc 4.7 or higher (https://docs.blender.org/manual/en/latest/render/cycles/gpu_rendering.html)

With *bunutu 20.04, modify the blender.desktop launcher to:

CYCLES_CUDA_EXTRA_CFLAGS="-ccbin clang-8" blender 

The above command will launch blender the compiler settings compatible with 20.04. The 1st GPU render requires a few minutes to compile the CUDA renderer, but afterward renders will run immediately. NVidia 1080 CUDA rendering was 6x faster than my old 4771 CPU alone.

 
 

Relacionados problema

1  Importar archivo MP4 en Blender  ( Import mp4 file in blender ) 
Instalé la licuadora para editar mis videos con formato MP4, pero cuando comencé IMPORT ARCHIFICES, Blender, muéstrame este error: "¡El archivo no se pudo car...

4  Blender distorsionado ui  ( Blender distorted ui ) 
Acabo de descargar la última versión de Blender desde el sitio web a mi máquina Xubuntu, cuando lo abro, obtengo esto: La captura de pantalla a continuación ...

3  Blender 2.5 Render no exportará sonido  ( Blender 2 5 render will not export sound ) 
He probado varios formatos, pero mi animación de licuadora no tendrá sonido. En Blender, juega bien cuando presiono el botón de reproducción, pero no hay soni...

5  Glibcxx_3.4.15 no encontrado  ( Glibcxx 3 4 15 not found ) 
Cuando intento ejecutar Blender Builds de graphicall.org (11.04 Natty 64-bit), obtengo el siguiente mensaje: ./blender: /usr/lib/x86_64-linux-gnu/libstdc++...

0  ¿Qué tipo de fuentes se pueden poner en Natrones u otros compositores para Linux?  ( What kind of sources can be put into natron or other compositors for linux ) 
Leí el artículo sobre la composición en Wikipedia y algunas otras páginas aleatorias, pero todavía tengo una pregunta abierta. Sé seguro, que el tipo de fuent...

3  Exportación de archivos .Blend usando ogrexml  ( Exporting blend files using ogrexml ) 
Mi pregunta es una simple esta vez: ¿Cómo puedo exportar archivos de glends usando OGREXML en UBUNTU 12.04 (x64)? He instalado Blender-ogrexml, pero ¿cómo lo ...

1  "No se puede abrir el archivo userpref.blend @ para escribir: Permiso denegado" en Blender  ( Cannot open file userpref blend for writing permission denied in blender ) 
Estoy usando Blender 2.69, instalado a través del centro de software, y cuando guardo la preferencia de usuario a través del archivo - & gt; Preferencias de u...

0  ¿Por qué la licuadora no tiene ciclos procesados?  ( Why blender has no cycles render built in ) 
No hay ciclos render en la licuadora. Y no hay soporte de aceleración de OpenCl y CudA. Por favor, mejore esto y actualice el repositorio (Blender 2.63) ...

3  Desactive todos los atajos de teclado, excepto por la pestaña Alt + en el programa  ( Disable all keyboard shortcuts except for alttab in program ) 
Estoy tratando de usar la licuadora de software 3D en Ubuntu y el software es un atajo de teclado muy pesado. El problema es que muchos de los atajos de tecla...

15  ¿Es la licuadora buena como una herramienta CAD?  ( Is blender good as a cad tool ) 
por ejemplo para la ingeniería mecánica; ¿De lo que he visto, Blender es bastante flexible y poderoso, así que tal vez sirve bien para esto también? ...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos