Tratando de actualizar desde 14.04 lts a 15.10, no funciona debido a los "paquetes rotos" -- 14.04 campo con apt campo con upgrade campo con updates campo con 15.10 camp askubuntu Relacionados El problema

Trying to upgrade from 14.04 LTS to 15.10, not working due to “broken packages”


0
vote

problema

Español


Estoy escribiendo esto mientras estoy realmente cansado, así que, por favor, soporta conmigo mientras intentas explicar mis problemas aquí :)
Estoy tratando de actualizar a 15.10 de 14.04 LTS.
He hecho alguna solución básica de problemas buscando por todas horas en Google durante horas. Entonces, ¿qué he hecho?
1. He hecho sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade al menos 10 - 15 veces
2. He ido al directorio ABCDEFGHIJKLMNABCDEFGHIJKLMN6 en el ABCDEFGHIJKLMNABCDEFGHIJKLMN7 A LAS PAQUETES BURICOS ... Digamos que la lista contiene 50 paquetes, donde como Noté algo extraño de ellos. La mayoría de ellos se enumeran como "rotos" allí porque una versión de 64 bits depende de una versión de 32 bits del mismo programa. A lo cual pasé por lo menos 25 de esos casos (solo mirar, no hacer nada), y después de eso vi el patrón. La mayoría de los casos, si no todos los casos (la duda) eran así.
3. He marcado todos los PPA que he agregado yo mismo, y luego eliminé todos los conductores de NVIDIA (un ventilador en mi tarjeta gráfica se rompió y comenzó a vibrar mi lecho a bits), pensé que tal vez los ayudarían, pero Lamentablemente no lo hizo.
Mientras eliminan los programas, pensé que debería hacer un sudo apt-get autoremove && sudo apt-get autoclean && sudo apt-get purge para ver si se le quitaría, y eso fue alrededor de 50 paquetes (creo). Ahora, tengo una cantidad decente de pasta para adherirme aquí, así que fui a pastebin y pegado pegado allí en su lugar

Todavía nada funciona, así que aquí les estoy pidiendo ayuda a esta comunidad y, con suerte, podamos obtener este enigma resuelto :)

vítores

/ f4rm0r

Editar: Como resulta que 16.04 está a la vuelta de la esquina, y como me había olvidado completamente de buscarlo (debido a estar cansado), ahora he decidido que esperaré aproximadamente 4 semanas para que se libere adecuadamente. ¡Gracias por todas sus sugerencias hasta ahora, apreciadas! :)

Original en ingles


I am writing this while I am really tired, so please, bear with me while trying to explain my troubles here :)
I am trying to update to 15.10 from 14.04 LTS.
I have done some basic troubleshooting by searching all over on google for hours. So what have I done?
1. I have done sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade at least 10 - 15 times
2. I have gone in to the directory /var/log/dist-upgrade and checked in the apt.log in there after broken packages... let's just say that the list contains 50+ packages, where as I noticed some strange thing about them. Most of them are listed as "broken" in there because a 64-bit version depends on a 32-bit version of the same program. which I went through at least 25 of those cases (just looking, not doing anything), and after that I saw the pattern. Most cases, if not all cases (doubt it) were like that.
3. I have unmarked all the PPA's I've added by myself, and then removed all of the nvidia drivers (a fan on my graphics card broke and started to vibrate my MBoard to bits), I thought that maybe those would help, but sadly it did not.
While deleting programs I thought I should do some sudo apt-get autoremove && sudo apt-get autoclean && sudo apt-get purge to see if what would be taken away, and that was about 50+ packages (I think). now, I got a decent amount of paste to stick here, so I went over to pastebin and glued it stuck there instead

Still nothing works, so here I am asking this community for help, and hopefully we can get this riddle solved :)

Cheers

/ F4rm0r

Edit: As it turns out 16.04 is just around the corner, and as I had forgotten completely to look it up (due to being tired) I have now decided that I will wait approximately 4 weeks for it to be properly released. Thank you for all of your suggestions so far, appreciated! :)

              
   
   

Lista de respuestas

1
 
vote

Como se mencionó en la sección de comentarios, debe ejecutar el siguiente comando y luego publicar los errores si corresponde:

  sudo apt-get update; sudo apt-get install -y os-uninstaller && os-uninstaller 9  

Se debe tener en cuenta que esta es una forma real real de actualizar a una nueva versión. No puedo decir que no lo hago yo mismo, ya que viene con ventajas, pero la gestión de paquetes rotos, si se debe esperar al menos temporal. Si el comando anterior no funciona, publique los errores y vamos a ir desde allí.

También se debe tener en cuenta que esto puede no ser tan fácil, ya que hay una transición a Systemd que puede no poder manejar la APT.

Normalmente, debe ejecutar el siguiente comando para realizar la actualización:

  acroread0  

En unas pocas semanas, se lanzarán 16.04 y luego ejecutaría lo siguiente en lugar:

  acroread1  

Es posible que tenga que esperar hasta entonces, ya que este es el próximo lanzamiento de LTS y, por lo tanto, se debe esperar una actualización de 14.04.

Como siempre, posiblemente considere un poco de sueño, ya que las cosas pueden parecer más fáciles en la mañana.

 

As mentioned in the comment section, you need to run the following command and then post the errors if any:

sudo apt-get -f install 

It should be noted that this is a real gutsy way to upgrade to a new version. I can't say that I don't do it myself as it does come with advantages but broken package management if at least temporary should be expected. If the above command doesn't work, post the errors and we will go from there.

It should also be noted that this may not be so easy as there is a transition to systemd that apt-get may not fully be able to handle.

Normally, you should run the following command to do the upgrade:

sudo do-release-upgrade -d 

In a few weeks, 16.04 will be released and then you would run the following instead:

sudo do-release-upgrade 

You may have to wait until then as this is the next LTS release and so an upgrade from 14.04 should be expected.

As always, possibly consider some sleep as things may seem more easy in the morning.

 
 
   
   

Relacionados problema

0  Dell XPS 13 (3950) VideoCard no funciona  ( Dell xps 13 3950 videocard not working ) 
Soy un poco nuevo para esto, así que soporta conmigo si la publicación no sigue el formato correcto 100%. Tengo Ubuntu 15.10 instalado con el kernel 4.5RC3 ...

3  Comportamiento de enfoque de ventana extraño con Ubuntu 15.10 y GNOME  ( Strange window focus behavior with ubuntu 15 10 and gnome ) 
Estoy ejecutando Ubuntu 15.10 y ABCDEFGHIJKLMNABCDEFGHIJKLMN0 . Desde la actualización de 15.04, he notado que cuando hago doble clic en una ventana, esa ven...

0  Problema de dependencia Instalación de Dell OSAM en Ubuntu 15.10  ( Dependency problem installing dell osam on ubuntu 15 10 ) 
Tengo un problema simple con las dependencias. Quiero instalar un paquete de administración de servidor de Dell llamado OSAM en Ubuntu 15.10. Para la instal...

0  Lenovo ThinkPad L460 TouchPad no funciona  ( Lenovo thinkpad l460 touchpad not working ) 
Hoy recibí mi nuevo Lenovo ThinkPad L460. Así que instalé un Ubuntu fresco 15.10 en él y todo funcionó bien hasta que quería usar el TouchPad. No está funcion...

0  ¿Cómo cambiar la pantalla de bloqueo?  ( How to change lock screen ) 
I instalé KDE en Ubuntu 15.10, pero la pantalla de inicio de sesión es la que viene con la unidad. ¿Hay alguna forma de usar la pantalla de inicio de sesión d...

0  Problema con Ubuntu 15.10 después de la bota dual  ( Problem with ubuntu 15 10 after dual boot ) 
i Dual arrancó mi PC de Windows 10 con Ubuntu 15.10. Funcionó bien durante un par de semanas, pero ahora está detenido, me detiene con el sistema Ubuntu e ini...

7  Después de actualizar a 15.10 WiFi a una red corporativa (WPA2) ya no funciona  ( After upgrade to 15 10 wifi to a corporate network wpa2 is not working anymore ) 
El pasado viernes, actualizé a Ubuntu 15.10. En ese momento me conecté a una red corporativa con WiFi. Después de la actualización ya no funciona. Configura...

1  ¿Cómo puedo obtener un instalador Beta1 de Ubuntu 15.10 (Wily) (si estoy listo para probarlo)? [duplicar]  ( How can i get an ubuntu 15 10 wily beta1 installer if im ready to test it ) 
Esta pregunta ya tiene respuestas aquí : ¿Cómo puedo cambiar de 32 bits? Instalación a un de 64 bits...

0  Ubuntu 15.10 Editor predeterminado no funciona para los archivos remotos SFTP  ( Ubuntu 15 10 default editor doesnt work for sftp remote files ) 
Instalé un editor de texto diferente en Ubuntu 15.10, pero Nautilus (y NEMO) todavía abre archivos con GEDIT ... En las "Propiedades de archivo" - & gt; "Abri...

1  Iniciar OpenVPN como servicio Ubuntu 15.10  ( Start openvpn as a service ubuntu 15 10 ) 
Acabo de instalar Ubuntu 15.10 e instalé OpenVPN. Estoy usando los mismos archivos .conf como tuve en 14.x, sin embargo, el servicio no comenzará con sí mis...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos