¿Cómo obtener todos los paquetes enumerados en un PPA a la vez? -- 14.04 campo con ppa campo con gcc camp askubuntu Relacionados El problema

How to get all packages listed in a PPA at once?


1
vote

problema

Español

Por ejemplo, si hago:

  sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update sudo apt-get install gcc-5 g++-5   

Obtengo GCC-5, pero no GFORTRAN-5 o CPP-5 o cualquiera de los otros paquetes Listado aquí . ¿Cómo obtener todos esos paquetes a la vez?

Original en ingles

For example, if I do:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update sudo apt-get install gcc-5 g++-5 

I get gcc-5 but not gfortran-5 or cpp-5 or any of the other packages listed here. How to get all of those packages at once?

        

Lista de respuestas

1
 
vote
vote
La mejor respuesta
 

VIA Y-PPA-Manager

  while read -r word; do      sed -e "s/<$word>//g" -e '/^s*$/d' file2 -i;  done < file1 0  

  1. inicio y-ppa-manager y seleccione Administrar PPAS

    ingrese la descripción de la imagen aquí

  2. Seleccione su PPA y haga clic en Paquetes de lista

    ingrese la descripción de la imagen aquí

  3. Vea los paquetes e instale lo que necesita a través de instalar

    ingrese la descripción de la imagen aquí

 

Via Y-PPA-Manager

sudo add-apt-repository ppa:webupd8team/y-ppa-manager sudo apt-get update sudo apt-get install y-ppa-manager 

  1. Start Y-PPA-Manager and select Manage PPAs

    enter image description here

  2. Select your PPA and click List packages

    enter image description here

  3. See the packages and install what you need via Install

    enter image description here

 
 
2
 
vote

Este while read -r word; do sed -e "s/<$word>//g" -e '/^s*$/d' file2 -i; done < file1 1 pondrá todos los paquetes en un archivo de texto.

Puede editar este archivo manualmente para eliminar cualquier cosa no deseada y usar ese archivo para alimentarlo a ABCDEFGHIJKLMNABCDEFGHIJKLMN32 como while read -r word; do sed -e "s/<$word>//g" -e '/^s*$/d' file2 -i; done < file1 3 . Esta última parte probablemente será una mala idea sin confirmar que estos paquetes no están en conflicto con otros paquetes en el PPA.


La forma normal de hacer es escribirlos. Así que ...

  while read -r word; do      sed -e "s/<$word>//g" -e '/^s*$/d' file2 -i;  done < file1 4  

Después de echar un vistazo rápido a los paquetes para ver si pueden tener conflictos.

 

This awk '$1 == "Package:" { if (a[$2]++ == 0) print $2; }' /var/lib/apt/lists/*ubuntu-toolchain-r*test*Packages > to_install.txt will put all the packages into a text file.

You can manually edit this file to remove anything unwanted and use that file to feed it to apt-get like for i in $(cat to_install.txt); do sudo apt-get install $i; done. This last part will probably be a bad idea without confirming these packages are not conflicting with other packages in the PPA.


The normal way to do is write them out. So ...

sudo apt-get install gcc-5 g++-5 gfortran-5 gnat-5  

after having a quick look at the packages to see if they might have conflicts.

 
 
   
   

Relacionados problema

0  GCC no puede encontrar ansinist.h aunque esté allí en / usr / incude / ansinist  ( Gcc cannot find ansinist h even though it is there in usr incude ansinist ) 
Estoy tratando de hacer un programa proporcionado por NIST. No tengo mucha experiencia en tales tareas. Estoy recibiendo el siguiente error. util.c:19:22...

1  ¿Cómo instalo GCC-4.6 en Ubuntu 15.10 (Edición de 32 bits)  ( How do i install gcc 4 6 on ubuntu 15 10 32bit edition ) 
Cuando intento instalar GCC-4.6 en Ubuntu15.10 (edición de 32 bits) usando apt-get, pero no puedo. Lo probé, pero Ubuntu mostró estos mensajes de error: ...

2  Problema al compilar GCC en Ubuntu  ( Problem when compiling gcc in ubuntu ) 
Me he encontrado con el problema bien conocido al instalar GCC: configure:3605: error: in /usr/local/gcc-4.8.1/i686-pc-linux-gnu/libgcc': configure:3608: e...

22  ¿Cómo actualizar GCC a la última versión (en este caso 4.7) en Ubuntu 10.04?  ( How to update gcc to the latest versionin this case 4 7 in ubuntu 10 04 ) 
Tengo ubuntu 10.04 32 bits con gcc 4.4.3 actualmente instalado en él. Quiero actualizarlo a gcc/g++ 4.7 (estoy buscando soporte C ++ 0X) Cómo actualizar...

2  COLECCIÓN2: ERROR FATAL: No se puede encontrar la compilación 'LD' terminada  ( Collect2 fatal error cannot find ld compilation terminated ) 
Cuando intento ejecutar el programa C y C ++, estoy recibiendo dmesg0 Ya he instalado la última versión de GCC y G ++. ...

0  No se puede ejecutar Cudaminer en Jetson  ( Unable to run cudaminer on jetson ) 
Después de descargar y ejecutar ./autogen.sh y ./configure la ejecución del comando HACK le da el siguiente error en mi Jetson TK1 gcc -std = gnu99 -dhave_...

2  no se puede compilar GCC o G ++ libc_nonshared.a no reconocido  ( Cannot compile gcc or g libc nonshared a not recognized ) 
Ya no puedo compilar archivos C / C ++ ya que usando una nueva cuenta (creo que fue desde entonces) y estoy obteniendo un error extraño cada vez que intento c...

1  ¿Cómo construir la aplicación GUI en lenguaje C usando GTK +?  ( How to build gui application in c language using gtk ) 
He escrito código en lenguaje C usando GTK. Este código le da una ventana con 2 botones, pero no sé cómo hacer la aplicación GUI independiente de este código....

1  ¿Cómo instalo GCC 4.7.1 en 12.04?  ( How do i install gcc 4 7 1 on 12 04 ) 
Sugerencia que le sucede a un error en el GCC 4.7.0 de Ubuntu, que se ha solucionado en versiones posteriores de GCC; Creo que ya está arreglado en 4.7.1. ...

4  Eclipse no puede encontrar bibliotecas de índice de GCC o G ++  ( Eclipse cant find index libraries of gcc or g ) 
La instalación de las herramientas de CDT en Eclipse no puede encontrar en las bibliotecas de índice de GCC o G ++, pero el archivo se está ejecutando. Ex: ...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos