Problemas con el soporte ZIP en la compilación de Python personalizados: ZipImport.ZipimportError: no se pueden descomprimir los datos; zlib no disponible -- software-installation campo con pip camp askubuntu Relacionados El problema

Trouble with zip support in custom Python build: zipimport.ZipImportError: can't decompress data; zlib not available


1
vote

problema

Español

Miré aquí pero no estoy obteniendo mucho de la Respuesta:

Una gran razón para esto es porque soy un nuevo usuario de Linux y aún no he visto todos los comandos en acción. Tengo el mismo problema exacto que este tipo Pero todas las respuestas están demasiado avanzadas para mí En este momento, para entender qué es exactamente lo que necesito hacer.

Estoy usando Linux Ubuntu 14.04 y estoy tratando de generar un bloque de Génesis para jugar con Ethereum y Smart Contracts. Estoy siguiendo este tutorial y cuando estoy en el Punto de poner esto en mi consola:

  sudo python get-pip.py   

Obtengo este error:

  zipimport.ZipImportError: can't decompress data; zlib not available   

Es mi comprensión de que esto tiene que ver con Python que no se está construyendo con el soporte ZIP. Esto puede ser el caso, ya que no tenía idea de lo que estaba haciendo al intentar instalar Python. Lo que he hecho para tratar de resolver esto es instalar la última versión de Zlib y probarlo de nuevo, pero cuando lo intenté de nuevo, todavía tengo el mismo error. Reinstalé Python, y todavía estoy recibiendo el mismo error. Ahora, me estoy molestando. ¿Qué puedo hacer para solucionar este problema?

Original en ingles

I looked here but I am not getting a lot out of the answer:

A big reason for this is because I am a new Linux user and I haven't seen all the commands in action yet. I have the exact same problem as this guy but all the responses are too advanced for me right now to understand what exactly it is I need to do.

I am using Linux Ubuntu 14.04 and I am trying to generate a genesis block to play around with Ethereum and smart contracts. I'm following this tutorial and when I'm at the point of putting this in my console:

sudo python get-pip.py 

I get this error:

zipimport.ZipImportError: can't decompress data; zlib not available 

It is my understanding that this has to do with Python not being built with zip support. This may well be the case as I had no idea what I was doing when trying to install Python. What I have done to try and resolve this is to install the latest version of zlib and try it again, but when I tried it again, I still got the same error. I re-installed Python, and I'm still getting the same error. Now, I'm just getting annoyed. What can I do to fix this issue?

     
 
 

Lista de respuestas

3
 
vote
vote
La mejor respuesta
 

Parece que construyó su python usted mismo y no use la instalación predeterminada. Necesitas hacer estos pasos:

  1. Instalar el ABCDEFGHIJKLMNABCDEFGHIJKLMN4 La versión más reciente

  2. luego Complie Python de nuevo y ejecuta una línea

      ./configure --prefix=/root/Python-2.7.8 --with-zlib-dir=/usr/local/lib   
 

Looks like you built your Python yourself and not using the default installation. You need to do these steps:

  1. Install the zlib the newest version

  2. Then complie python again and run a line

    ./configure --prefix=/root/Python-2.7.8 --with-zlib-dir=/usr/local/lib 
 
 
         
         
0
 
vote

Puedes probar esto:

  1. Editar el archivo Modules/Setup.dist

  2. Encuentra esto

      #zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz    
  3. desenlace #

  4. ¡Inténtalo de nuevo!

 

you can try this:

  1. edit the file Modules/Setup.dist

  2. find this

    #zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz  
  3. unmask #

  4. try again!

 
 

Relacionados problema

0  PIP3 no está trabajando en Ubuntu  ( Pip3 is not working in ubuntu ) 
obtuve el siguiente error al usar pip3 en Ubuntu: mt@mt:~$ pip3 -V pip 9.0.1 from /usr/local/lib/python3.5/dist-packages (python 3.5) mt@mt:~$ python3 Py...

51  ¿Sigue siendo una práctica rota?  ( Is sudo pip install still a broken practice ) 
Soy nuevo en Ubuntu, así que por favor soporta conmigo. Instalé ABCDEFGHIJKLMNABCDEFGHIJKLMN8 Uso de este comando: ABCDEFGHIJKLMNABCDEFGHIJKLMN9 . Luego in...

0  ¿Por qué Ubuntu 16.04 viene con Python 3.5 pero no PIP3?  ( Why does ubuntu 16 04 come with python 3 5 but not pip3 ) 
Esta es probablemente una pregunta básica, pero soy bastante nuevo en Ubuntu. Por lo que entiendo, Ubuntu 16.04 (y las siguientes versiones) vienen con Python...

-2  Quiero saber sobre los administradores de paquetes en Ubuntu [CERRADO]  ( I want to know about package managers in ubuntu ) 
cerrado . Esta pregunta necesita detalles o claridad . Actualmente no está aceptando respuestas. ...

2  ¿Por qué Pip no instala el último cmake en Ubuntu?  ( Why does pip not install the latest cmake on ubuntu ) 
Como puede ver en https://pypi.org/project/cmake/ , Esta no es la última versión. En Windows, es trabajo como se esperaba. ¿Es un error o algo? root@85aca...

2  Problemas al instalar el paquete EDX-DL con PIP  ( Issues while installing edx dl package with pip ) 
QUERÍO DESEAR A BULT Descargar alguna conferencia de YouTube y EDX, así que eché un vistazo al proyecto aquí: https://github.com/coursera-dl/edx-dl < / p>...

0  Obtenga un error de importación después de instalar paquetes a través de Conda  ( Getting import error after installing packages through conda ) 
Acabo de instalar ABCDEFGHIJKLMNABCDEFGHIJKLMN2 , ABCDEFGHIJKLMNABCDEFGHIJKLMN3 , ABCDEFGHIJKLMNABCDEFGHIJKLMN4 Junto a ABCDEFGHIJKLMNABCDEFGHIJKLMN5 Di...

1  ¿Cómo realizo una reinstalación completa de PIP y PIP3?  ( How do i perform a full reinstallation of pip and pip3 ) 
Quiero de mi computadora lo que todos los demás quieren: para que funcione correctamente. Ahora en el problema: estaba tratando de instalar un paquete a tra...

0  Reinstale / actualice todos los paquetes de Python User-Site y no Ubuntu Global Ones  ( Reinstall upgrade all python user sites packages and not ubuntu global ones ) 
Cuando instalé Ubuntu (16.04 LTS), no me di cuenta de que (en general) no es una buena idea instalar Paquetes de Python a través de pip usando sudo : su...

0  No se puede instalar y actualizar los paquetes de Python en Ubuntu 14.04 [duplicado]  ( Cannot install and upgrade python packages on ubuntu 14 04 ) 
Esta pregunta ya tiene una respuesta aquí : Error en PIP: Tipo (s) de operandos no compatibles para ...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos