Sonido dejó de funcionar en HDMI en 14.04 -- 14.04 campo con sound campo con pulseaudio campo con hdmi campo con intel camp askubuntu Relacionados El problema

Sound stopped working on hdmi on 14.04


-1
vote

problema

Español

Tengo un Dell Inspiron 15 3542 y nunca pude obtener HDMI funcionando correctamente y hace unos días finalmente logré trabajar después de instalar los controladores de Intel. Todo estaba funcionando bien hasta hoy, mi televisión no produciría ningún sonido y HDMI no era una opción en Configuración de sonido. Encontré un hilo con problemas algo similares y, al tratar de lidiar con mi familia impaciente, corrí a los comandos que se sugirieron antes de ver el pequeño comentario debajo de ella, afirmando que causó aún más problemas. Los comandos que corrí se pueden encontrar en la parte inferior de aquí: HDMI no se muestra en la configuración de" Sonido "en Ubuntu 14.04 LTS

El único que no hice fue sudo apt-get dist-actualice porque quería permanecer en 14.04lts y no estaba seguro de cuál me pondría ese comando. Ahora todavía no tengo audio HDMI, pero ahora tampoco tengo la mitad de la configuración de mi sistema. Apariencia, sonido, etc ...

¿Cómo puedo arreglar esto sin perder mis datos? ¡Soy relativamente nuevo en Linux y realmente podría usar algo de ayuda! Ahora me veo obligado a iniciar Windows para trabajar audio HDMI ...

Original en ingles

I have a Dell inspiron 15 3542 and i could never get HDMI working properly and a few days ago I finally got it working after installing intel drivers. All was working fine until today my tv wouldn't produce any sound and HDMI wasn't an option under sound settings. I found a thread with somewhat similar issues and while trying to deal with my impatient family I ran the commands that were suggested before seeing the small comment under it stating it caused even more problems. The commands I ran can be found at the bottom of here: HDMI is not displayed in the "Sound" settings on Ubuntu 14.04 LTS

The only one i didn't do was sudo apt-get dist-upgrade because I wanted to stay on 14.04LTS and wasn't sure what that command would put me on. Now I still don't have HDMI audio out but now I also don't have half of my system settings. appearance, sound, etc...

How can I fix this without losing my data? I am relatively new to linux and I could really use some help! I'm now forced to boot windows for working HDMI audio...

              
   
   

Lista de respuestas

0
 
vote
vote
La mejor respuesta
 

Hay una problema conocido sobre este tipo de HDMI Problema de detección de audio cuando la computadora portátil se inicia sin el cargador. Las cosas de ahorro de energía a veces hacen que la detección no funciona.

Una forma fácil de verificar que esto es a la fuerza (inofensiva, no se preocupe), juegue un sonido con comandos de línea de comandos, asigne la salida al puerto HDMI, incluso si no está en su configuración de sonido.

Primero, conecte su dispositivo HDMI y abra un terminal con ctrl + alt + t , ejecute:

ABCDEFGHIJKLMNABCDEFGHIJKLMN1

Debería ver una lista de dispositivos de audio aquí:

  **** List of PLAYBACK Hardware Devices **** card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]   Subdevices: 1/1   Subdevice #0: subdevice #0 card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]   Subdevices: 1/1   Subdevice #0: subdevice #0 card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]   Subdevices: 1/1   Subdevice #0: subdevice #0 card 1: PCH [HDA Intel PCH], device 0: ALC290 Analog [ALC290 Analog]   Subdevices: 1/1   Subdevice #0: subdevice #0   

Siguiente, juegue un sonido y asigne el dispositivo de salida al HDMI:

ABCDEFGHIJKLMNABCDEFGHIJKLMN3

El número "1" Aquí está la base en la salida del comando ABCDEFGHIJKLMNABCDEFGHIJKLMN4 , por lo que podría ser 0, 1 o 2. y puede usar otro archivo para reemplazar el TMP.WAV aquí.

Esto debe activar su dispositivo de audio HDMI, y ahora estará disponible en la configuración del sonido.

solución

Si este es el caso, una solución es para editar el archivo de configuración con:

ABCDEFGHIJKLMNABCDEFGHIJKLMN5

(VI podría cambiarse con cualquier otro editor con el que esté familiarizado)

y agrega la siguiente línea:

  options snd-hda-intel power_save_controller=N    

Después de reiniciar, su detección de audio HDMI debe estar funcionando siempre que el cargador esté enchufado o no.

buena suerte.

 

There is a known issue about this kind of HDMI audio detection issue when the laptop is booted without the charger. The power saving stuff sometimes make the detection not working.

One easy way to verify this is to forcibly (harmless, don't worry) play a sound with command-line commands, assign the output to the HDMI port even if it's not in your sound settings.

First, connect your HDMI device and open a terminal with Ctrl + Alt + t, run:

aplay -l

You should see a list of audio devices here:

**** List of PLAYBACK Hardware Devices **** card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]   Subdevices: 1/1   Subdevice #0: subdevice #0 card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]   Subdevices: 1/1   Subdevice #0: subdevice #0 card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]   Subdevices: 1/1   Subdevice #0: subdevice #0 card 1: PCH [HDA Intel PCH], device 0: ALC290 Analog [ALC290 Analog]   Subdevices: 1/1   Subdevice #0: subdevice #0 

Next, play a sound and assign the output device to the HDMI:

aplay -D hdmi:HDMI,1 tmp.wav

The number "1" here is base on the output from the aplay -l command, so it could be 0, 1 or 2. And you can use another file to replace the tmp.wav here.

This should wake your HDMI audio device up, and it will now be available in the Sound settings.

Workaround

If this is the case, a workaround is to edit the config file with:

sudo vi /etc/modprobe.d/alsa-base.conf

(vi could be changed with any other editor that you're familiar with)

And append the following line to it:

options snd-hda-intel power_save_controller=N  

After reboot, your HDMI audio detection should be working whenever the charger is plugged or not.

Good luck.

 
 
         
         
0
 
vote

ejecutar

ABCDEFGHIJKLMNABCDEFGHIJKLMN7

para recuperar los iconos en la configuración del sistema.

 

Run

sudo apt-get install ubuntu-desktop

to get the icons in system settings back.

 
 

Relacionados problema

10  Intel_PowerCramp: Iniciar / Detener la inyección de ralentí forzada  ( Intel powerclamp start stop forced idle injection ) 
No lo sabe realmente cuando comenzó, acabo de actualizar de de 13.10 a 14.04 y estaba a punto de hacer algo sobre las actuaciones de gráficos (la unidad se si...

1  Inspiron 7590 - Sin señal a pantalla externa en Linux (funciona en Windows 10)  ( Inspiron 7590 no signal to external display on linux works on windows 10 ) 
Estoy usando la computadora portátil que se mantiene anteriormente (Configuración GTX1650) e instaló una distro Linux junto con Windows 10. El único (pero al ...

1  Faltan los dispositivos de audio integrados de gráficos HDMI  ( Integrated graphics hdmi audio devices are missing ) 
Acabo de comprar una computadora nueva para usar como HTPC con Ubuntu 12.04 de 64 bits, pero no puedo hacer que el audio HDMI funcione. Estoy usando los gráfi...

-1  Estoy buscando Intel64.iso [duplicado]  ( Im looking for intel64 iso ) 
Esta pregunta ya tiene respuestas aquí : es la versión de 64 bits de Ubuntu solo compatible con cpus...

0  Sin sonido en Dell Inspiron 6400n  ( No sound on dell inspiron 6400n ) 
Después de una instalación limpia de Ubuntu 12.04 en mi computadora portátil Dell Inspiron 6400N, no hay sonido en ninguna aplicación, utilice, aparte del rui...

1  ¿Cuál es mejor para Ubuntu? Brazo o Intel?  ( Which one is better for ubuntu arm or intel ) 
Si iba a comprar una nueva computadora portátil o una PC que sería mejor si solo instalara Ubuntu? He leído algunos artículos sobre Ubuntu Booting realmente...

46  kidle_inject causando una carga muy alta  ( Kidle inject causing very high load ) 
Cada vez que kidle_inject comienza a ejecutarse en mi sistema, la carga se dispara. En general, solo se lleva a una carga de alrededor de este 5.23, 3.65, ...

0  Ubuntu 14.04 Atajo de brillo no funciona  ( Ubuntu 14 04 brightness shortcut not working ) 
Estoy usando Asus A450L: Aquí hay algunas información: cat /proc/cmdline BOOT_IMAGE=/boot/vmlinuz-3.13.0-30-generic.efi.signed root=UUID=d1cccc17-9e70-468...

2  Problema Obtenga salida 4K (UHD) a Sony 65 "4K TV XBR-65X900A [CERRADO]  ( Problem getting 4k uhd output to sony 65 4k tv xbr 65x900a ) 
cerrado. Esta pregunta es off-topic . Actualmente no está aceptando respuestas. ¿Quieres ...

11  ¿Cómo consigo Turbo Boost funcionando?  ( How do i get turbo boost working ) 
Tengo un cuaderno de HP Pavilion DV6-2190US, tiene 8 GB DDR3 y un procesador I7 con 1.60 GHz (turbo Boost hasta 2.80GHz) No estoy seguro de si estoy haciend...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos