¿Cómo diagnosticar dependencias del paquete? -- apt campo con dependencies camp askubuntu Relacionados El problema

How to diagnose package dependancies?


2
vote

problema

Español

Quiero instalar postfixadmin en Trusty. Estoy confundido acerca de las dependencias.

http://packages.ubuntu.com/trusty/postfixadmin shows (creo) que necesita Apache2 o LightTPD o HTTPD que se instale.

Ya he instalado ABCDEFGHIJKLMNABCDEFGHIJKLMN1 , que, creo que debería satisfacer httpd y, por lo tanto, APT no debe necesitar instalar apache

pero apt-get -s install postfixadmin quiere instalar apache2 , y no entiendo por qué?

¿Alguna idea?

Original en ingles

I want to install postfixadmin on trusty. I'm confused about dependencies.

http://packages.ubuntu.com/trusty/postfixadmin shows (I think) that it needs apache2 OR lighttpd OR the httpd to be installed.

I have already installed nginx-full, which, I believe should satisfy httpd and therefore apt should NOT need to install apache.

But apt-get -s install postfixadmin wants to install apache2, and I don't understand why?

Any ideas?

     
 
 

Lista de respuestas

1
 
vote

Una de las dependencias de postfixadmin es libapache2-mod-php5 | php5-cgi | php5 . ABCDEFGHIJKLMNABCDEFGHIJKLMN2 Depende de apache2 , como podría esperar. ABCDEFGHIJKLMNABCDEFGHIJKLMN4 Depende de libapache2-mod-php5 . ABCDEFGHIJKLMNABCDEFGHIJKLMN6 , por otro lado, no no depende de cualquier apache.

Por lo tanto, si instala php5-cgi primero y luego instale postfixadmin , Apache no se instalará.

 

One of the dependencies of postfixadmin is libapache2-mod-php5 | php5-cgi | php5. libapache2-mod-php5 depends on apache2, as you might expect. php5 depends on libapache2-mod-php5. php5-cgi, on the other hand, does not depend on anything Apache.

Therefore, if you install php5-cgi first and then install postfixadmin, Apache won't be installed.

 
 

Relacionados problema

2  12.04 Actualización MI SISTEMA  ( 12 04 upgrade hosed my system ) 
Desearía poder ser más específico. Instalé la actualización del administrador de actualizaciones y después de reiniciar la computadora, encontré que no podía ...

592  ¿Cómo resuelvo las dependencias no satisfechas después de agregar un PPA?  ( How do i resolve unmet dependencies after adding a ppa ) 
Ocasionalmente, cuando estoy instalando cosas, recibo un error como lo siguiente: Some packages could not be installed. This may mean that you have request...

1  Instale Python2.7 Problemas de dependencias insatisfechas - Ubuntu 18.04  ( Install python2 7 unmet dependencies problems ubuntu 18 04 ) 
Recientemente limpio, reinstaló Ubuntu 18.04 y ahora quería instalar Python2.7 para varias otras dependencias, sin embargo, no puedo hacerlo. Correr sudo apt...

0  No se puede instalar nada debido al problema de dependencia  ( Unable to install anything due to dependency problem ) 
Este mensaje se muestra cada vez que intento instalar cualquier cosa. Por favor, buenas personas, cuento con Ubuntu. No puedo volver a Windows. Por favor ayu...

2  LIBETPAN15 no está instalable al intentar instalar el Dock de El Cairo  ( Libetpan15 not installable when trying to install cairo dock ) 
Al agregar el Dock Cairo a Ubuntu 12.04, recibo este mensaje que me dice que necesito una dependencia. ¿Qué hago ahora para continuar con la instalación? T...

0  ¿Cómo instalar las dependencias de WebSocket ++?  ( How to install websocket dependencies ) 
Estoy tratando de desarrollar aplicaciones websocket en C ++. He elegido usar WebSocket ++ ya que es un ABCDEFGHIJKLMNABCDEFGHIJKLMN5 que no intenta retro...

3  No se puede instalar la oficina de WPS [duplicar]  ( Cannot install wps office ) 
Esta pregunta ya tiene respuestas aquí : e: paquete 'libpng12-0' no tiene Candidato de la instalació...

2  Dependencia rota libgcrypt11  ( Broken libgcrypt11 dependency ) 
He ejecutado un comando apt-get update && apt-get upgradeDefghijklmn8Defghijklmn8. El proceso completado (con un error): ABCDEFGHIJKLMNABCDEFGHIJKLMN9 a...

0  Las dependencias del paquete no se pueden resolver Ayuda [DUPLICADO]  ( Package dependencies cannot be resolved help ) 
Esta pregunta ya tiene respuestas aquí : ¿Cómo resuelvo las dependencias no satisfechas después de a...

0  Sudo apt-get -f Instale error GCC-6-Base  ( Sudo apt get f install error gcc 6 base ) 
No puedo instalar anualmente en mi compuerta, obteniendo este error, incluso si intento instalar sudo apt-get -f. Utilizando Ubuntu 17.04 64 bits dpkg: dep...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos