Estoy tratando de instalar Nodejs-Legacy y sigue fallando [duplicar] -- apt campo con nodejs camp askubuntu Relacionados El problema

I'm trying to install nodejs-legacy and it keeps failing [duplicate]


0
vote

problema

Español
Esta pregunta ya tiene respuestas aquí :
obteniendo "'archivo 'Es diferente del mismo archivo en el sistema "Cuando intento actualizar a través de Synaptic (2 respuestas)
CERRADO hace 6 años .

No tengo idea de cuál es el problema, pero sigo intentando instalar Nodejs-Legacy al ejecutar sudo apt-get install, pero sigue fallando. Aquí está toda la salida cuando intento hacer el comando.

  Reading package lists... Done Building dependency tree        Reading state information... Done The following packages were automatically installed and are no longer required:   ax25-node libax25 libc-ares2 libv8-3.14.5 openbsd-inetd Use 'apt-get autoremove' to remove them. The following NEW packages will be installed:   nodejs-legacy 0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded. 1 not fully installed or removed. Need to get 0 B/15.4 kB of archives. After this operation, 119 kB of additional disk space will be used. (Reading database ... 198807 files and directories currently installed.) Unpacking nodejs-legacy (from .../nodejs-legacy_0.10.15~dfsg1-4_all.deb) ... dpkg: error processing /var/cache/apt/archives/nodejs-legacy_0.10.15~dfsg1-4_all.deb (--unpack):  trying to overwrite '/usr/share/man/man1/node.1.gz', which is also in package nodejs 0.10.24-1chl1~saucy1 Processing triggers for man-db ... Errors were encountered while processing:  /var/cache/apt/archives/nodejs-legacy_0.10.15~dfsg1-4_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1)   

Solución:

Así que encontré la respuesta a mi pregunta en otro hilo. Tuve que usar sudo dpkg -r nodejs-legacy y sudo apt-get -f install .

Entonces, el crédito por donde se debe crédito, aquí está el enlace la respuesta que me explicó lo que tenía que hacer.

https://askubuntu.com/a/185123/237774

Original en ingles

I have no idea what the problem is, but I keep trying to install nodejs-legacy by running sudo apt-get install, but it keeps failing. Here's all of the output when I try to do the command.

Reading package lists... Done Building dependency tree        Reading state information... Done The following packages were automatically installed and are no longer required:   ax25-node libax25 libc-ares2 libv8-3.14.5 openbsd-inetd Use 'apt-get autoremove' to remove them. The following NEW packages will be installed:   nodejs-legacy 0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded. 1 not fully installed or removed. Need to get 0 B/15.4 kB of archives. After this operation, 119 kB of additional disk space will be used. (Reading database ... 198807 files and directories currently installed.) Unpacking nodejs-legacy (from .../nodejs-legacy_0.10.15~dfsg1-4_all.deb) ... dpkg: error processing /var/cache/apt/archives/nodejs-legacy_0.10.15~dfsg1-4_all.deb (--unpack):  trying to overwrite '/usr/share/man/man1/node.1.gz', which is also in package nodejs 0.10.24-1chl1~saucy1 Processing triggers for man-db ... Errors were encountered while processing:  /var/cache/apt/archives/nodejs-legacy_0.10.15~dfsg1-4_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1) 

Solution:

So I found the answer to my question in another thread. I had to use sudo dpkg -r nodejs-legacy and sudo apt-get -f install.

So, credit for where credit is due, here is the link the answer that explained to me what I had to do.

https://askubuntu.com/a/185123/237774

     
 
 

Lista de respuestas

3
 
vote

Intente eliminar el paquete abcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcdefghijklmnabcDefghijklmnArt14

  Package: *        Pin: release a=quantal* Pin-Priority: 2012 6  

 

Try to remove previously installed nodejs package and then install nodejs-legacy package.

sudo dpkg -r nodejs sudo apt-get install nodejs-legacy 
 
 
     
     

Relacionados problema

1  Instalación de nodejs y problemas con Heroku  ( Instaling nodejs and problems with heroku ) 
Estoy tratando de instalar el nodo js de https://nodejs.org/en/ Descargar / Paquete-Manager / Después de instalar curl y abcdefhijklmnabcdefghijklmn5 ...

8  Haz un .deb para una aplicación node.js  ( Make a deb for a node js application ) 
¿Cómo hago un iBEB para una aplicación node.js que instala NOde.js y sus módulos NPM requeridos en DPKG -I? ¿Cuál es el lugar en el sistema de archivos dond...

1  Nodo.js NVM causa el bucle de inicio de sesión de Xubuntu con ~ / .profile line  ( Node js nvm causes xubuntu login loop with profile line ) 
Hay varios puestos en el bucle de inicio de sesión de Xubuntu, pero ninguno de ellos abordan NVM (administrador de la versión del nodo). He instalado nodejs...

61  ¿Cómo instalar nodejs 4 usando apt?  ( How to install nodejs 4 using apt ) 
¿Cómo puedo instalar nodejs 4 en Ubuntu usando apt-get Utilities? ...

1  / usr / local / bin / Bower: No hay dicho archivo o directorio después de reinstalar node.js y Bower  ( Usr local bin bower no such file or directory after reinstalling node js and b ) 
Reinstalé nodejs ( node , abcdefhijklmnabcdefghijklmn6 ) Debido a una antigua configuración corruptida. De lo que instalé bower ABCDEFGHIJKLMNABCDEFGH...

1  Node.js que no comienza de forma predeterminada en Lubuntu Invitado que se ejecuta en Oracle VM VirtualBox  ( Node js not starting by default in lubuntu guest running in oracle vm virtualbox ) 
Estoy usando Lubuntu 14.10 en Oracle VM VirtualBox. Instalé node.js usando NVM . Después de la instalación, podría ejecutar node --version en el mismo te...

1  No se puede instalar Express.js  ( Unable to install express js ) 
Estoy ejecutando Ubuntu 14.04 64 bit. Fui capaz de instalar NOde.js usando los siguientes comandos: curl -sL https://deb.nodesource.com/setup_5.x | sudo -E...

1  ¿Cómo demore un servicio SYSTEMSD para que NVM & NODE se inicien correctamente antes de funcionar?  ( How do i delay a systemd service so that nvm node are correctly initialised be ) 
Tengo el siguiente servicio: [Unit] Description=Launch Demo [Service] Type=forking ExecStart=/bin/bash /opt/Demo/launch_script.sh [Install] WantedBy=mult...

27  La versión de control de NODEJS no devuelve nada  ( Checking version of nodejs returns nothing ) 
Estoy tratando de instalar el nodo JS en Ubuntu para que pueda ejecutar Angularjs. No estoy seguro de si lo he instalado anteriormente, así que corrí ABCDEFG...

0  Ejecutar una aplicación de nodo en Ubuntu  ( Running a node app in ubuntu ) 
Tengo una aplicación de nodos que básicamente ejecuta en 4 pasos ya que también necesito ejecutar Mongodb y Redis: mongod --config=/etc/mongod.conf service...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos