Versión incorrecta de Linux-Headers-Server -- server campo con apt campo con dependencies camp askubuntu Relacionados El problema

wrong linux-headers-server version


1
vote

problema

Español

En mi servidor Ubuntu 12.04 Recibo el mensaje que $CMD1 depende de $CMD2 3.2.0.55.65 pero está instalado 3.2.0.56.66 está instalado.

El sugerido $CMD3 no funciona.

Mis fuentes. Lista:

  $CMD4  
Original en ingles

On my Ubuntu 12.04 server I get the message that linux-server depends on linux-headers-server 3.2.0.55.65 but 3.2.0.56.66 is installed.

The suggested apt-get -f install won't work.

my sources.list:

    # deb cdrom:[Ubuntu-Server 12.04 LTS _Precise Pangolin_ - Release amd64 (20120424.1)]/ dists/precise/main/binary-i386/ # deb cdrom:[Ubuntu-Server 12.04 LTS _Precise Pangolin_ - Release amd64 (20120424.1)]/ dists/precise/restricted/binary-i386/ # deb cdrom:[Ubuntu-Server 12.04 LTS _Precise Pangolin_ - Release amd64 (20120424.1)]/ precise main restricted  #deb cdrom:[Ubuntu-Server 12.04 LTS _Precise Pangolin_ - Release amd64 (20120424.1)]/ dists/precise/main/binary-i386/ #deb cdrom:[Ubuntu-Server 12.04 LTS _Precise Pangolin_ - Release amd64 (20120424.1)]/ dists/precise/restricted/binary-i386/ #deb cdrom:[Ubuntu-Server 12.04 LTS _Precise Pangolin_ - Release amd64 (20120424.1)]/ precise main restricted  # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to # newer versions of the distribution. deb http://de.archive.ubuntu.com/ubuntu/ precise main restricted deb-src http://de.archive.ubuntu.com/ubuntu/ precise main restricted  ## Major bug fix updates produced after the final release of the ## distribution. deb http://de.archive.ubuntu.com/ubuntu/ precise-updates main restricted deb-src http://de.archive.ubuntu.com/ubuntu/ precise-updates main restricted  ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu ## team. Also, please note that software in universe WILL NOT receive any ## review or updates from the Ubuntu security team. deb http://de.archive.ubuntu.com/ubuntu/ precise universe deb-src http://de.archive.ubuntu.com/ubuntu/ precise universe deb http://de.archive.ubuntu.com/ubuntu/ precise-updates universe deb-src http://de.archive.ubuntu.com/ubuntu/ precise-updates universe  ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu  ## team, and may not be under a free licence. Please satisfy yourself as to  ## your rights to use the software. Also, please note that software in  ## multiverse WILL NOT receive any review or updates from the Ubuntu ## security team. deb http://de.archive.ubuntu.com/ubuntu/ precise multiverse deb-src http://de.archive.ubuntu.com/ubuntu/ precise multiverse deb http://de.archive.ubuntu.com/ubuntu/ precise-updates multiverse deb-src http://de.archive.ubuntu.com/ubuntu/ precise-updates multiverse  ## N.B. software from this repository may not have been tested as ## extensively as that contained in the main release, although it includes ## newer versions of some applications which may provide useful features. ## Also, please note that software in backports WILL NOT receive any review ## or updates from the Ubuntu security team. deb http://de.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse deb-src http://de.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse  deb http://security.ubuntu.com/ubuntu precise-security main restricted deb-src http://security.ubuntu.com/ubuntu precise-security main restricted deb http://security.ubuntu.com/ubuntu precise-security universe deb-src http://security.ubuntu.com/ubuntu precise-security universe deb http://security.ubuntu.com/ubuntu precise-security multiverse deb-src http://security.ubuntu.com/ubuntu precise-security multiverse  ## Uncomment the following two lines to add software from Canonical's ## 'partner' repository. ## This software is not part of Ubuntu, but is offered by Canonical and the ## respective vendors as a service to Ubuntu users. # deb http://archive.canonical.com/ubuntu precise partner # deb-src http://archive.canonical.com/ubuntu precise partner  ## Uncomment the following two lines to add software from Ubuntu's ## 'extras' repository. ## This software is not part of Ubuntu, but is offered by third-party ## developers who want to ship their latest software. # deb http://extras.ubuntu.com/ubuntu precise main # deb-src http://extras.ubuntu.com/ubuntu precise main 
        
       
       

Lista de respuestas

1
 
vote
vote
La mejor respuesta
 

resuelto por:

  $ modinfo i915 | grep modeset parm:           modeset:Use kernel modesetting [KMS] (0=DRM_I915_KMS from                 .config, 1=on, -1=force vga console preference [default]) (int) 2  
 

Solved by:

sudo apt-get remove linux-server  sudo apt-get install linux-server 
 
 
0
 
vote

ABCDEFGHIJKLMNABCDEFGHIJKLMN13

verificar si / boot es 100% lleno o tiene suficiente espacio?

ABCDEFGHIJKLMNABCDEFGHIJKLMN14

Si se libera completamente un poco de espacio

Eche un vistazo a la versión que está ejecutando

ABCDEFGHIJKLMNABCDEFGHIJKLMN15

Ejemplo:

ABCDEFGHIJKLMNABCDEFGHIJKLMN16

AVISO ABCDEFGHIJKLMNABCDEFGHIJKLMN17 Para mí fue ABCDEFGHIJKLMNABCDEFGHIJKLMN18 El suyo podría ser más bajo ... Mayor solo depende

Todo antes de $ modinfo i915 | grep modeset parm: modeset:Use kernel modesetting [KMS] (0=DRM_I915_KMS from .config, 1=on, -1=force vga console preference [default]) (int) 9 se puede eliminar por mi ejemplo. Recomendado para dejar una versión de rollback para todo antes de -10

El objetivo aquí es para liberar un poco de espacio

No copie este cheque su propia máquina

ten cuidado

ABCDEFGHIJKLMNABCDEFGHIJKLMN21

ABCDEFGHIJKLMNABCDEFGHIJKLMN22

ABCDEFGHIJKLMNABCDEFGHIJKLMN23

ABCDEFGHIJKLMNABCDEFGHIJKLMN24

Una vez que haya liberado un poco de espacio

ABCDEFGHIJKLMNABCDEFGHIJKLMN25 Trate de obtener el uso de% a una cantidad razonable para instalar

ABCDEFGHIJKLMNABCDEFGHIJKLMN26

ABCDEFGHIJKLMNABCDEFGHIJKLMN27

ABCDEFGHIJKLMNABCDEFGHIJKLMN28

ABCDEFGHIJKLMNABCDEFGHIJKLMN29

 

df -h

check if /boot is 100% full or has enough space?

/dev/sda1 228M 133M 84M 100% /boot

IF full free up some space

take a look at what version you're running with

uname -a

Example:

Linux YOURSERVERNAME 3.2.0-70-generic #105-Ubuntu UTC ... GNU/Linux

notice 3.2.0-XX-generic for me it was 70 yours might be lower... higher just depends

everything before 70 can be removed for my example. recommended to leave a rollback version so everything before 68

The goal here is to free up some space

DON'T COPY THIS CHECK YOUR OWN MACHINE

BE CAREFUL

rm abi-3.2.0-XX-generic

rm config-3.2.0-XX-generic

rm initrd.img-3.2.0-XX-generic

rm System.map-3.2.0-XX-generic

once you have freed up some space

df -h try to get USE% to a reasonable amount for installs

/dev/sda1 XX% /boot

sudo apt-get -f install

sudo apt-get autoclean

sudo apt-get autoremove

 
 

Relacionados problema

2  Dependencia rota libgcrypt11  ( Broken libgcrypt11 dependency ) 
He ejecutado un comando apt-get update && apt-get upgradeDefghijklmn8Defghijklmn8. El proceso completado (con un error): ABCDEFGHIJKLMNABCDEFGHIJKLMN9 a...

1  Instale Python2.7 Problemas de dependencias insatisfechas - Ubuntu 18.04  ( Install python2 7 unmet dependencies problems ubuntu 18 04 ) 
Recientemente limpio, reinstaló Ubuntu 18.04 y ahora quería instalar Python2.7 para varias otras dependencias, sin embargo, no puedo hacerlo. Correr sudo apt...

3  No se puede instalar la oficina de WPS [duplicar]  ( Cannot install wps office ) 
Esta pregunta ya tiene respuestas aquí : e: paquete 'libpng12-0' no tiene Candidato de la instalació...

0  No se puede instalar nada debido al problema de dependencia  ( Unable to install anything due to dependency problem ) 
Este mensaje se muestra cada vez que intento instalar cualquier cosa. Por favor, buenas personas, cuento con Ubuntu. No puedo volver a Windows. Por favor ayu...

0  ¿Cómo instalar las dependencias de WebSocket ++?  ( How to install websocket dependencies ) 
Estoy tratando de desarrollar aplicaciones websocket en C ++. He elegido usar WebSocket ++ ya que es un ABCDEFGHIJKLMNABCDEFGHIJKLMN5 que no intenta retro...

592  ¿Cómo resuelvo las dependencias no satisfechas después de agregar un PPA?  ( How do i resolve unmet dependencies after adding a ppa ) 
Ocasionalmente, cuando estoy instalando cosas, recibo un error como lo siguiente: Some packages could not be installed. This may mean that you have request...

2  LIBETPAN15 no está instalable al intentar instalar el Dock de El Cairo  ( Libetpan15 not installable when trying to install cairo dock ) 
Al agregar el Dock Cairo a Ubuntu 12.04, recibo este mensaje que me dice que necesito una dependencia. ¿Qué hago ahora para continuar con la instalación? T...

0  Sudo apt-get -f Instale error GCC-6-Base  ( Sudo apt get f install error gcc 6 base ) 
No puedo instalar anualmente en mi compuerta, obteniendo este error, incluso si intento instalar sudo apt-get -f. Utilizando Ubuntu 17.04 64 bits dpkg: dep...

2  12.04 Actualización MI SISTEMA  ( 12 04 upgrade hosed my system ) 
Desearía poder ser más específico. Instalé la actualización del administrador de actualizaciones y después de reiniciar la computadora, encontré que no podía ...

0  Las dependencias del paquete no se pueden resolver Ayuda [DUPLICADO]  ( Package dependencies cannot be resolved help ) 
Esta pregunta ya tiene respuestas aquí : ¿Cómo resuelvo las dependencias no satisfechas después de a...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos