LIBUSB-0.1.SO.4 Error de lib compartido en el sistema Ubuntu 64 bit -- 64-bit campo con shared-library camp askubuntu Relacionados El problema

libusb-0.1.so.4 shared lib error in ubuntu 64 bit system


13
vote

problema

Español

Estoy tratando de instalar el controlador ZTE MF191 en la máquina Ubuntu 12.04 64 bits. No estoy seguro de que es compatible con 64 bits o no. Pero funciona bien en el sistema de 32 bits. Este paquete de controladores tiene un archivo ejecutable llamado zr cuando intento ejecutar esto, tire un error

  libusb-0.1.so.4: cannot open shared object file: No such file or directory   

I Googled It, pero no puedo encontrar una manera de instalarlo (lib). Algunas personas sugirieron instalar la versión de 32 bits, pero no puedo encontrar una en Synaptic. Por favor ayuda.

Original en ingles

I am trying to install ZTE MF191 driver in ubuntu 12.04 64 bit machine. I am not sure is it support 64 bit or not. But it works fine in 32bit system. These driver package has a executable file named zr When i try to run this it throws an error

libusb-0.1.so.4: cannot open shared object file: No such file or directory 

I googled it but can't find a way to install(lib) it. Some people suggested to install 32bit version but i can't find one in synaptic. Please help.

     

Lista de respuestas

20
 
vote
vote
La mejor respuesta
 

Para instalar la versión de 32 bits, ejecute:

  sudo add-apt-repository ppa:nginx/stable 3  

Esto solo funciona si se habilita MultiarCH (tal vez no lo hace si actualizó desde una versión anterior de Ubuntu). Busque sudo add-apt-repository ppa:nginx/stable 4 en /etc/dpkg/dpkg.cfg.d/dpkg.cfg.d/multadar para verificar si Multiarch está habilitado, y si no lo hace, ejecute sudo add-apt-repository ppa:nginx/stable 5 para habilitar multiarca y ABCDEFGHIJKLMNABCDEFGHIJKLMN16 Para obtener las nuevas listas de paquetes.

 

To install the 32-bit version, run:

apt-get install libusb-0.1-4:i386 

This only works if MultiArch is enabled (maybe it doesn't if you upgraded from an older Ubuntu version). Look for foreign-architecture i386 in /etc/dpkg/dpkg.cfg.d/multiarch to check if MultiArch is enabled, and if it doesn't, run echo "foreign-architecture i386" | sudo tee /etc/dpkg/dpkg.cfg.d/multiarch to enable MultiArch and apt-get update to get the new package lists.

 
 
6
 
vote

Para instalar Libusb usar sudo add-apt-repository ppa:nginx/stable 7

 

to install libusb use sudo apt-get install libusb-0.1-4

 
 
   
   
5
 
vote

Falló por mí incluso después de sudo add-apt-repository ppa:nginx/stable 8 / sudo add-apt-repository ppa:nginx/stable 9 Así que lo hice ABCDEFGHIJKLMNABCDEFGHIJKLMN20 y funcionó bien en mi sistema Ubuntu 64bit

 

It failed for me even after sudo apt-get install libusb-0.1-4:i386/sudo apt-get install libusb-0.1-4 so I did sudo apt-get install libusb-dev and it worked fine on my Ubuntu 64bit system

 
 
 
 
0
 
vote

Este error aún existe en Ubuntu 18.04 LTS; Mi solución fue instalar sudo apt-get update && sudo apt-get -f install nginx 1 . Esto lo resolvió para mí.

 

This error still exists in Ubuntu 18.04 LTS; my workaround was to install libusb-dev. This resolved it for me.

 
 

Relacionados problema

1  Buscando la biblioteca LTS  ( Looking for lts library ) 
He tratado de buscar esto, pero buscar "Linux LTS", obviamente, no me da lo que quiero. Soy un N00B en mi camino a través de una solución demasiado complica...

4  ¿Cuál es el papel de las bibliotecas estáticas?  ( What is the role of static libraries ) 
Bibliotecas estáticas de forma predeterminada en vivo en /usr/lib o abcdefhijklmnabcdefghijklmn7 pero los eliminé a todos en mi sistema operativo con este...

1  Un software (fluido 6) no encuentra la biblioteca compartida  ( A sofware fluent 6 does not find shared library ) 
Después de la configuración fluida (software CFD), cuando ejecuto la aplicación recibo un error: /usr/local/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26 -3d...

1  No se puede ejecutar "Biblioteca compartida" en Nautilus  ( Cant run shared library in nautilus ) 
Recientemente reinstalé Ubuntu en 64 bits (antes de que lo tuviera en 32 bits). Tuve la carpeta de inicio en una partición y el sistema en otro. Entonces, cua...

14  ¿Cómo instalo Libtiff.SO.3?  ( How do i install libtiff so 3 ) 
Cuando intento ejecutar maya desde el terminal, obtengo: error while loading shared libraries: libtiff.so.3: cannot open shared object file: No such file o...

1  Agregando cambios personalizados a las apagadas para Python  ( Adding custom changes to the openblas for python ) 
My Pregunta: ¿Cómo obtengo Python para usar mi propia versión compilada de OpenBlas? Fondo The theano Guía de instalación sugiere que uno debe probar ...

3  Clase de ELF incorrecta: Error de Elfclass32 en el uso de 32 bits. En la máquina de 64 bits usando Dlopen  ( Wrong elf class elfclass32 error in using 32 bit so in 64 bit machine using dl ) 
Necesito usar una biblioteca compartida de 32 bits creada por alguien más en mi aplicación de 64 bits en Ubuntu 14.04. Recibo el error dado en el título. He i...

10  No se puede iniciar texto sublime  ( Unable to start sublime text ) 
Había estado usando un texto sublime 2 sin problemas. Me instalé inactiva y ahora no puedo iniciar texto sublime. Intenté desinstalar el ralentí, pero el text...

4  Configuración de ld_library_path antes de ejecutar una aplicación de un terminal no tiene efecto  ( Setting ld library path before running an app from a terminal has no effect ) 
Tengo varias compilaciones de una aplicación en mi sistema (una compilación de desarrollo y muchas compilaciones publicadas mayores). Cuando estoy tratando de...

1  Biblioteca desaparecida de Witcher 2 libgtk-x11-2.0.0.0.0  ( Witcher 2 missing library libgtk x11 2 0 so 0 ) 
Los eventos que llevaron a esta situación son los siguientes: Intenté ejecutar el wither 2 en Linux desde gog.com e instalé las dependencias ( http://www.g...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos