Descargué Ruby en rieles, pero dice que no está instalado -- installation campo con 12.10 campo con command-line campo con ruby campo con git camp askubuntu Relacionados El problema

I downloaded ruby on rails, but it says it isn't installed


0
vote

problema

Español

Descargué Ruby en rieles en Ubuntu 12.10 a través de este tutorial http://technical-feeds.blogspot.ca/2013/02/how-o-install-ubuntu-and-and-ruby-on-rails.html .

Hice todo y funcionó bien.

Revisé Ruby -V y volví como Ruby 2.0.0P0. También revisé rieles, rubygems y git, volvieron bien.

Luego cerré la terminal y abrí uno nuevo y traté de revisar la versión, pero esto regresó para Ruby

Bimbola @ Ubuntu: ~ $ Ruby -V El programa 'Ruby' se puede encontrar en los siguientes paquetes: * RUBY1.8 * RUBY1.9.1 Prueba: sudo apt-get install

y esto vino para rieles

Bimbola @ Ubuntu: ~ $ Rails -V El programa 'Rails' se puede encontrar en los siguientes paquetes: * Rails * Ruby-Railties-3.2 Pruebe: sudo apt-get install

git sigue siendo bueno aunque

Bimbola @ Ubuntu: ~ $ Git --version Git versión 1.7.10.4

Original en ingles

I downloaded ruby on rails on ubuntu 12.10 through this tutorial http://technical-feeds.blogspot.ca/2013/02/how-to-install-ubuntu-and-ruby-on-rails.html.

I did everything and it worked fine.

I checked ruby -v and it came back as ruby 2.0.0p0. I also checked rails, rubygems and git they came back good.

Then I closed the terminal and opened a new one and tried to check the version but this came back for ruby

bimbola@ubuntu:~$ ruby -v The program 'ruby' can be found in the following packages: * ruby1.8 * ruby1.9.1 Try: sudo apt-get install

And this came for rails

bimbola@ubuntu:~$ rails -v The program 'rails' can be found in the following packages: * rails * ruby-railties-3.2 Try: sudo apt-get install

git is still fine though

bimbola@ubuntu:~$ git --version git version 1.7.10.4

              

Lista de respuestas

2
 
vote
vote
La mejor respuesta
 

Trate de hacer lo siguiente, podría funcionar:

Abrir un terminal y tipo:

ABCDEFGHIJKLMNABCDEFGHIJKLMN0

luego

  //In order to install RVM  curl -L get.rvm.io | bash -s stable --auto   

Actualizar el perfil de Bash:

ABCDEFGHIJKLMNABCDEFGHIJKLMN2

Instale los siguientes paquetes:

  sudo apt-get install build-essential openssl libreadline6 libreadline6-dev  curl git-core zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-dev sqlite3  libxml2-dev libxslt-dev autoconf libc6-dev ncurses-dev automake libtool bison   subversion pkg-config   

Ahora instale Ruby:

  rvm install 1.9.3   

TIPO TIPO:

  ABCDEFGHIJKLMNABCDEFGHIJKLMN5   

Hágale predeterminado:

  rvm --default use 1.9.3-p327   

finalmente instalar rieles:

  gem install rails -v 3.2.9   
 

Try and do the following, it might work:

Open a terminal and type:

sudo apt-get install curl

Then

//In order to install RVM  curl -L get.rvm.io | bash -s stable --auto 

reload the bash profile:

. ~/.bash_profile

install the following packages:

sudo apt-get install build-essential openssl libreadline6 libreadline6-dev \ curl git-core zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-dev sqlite3 \ libxml2-dev libxslt-dev autoconf libc6-dev ncurses-dev automake libtool bison  \ subversion pkg-config 

Now install Ruby:

rvm install 1.9.3 

then type:

rvm use 1.9.3 

make it default:

rvm --default use 1.9.3-p327 

Finally install Rails:

gem install rails -v 3.2.9 
 
 
     
     

Relacionados problema

5  ¿Cuáles son los pasos para configurar la gitosis?  ( What are the steps for configuring gitosis ) 
Buscando pasos de configuración para la gitosis después de instalar desde apt-get . ...

16  ¿Cómo obtengo "rápidamente" para usar GIT?  ( How do i get quickly to use git ) 
¿Cómo obtengo rápidamente ¡Para usar Git como su control de versión predeterminado en lugar de BAZAAR? ...

2  Fatal: no se pudo crear la dirección de árbol de trabajo 'MetaSploit-Framework'.: Permiso denegado  ( Fatal could not create work tree dir metasploit framework permission denied ) 
Estoy siguiendo esta guía. Estoy haciendo esto: cd /opt git clone https://github.com/rapid7/metasploit-framework.git cd metasploit-framework cuando e...

0  No puedo firmar compromisos con git  ( Cant sign commits with git ) 
Estoy tratando de configurar Git para firmar todos mis comisiones. GPG funciona bien para mí por sí mismo, al igual que Git. Sin embargo, cuando habilito la f...

0  Incapaz de conectarse al proxy, git  ( Unable to connect to proxy git ) 
Configure un sistema de sistema de ancho en mi máquina a través de la configuración de la red, el proxy fue localhost: 9191 (Yo estaba usando burpsuite). Ahor...

2  ¿Cómo instalar GITG 0.3.3 en Ubuntu 14.04?  ( How to install gitg 0 3 3 on ubuntu 14 04 ) 
Quiero instalar gitg versión 0.3.3 en Ubuntu 14.04. ¿Cómo puedo hacer eso? ...

34  ¿Cómo clonar solo algunos directorios de un repositorio de git?  ( How to clone only some directories from a git repository ) 
Por ejemplo, quiero descargar PCL 3D_REC_FRAMEWARK. Este es el repositorio GIT de PCL: https://github.com/pointcloudlibrary/pcl.git ¿Cómo puedo descarga...

1  ¿Cómo instalar GIT-HG en Lubuntu? [duplicar]  ( How to install git hg in lubuntu ) 
Esta pregunta ya tiene respuestas aquí : ¿Cómo encuentro el paquete que proporciona un archivo? ...

1  Extracción de la necesidad de sudo con una contraseña  ( Removing the need to sudo with a password ) 
Descargo de responsabilidad: Sé que se ha preguntado mucho esta pregunta, he leído un montón de maneras y he intentado un montón de formas, pero sigo con prob...

1  ¿Cómo instalar KDE 4.3 en Ubuntu 9.04? (o ¿cómo puedo usar konqueror 4.3 en andlinux?)  ( How to install kde 4 3 on ubuntu 9 04 or how can i use konqueror 4 3 on andlin ) 
Añadido el archivo de Kubuntu Jaunty Backport en el archivo Sources.List, la clave GPG + HECHO APT-GET UPDATE y DIST-Upgrade etc ... Elija una pregunta: ...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos