Fallo de autenticación SASL: sin secreto en la base de datos -- email campo con mail campo con postfix campo con sasl camp askubuntu Relacionados El problema

SASL authentication failure: no secret in database


0
vote

problema

Español

Tengo un VPS con panel Plesk en Ubuntu Server 10.04. Todo estaba configurado y funcionando perfectamente. Solo el cambio que realicé a la configuración de correo era permitir que el puerto de envío 587. Todo estaba funcionando: IMAP, SMTP, etc.

Pero ayer, creo que después de una actualización, noté que no puedo enviar correos. Entonces, ahora no hay forma de hacerlo funcionar.

Estos son mensajes que recibo en /var/log/mail.info :

  postfix/smtpd[9523]: warning: SASL authentication failure: no secret in database postfix/smtpd[9523]: warning: SASL DIGEST-MD5 authentication failed: One time use of a plaintext password will enable requested mechanism for user postfix/smtpd[9523]: disconnect...   

Hay muchos tutoriales para hacer que el trabajo de Postfix con Dovecot, pero tengo miedo de instalar Dovecot, porque cuando ejecuto apt-get instale dovecot-imapd, dice que se eliminarán muchas características de PSA- *.

Cualquier ayuda es bienvenida. No me metí con nada hasta que anoche, cuando intenté algunas de las soluciones, encontré buscar en Google, pero sin suerte en absoluto .

Aquí están mi ABCDEFGHIJKLMNABCDEFGHIJKLMN2 :

  # See /usr/share/postfix/main.cf.dist for a commented, more complete version   # Debian specific:  Specifying a file name will cause the first # line of that file to be used as the name.  The Debian default # is /etc/mailname. #myorigin = /etc/mailname  smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu) biff = no  # appending .domain is the MUA's job. append_dot_mydomain = no  # Uncomment the next line to generate "delayed mail" warnings #delay_warning_time = 4h  readme_directory = no  # TLS parameters smtpd_tls_cert_file = /etc/postfix/postfix_default.pem smtpd_tls_key_file = $smtpd_tls_cert_file smtpd_use_tls = yes smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache  # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for # information on enabling SSL in the smtp client.  myhostname = lvps5-35-246-107.dedicated.hosteurope.de alias_maps = hash:/etc/aliases, hash:/var/spool/postfix/plesk/aliases alias_database = hash:/etc/aliases myorigin = /etc/mailname mydestination = localhost.localdomain, localhost.dedicated.hosteurope.de, localhost relayhost = mynetworks = 127.0.0.0/8 [::1]/128 5.35.246.107/32 mailbox_command = procmail -a "$EXTENSION" mailbox_size_limit = 51200000 recipient_delimiter = + inet_interfaces = all inet_protocols = all virtual_mailbox_domains = $virtual_mailbox_maps, hash:/var/spool/postfix/plesk/virtual_domains virtual_alias_maps = $virtual_maps, hash:/var/spool/postfix/plesk/virtual virtual_mailbox_maps = hash:/var/spool/postfix/plesk/vmailbox transport_maps = hash:/var/spool/postfix/plesk/transport smtpd_tls_security_level = may smtp_tls_security_level = may smtp_use_tls = no smtpd_timeout = 3600s smtpd_proxy_timeout = 3600s disable_vrfy_command = yes smtpd_sender_restrictions = check_sender_access hash:/var/spool/postfix/plesk/blacklists, permit_sasl_authenticated, check_client_access pcre:/var/spool/postfix/plesk/non_auth.re smtpd_client_restrictions = permit_mynetworks smtp_send_xforward_command = yes smtpd_authorized_xforward_hosts = 127.0.0.0/8 [::1]/128 # SASL #smtpd_sasl_type = dovecot smtpd_sasl_auth_enable = yes #smtpd_sasl_path = smtpd # If your potential clients use Outlook Express or other older clients # this needs to be set to yes broken_sasl_auth_clients = yes smtpd_sasl_security_options = noanonymous smtpd_recipient_restrictions = permit_mynetworks, check_client_access pcre:/var/spool/postfix/plesk/no_relay.re, permit_sasl_authenticated, reject_unauth_destination  virtual_mailbox_base = /var/qmail/mailnames virtual_uid_maps = static:110 virtual_gid_maps = static:31 smtpd_milters = inet:localhost:12768 non_smtpd_milters = inet:localhost:12768 sender_dependent_default_transport_maps = hash:/var/spool/postfix/plesk/sdd_transport_maps virtual_transport = plesk_virtual plesk_virtual_destination_recipient_limit = 1 mailman_destination_recipient_limit = 1 message_size_limit = 10240000 smtpd_tls_loglevel = 4   

y mi master.cf :

  ABCDEFGHIJKLMNABCDEFGHIJKLMN5   

No soy experto en esto, y esto se está volviendo muy molesto ahora. Estaba funcionando perfectamente, y ahora no puedo enviar correos.

Original en ingles

I have a VPS with Plesk Panel on Ubuntu server 10.04. Everything was set up and working perfectly. Only change I made to the mail configuration was to allow submission port 587. Everything was still working: imap, smtp etc.

But yesterday, I think after an update, I noticed I can't send mails. So, now there is no way to make it work.

These are messages I get in /var/log/mail.info:

postfix/smtpd[9523]: warning: SASL authentication failure: no secret in database postfix/smtpd[9523]: warning: SASL DIGEST-MD5 authentication failed: One time use of a plaintext password will enable requested mechanism for user postfix/smtpd[9523]: disconnect... 

There are many tutorials to make postfix work with dovecot, but I'm afraid to install dovecot, because when I run apt-get install dovecot-imapd, it says that many psa-* features will be removed.

Any help is welcome. I didn't mess with anything until last night when I tried some of the solutions I found searching Google, but with no luck at all.

Here are my main.cf:

# See /usr/share/postfix/main.cf.dist for a commented, more complete version   # Debian specific:  Specifying a file name will cause the first # line of that file to be used as the name.  The Debian default # is /etc/mailname. #myorigin = /etc/mailname  smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu) biff = no  # appending .domain is the MUA's job. append_dot_mydomain = no  # Uncomment the next line to generate "delayed mail" warnings #delay_warning_time = 4h  readme_directory = no  # TLS parameters smtpd_tls_cert_file = /etc/postfix/postfix_default.pem smtpd_tls_key_file = $smtpd_tls_cert_file smtpd_use_tls = yes smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache  # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for # information on enabling SSL in the smtp client.  myhostname = lvps5-35-246-107.dedicated.hosteurope.de alias_maps = hash:/etc/aliases, hash:/var/spool/postfix/plesk/aliases alias_database = hash:/etc/aliases myorigin = /etc/mailname mydestination = localhost.localdomain, localhost.dedicated.hosteurope.de, localhost relayhost = mynetworks = 127.0.0.0/8 [::1]/128 5.35.246.107/32 mailbox_command = procmail -a "$EXTENSION" mailbox_size_limit = 51200000 recipient_delimiter = + inet_interfaces = all inet_protocols = all virtual_mailbox_domains = $virtual_mailbox_maps, hash:/var/spool/postfix/plesk/virtual_domains virtual_alias_maps = $virtual_maps, hash:/var/spool/postfix/plesk/virtual virtual_mailbox_maps = hash:/var/spool/postfix/plesk/vmailbox transport_maps = hash:/var/spool/postfix/plesk/transport smtpd_tls_security_level = may smtp_tls_security_level = may smtp_use_tls = no smtpd_timeout = 3600s smtpd_proxy_timeout = 3600s disable_vrfy_command = yes smtpd_sender_restrictions = check_sender_access hash:/var/spool/postfix/plesk/blacklists, permit_sasl_authenticated, check_client_access pcre:/var/spool/postfix/plesk/non_auth.re smtpd_client_restrictions = permit_mynetworks smtp_send_xforward_command = yes smtpd_authorized_xforward_hosts = 127.0.0.0/8 [::1]/128 # SASL #smtpd_sasl_type = dovecot smtpd_sasl_auth_enable = yes #smtpd_sasl_path = smtpd # If your potential clients use Outlook Express or other older clients # this needs to be set to yes broken_sasl_auth_clients = yes smtpd_sasl_security_options = noanonymous smtpd_recipient_restrictions = permit_mynetworks, check_client_access pcre:/var/spool/postfix/plesk/no_relay.re, permit_sasl_authenticated, reject_unauth_destination  virtual_mailbox_base = /var/qmail/mailnames virtual_uid_maps = static:110 virtual_gid_maps = static:31 smtpd_milters = inet:localhost:12768 non_smtpd_milters = inet:localhost:12768 sender_dependent_default_transport_maps = hash:/var/spool/postfix/plesk/sdd_transport_maps virtual_transport = plesk_virtual plesk_virtual_destination_recipient_limit = 1 mailman_destination_recipient_limit = 1 message_size_limit = 10240000 smtpd_tls_loglevel = 4 

and my master.cf:

# # Postfix master process configuration file.  For details on the format # of the file, see the master(5) manual page (command: "man 5 master"). # # Do not forget to execute "postfix reload" after editing this file. # # ========================================================================== # service type  private unpriv  chroot  wakeup  maxproc command + args #               (yes)   (yes)   (yes)   (never) (100) # ========================================================================== #  -o smtpd_tls_security_level=encrypt #  -o smtpd_sasl_auth_enable=yes #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject #  -o milter_macro_daemon_name=ORIGINATING #  -o smtpd_tls_wrappermode=yes #  -o smtpd_sasl_auth_enable=yes #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject #  -o milter_macro_daemon_name=ORIGINATING #628       inet  n       -       -       -       -       qmqpd pickup fifo n - - 60 1 pickup cleanup   unix  n       -       -       -       0       cleanup qmgr fifo n - n 1 1 qmgr #qmgr     fifo  n       -       -       300     1       oqmgr tlsmgr    unix  -       -       -       1000?   1       tlsmgr rewrite   unix  -       -       -       -       -       trivial-rewrite bounce    unix  -       -       -       -       0       bounce defer     unix  -       -       -       -       0       bounce trace     unix  -       -       -       -       0       bounce verify    unix  -       -       -       -       1       verify flush     unix  n       -       -       1000?   0       flush proxymap  unix  -       -       n       -       -       proxymap proxywrite unix -       -       n       -       1       proxymap smtp      inet  n       -       n       -       -       smtpd submission inet  n       -       n      -       -       smtpd # When relaying mail as backup MX, disable fallback_relay to avoid MX loops relay     unix  -       -       -       -       -       smtp         -o smtp_fallback_relay= #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5 showq     unix  n       -       -       -       -       showq error     unix  -       -       -       -       -       error retry     unix  -       -       -       -       -       error discard   unix  -       -       -       -       -       discard local     unix  -       n       n       -       -       local virtual   unix  -       n       n       -       -       virtual lmtp      unix  -       -       -       -       -       lmtp anvil     unix  -       -       -       -       1       anvil scache    unix  -       -       -       -       1       scache # ... 

I am no expert at this, and this is becoming very annoying now. It was working perfectly, and now I can't send mails.

           

Lista de respuestas

1
 
vote

No pude encontrar una solución, pero logré repararlo reinstalando. Publiqué el problema en el foro de Parallels, pero no pude encontrar ayuda.

Finalmente, encontré el enlace ABCDEFGHIJKLMNABCDEFGHIJKLMN3 EN ABCDEFGHIJKLMNABCDEFGHIJKLMNABCDEFGHIJKLMN4 Sección del panel PLESK. Allí fui a "Add component" e install QMail como SMPT, por lo que se eliminó automáticamente Postfix , y nuevamente instalado Postfix , por lo que QMail se elimina automáticamente.

Esto cambió el ABCDEFGHIJKLMNABCDEFGHIJKLMN10 . Luego, acabo de habilitar sudo rm ~/.Xauthority 1 , y dejé todo en el valor predeterminado, como la primera vez.

ahora funciona de nuevo. Las direcciones de correo electrónico se conservan y todo está bien.

Pensé que tal vez alguien con un problema similar podría encontrar esto útil, así que estoy respondiendo a mi pregunta :)

 

I couldn't find a solution, but I managed to repair it by reinstalling. I posted the problem on Parallels forum, but couldn't find help.

Eventually, I found the link "Updates and Upgrades" in "Server" section of the Plesk Panel. There I went to "Add component", and installed QMail as SMPT, so it automatically removed Postfix, and again installed Postfix, so QMail is automatically removed.

This changed Postfix's settings to the default. Then I just enabled submission port again, and left everything at the default, like the first time.

Now it works again. E-mail addresses are preserved and everything is ok.

I thought maybe someone with similar problem could find this useful, so I am answering my question :)

 
 

Relacionados problema

0  "MOTOR SQL 'MYSQL' NO APOYADO" CON SASLAUTH  ( Sql engine mysql not supported with saslauth ) 
Tengo problemas para autenticar la autenticación SMTP entrante en mi servidor Postfix (usando Cyrus SASL con un backend de MySQL). en mi auth.log i obtengo:...

14  "La autenticación SASL falló" con Mutt y Gmail, ¿por qué? [cerrado]  ( Sasl authentication failed with mutt and gmail why ) 
Es poco probable que esta pregunta ayude a cualquier visitante futuro; Solo es relevante para un pequeño área geográfica, u...

1  Fallo de autenticación SASL: Verificación de contraseña Falló SASL + PAM  ( Sasl authentication failure password verification failed saslpam ) 
Estoy golpeando la cabeza sobre esto durante las últimas 4 horas, ¡y no puedo romperlo! Google resulta asignación de problemas relacionados con la falla de au...

3  Ayuda Adaptando Courier-AuthDaemon Inscript  ( Help adapting courier authdaemon initscript ) 
Podría usar la ayuda con adaptar el servicio de mensajería estándar-AuthDaemon. Ejecutar un servidor de pequeñas empresas con Postfix, Courier, Mariad, AmAv...

3  No se puede conectar a Google Talk usando Pidgin (error SASL)  ( Unable to connect to google talk using pidgin sasl error ) 
Después de una nueva instalación de Ubuntu 11.10, Pidgin dejó de conectarse a cualquier servicio de Jabber (Google Talk y un IM local). Lo extraño es que la m...

2  ¿Por qué obtengo un error cuando intento postergar el archivo de contraseña SASL con PostFix?  ( Why do i get an error when i try to postmap sasl password file with postfix ) 
Instalé Postfix recientemente como sistema satelital. Necesito autenticarme en mis proveedores de correo SMPT. Hay necesidades postfix para crear una base de ...

0  Postfix PostgreSQL Dovecot SASL Autenticación falla el servidor Ubuntu 14.04LTS  ( Postfix postgresql dovecot sasl authentication fails ubuntu 14 04lts server ) 
Anteriormente configuré mi servidor de correo usando Ubuntu 12.04LTTS y todos funcionados bien (consulte Postfix Dovecot SASL Autenticación no habilitado / F...

1  Suprimir los mensajes de registro de Cyrus SASL en el archivo de registro de Apache  ( Suppress cyrus sasl log messages in apache log file ) 
Estamos ejecutando el stock Apache 2.4 usando Debian Jessie. Vemos este tipo de entradas de registro en nuestro syslog: ABCDEFGHIJKLMNABCDEFGHIJKLMN9 Al...

0  SASLAUTHD AUTÍO INICIAR DE INICIARIO A PUTFIX CONOCE 454 4.7.0 Fallo de autenticación temporal: falla genérica  ( Saslauthd auth login to postfix meet 454 4 7 0 temporary authentication failure ) 
Cuando utilice Cyrus SASL a AUTH POSTFIX, cumpla con 454 4.7.0 Fallo de autenticación temporal: falla genérica. La cadena de autentas fue Telnet - & GT; Postf...

4  ¿Cómo instalo Cyrus-SASL en el servidor 10.04?  ( How do i install cyrus sasl on 10 04 server ) 
Este indica que hay un modinfo iwlwifi | grep 82650 Paquete, pero no parece estar disponible en los repositorios? Necesito instalar Cyrus SASL para usar...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos