Instalación de Rstudio en un Chromebook con Ubuntu 16.04.7 Xenial: qt.qpa.xcb: no se pudo conectar a la pantalla -- 16.04 campo con qt campo con xfce4-terminal campo con rstudio camp askubuntu Relacionados El problema

Installing Rstudio on a Chromebook with Ubuntu 16.04.7 Xenial: qt.qpa.xcb: could not connect to display


0
vote

problema

Español

Esta es la información de mi sistema, y ​​lo estoy ejecutando de un Libro de Pixel de Chromebook:

  LSB modules are available. Distributor ID: Ubuntu Description:    Ubuntu 16.04.7 LTS Release:        16.04 Codename:       xenial   

Corrí estas líneas de código para instalar R:

  sudo echo "deb https://cloud.r-project.org/bin/linux/ubuntu xenial-cran40/" | sudo tee -a /etc/apt/sources.list  gpg --keyserver keyserver.ubuntu.com --recv-key E298A3A825C0D65DFD57CBB651716619E084DAB9  gpg -a --export E298A3A825C0D65DFD57CBB651716619E084DAB9 | sudo apt-key add -  sudo apt-get update  sudo apt-get install r-base r-base-dev   

Intenté ejecutar Rstudio, pero me di cuenta de que este comando no existía, así que entonces corrí

  sudo apt-get install gdebi-core wget https://download2.rstudio.org/rstudio-server-1.1.414-amd64.deb sudo gdebi rstudio-server-1.1.414-amd64.deb   

y esto fue devuelto:

  Setting up rstudio-server (1.4.1103) ... Couldn't find an alternative telinit implementation to spawn.   

Se solucionó esto al descargar el archivo Deb de la derecha en lugar de llevarlo desde un servidor desactualizado

  ABCDEFGHIJKLMNABCDEFGHIJKLMN5   

Pero cuando intenté ejecutar RSTUDIO, obtengo este error:

  qt.qpa.xcb: could not connect to display  qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found. This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.  Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.  Aborted (core dumped)   

He intentado seguir lo que otros usuarios hicieron en línea, pero nada funciona.

¿Puede alguien caminar por favor a través de cómo resolver esto? Los comentarios sobre la actualización de una versión más reciente de Ubuntu no son útiles.

Original en ingles

This is my system information, and I'm running it off of a Chromebook Pixelbook:

LSB modules are available. Distributor ID: Ubuntu Description:    Ubuntu 16.04.7 LTS Release:        16.04 Codename:       xenial 

I ran these lines of code to install R:

sudo echo "deb https://cloud.r-project.org/bin/linux/ubuntu xenial-cran40/" | sudo tee -a /etc/apt/sources.list  gpg --keyserver keyserver.ubuntu.com --recv-key E298A3A825C0D65DFD57CBB651716619E084DAB9  gpg -a --export E298A3A825C0D65DFD57CBB651716619E084DAB9 | sudo apt-key add -  sudo apt-get update  sudo apt-get install r-base r-base-dev 

I tried running rstudio, but realized that this command didn't exist, so then I ran

sudo apt-get install gdebi-core wget https://download2.rstudio.org/rstudio-server-1.1.414-amd64.deb sudo gdebi rstudio-server-1.1.414-amd64.deb 

And this was returned:

Setting up rstudio-server (1.4.1103) ... Couldn't find an alternative telinit implementation to spawn. 

Fixed this by downloading the right deb file instead of taking it from an outdated server

wget https://download2.rstudio.org/server/xenial/amd64/rstudio-1.4.1103-amd64.deb sudo apt install ./rstudio-1.4.1103-amd64.deb 

but when I tried to run rstudio I get this error:

qt.qpa.xcb: could not connect to display  qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found. This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.  Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.  Aborted (core dumped) 

I've tried following what others users did online, but nothing works.

Can someone please walk me through how to solve this? Comments on updating to a newer version of Ubuntu aren't helpful.

           
     
     

Lista de respuestas


Relacionados problema

0  Han instalado libssl1.0.0 pero aún así obteniendo el error, "libssl.so.1.0.0: no se puede abrir el archivo de objeto compartido: no hay dicho archivo o directorio"  ( Have installed libssl1 0 0 but still getting the error libssl so 1 0 0 cannot ) 
Instalé LIBSSL [1] y parece que se debe hacer correctamente, pero aún así obtener el error siguiente al intentar abrir un programa dependiente (RSTUDIO). [1...

1  Removiendo RSTUDIO y su usuario del sistema  ( Removing rstudio and its user from the system ) 
i instalado rstudio en mi sistema, pero no lo necesito ahora. Ha creado su propio usuario. Cada vez que enciendo mi sistema, aparecen dos usuarios en la pan...

2  Instalación de paquetes R con dependencias  ( Installing r packages with dependencies ) 
He hecho recientemente el movimiento de Windows a Ubuntu (en realidad por la segunda vez, ¡pero creo que esta vez es de verdad!), Y he logrado instalar R y Rs...

4  Problema con la dependencia de la instalación de RIGUIO R en Ubuntu 16.10  ( Issue with dependency of r studio installation in ubuntu 16 10 ) 
sudo dpkg -i rstudio-1.0.136-amd64.deb(Lendo banco de dados ... 213133 ficheiros e directórios actualmente instalados.) A preparar para desempacotar rstudio-...

0  Errores que instalan RGDAL en RSTUDIO 1.1 en Ubuntu 16.04  ( Errors installing rgdal in rstudio 1 1 on ubuntu 16 04 ) 
Estoy usando: Ubuntu 16.04.4 lts anaconda-navigator 1.7.0 RSTUDIO 1.1.383 dentro de la consola, envío & gt; install.packages ('rgdal') y obtén lo ...

0  La restauración de la duplicidad salió mal  ( Duplicity restore went wrong ) 
Uso de - Force En un experimento de restauración de duplicidad, hice la duplicidad accidentalmente, elimine numerosas carpetas. Sí, es posible destruir datos ...

6  Script de instalación de R & Rstudio para Ubuntu 18.04: Paquetes TDD [CERRADO]  ( R rstudio installation script for ubuntu 18 04 tdd packages ) 
cerrado . Esta pregunta debe ser más enfocado . Actualmente no está aceptando respuestas. ...

0  Dependencia no satisfecha al instalar RSTUDIO en Ubuntu 16.10  ( Unmet dependency while installing rstudio on ubuntu 16 10 ) 
Así que descargué Rstudio y yo intenté instalarlo con Gdebi en mi Ubuntu 16.10 sudo gdebi rstudio-0.99.903-amd64.deb El mensaje de error This packag...

0  Error al cargar rstudio  ( Error loading rstudio ) 
Error: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory intentado: $ sudo apt-get inst...

2  ¿Cómo habilitar el menú global de la aplicación en RSTUDIO?  ( How to enable global application menu in rstudio ) 
en Ubuntu 15.04 Unity , ¿cómo puedo permitir la barra de menú global para la aplicación qt rstudio ? Encontré un 12.04 Pregunta , que no se resolvió y ...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos