Archivo faltante / usr / share / proj / EPSG en Ubuntu 20.04 -- apt campo con package-management camp askubuntu Relacionados El problema

Missing file /usr/share/proj/epsg on Ubuntu 20.04


1
vote

problema

Español

Yo uso Ubuntu 20.04.1 LTS y durante mucho tiempo (Debian 7) el ABCDEFGHIJKLMNABCDEFGHIJKLMNABCDEFGHIJKLMN0 BIBLIOTECA DE PROYECCIÓN. Por lo general, los paquetes se instalan a través de

  sudo apt install proj-bin proj-data libproj-dev     

Desafortunadamente El repositorio compartido ABCDEFGHIJKLMNABCDEFGHIJKLMN2 no está completamente equipado con todos los archivos como bajo Ubuntu 18.04. Falta el archivo /usr/share/proj/epsg por ejemplo.

¿Dónde está el archivo de proyección EPSG ahora?

Original en ingles

I use Ubuntu 20.04.1 LTS and for a long time (Debian 7) the proj projection library. Usually the packages are installed via

sudo apt install proj-bin proj-data libproj-dev   

Unfortulally the shared repository /usr/share/proj is not fully equiped with all files like under Ubuntu 18.04. I missing the file /usr/share/proj/epsg for example.

Where is the epsg projection file to be found now?

     

Lista de respuestas

1
 
vote

La estructura del paquete parece ser cambiada aguas arriba. Puede comparar los contenidos del paquete con la tabla a continuación:

Ubuntu versión proj-data Versión del paquete Lista de archivos 18.04 lts 4.9.3-2 https://packages.ubuntu.com/bionic/all/proj -Data / FileList 20.04 lts 6.3.1-1 https://packages.ubuntu.com/focal/all/proj -Data / FileList

El archivo epsg se puede obtener del paquete de 18.04 lts o desde https://salsa.debian.org/debian-gis-team/proj//blob/debian/5.0.0-4/nad/ EPSG . Para obtener detalles oficiales: marque la https://proj.org .

 

The package structure seems to be changed upstream. You can compare package contents with table below:

Ubuntu version proj-data package version File list
18.04 LTS 4.9.3-2 https://packages.ubuntu.com/bionic/all/proj-data/filelist
20.04 LTS 6.3.1-1 https://packages.ubuntu.com/focal/all/proj-data/filelist

The epsg file may be obtained from 18.04 LTS package or from https://salsa.debian.org/debian-gis-team/proj/-/blob/debian/5.0.0-4/nad/epsg . To get official details - check the https://proj.org.

 
 
 
 

Relacionados problema

1  ¿Cuáles son los distintos 'anuncios' o 'ANTICIOS' para las actualizaciones de los paquetes?  ( What are the various announcements or notices for package updates ) 
Recientemente, me encontré con USN - Ubuntu Security Notices y DSA - Debian Security anuncian y descubrí que estas son las listas de correo para las actualiza...

0  Instalación de paquetes de Ubuntu dentro del script de Python  ( Installing ubuntu packages within python script ) 
Quiero instalar los siguientes paquetes dentro de My Python Script: python-pip python-sqlalchemy mongodb python-bson python-dpkt python-jinja2 python-magi...

8  Subproceso de instalación de postes Docker-CE nunca termina  ( Docker ce post installation subprocess never finishes ) 
Intenté instalar docker-ce siguiendo las instrucciones proporcionadas en la documentación oficial de Docker usando el repositorio . La instalación se atasc...

2  Instale paquetes de la pila de habilitación de hardware LTS para Ubuntu 14.04.3 tiene dependencias no satisfechas  ( Install packages from lts hardware enablement stack for ubuntu 14 04 3 has unmet ) 
Pude instalar el nuevo kernel, 3.19, sin embargo, cuando intento obtener los nuevos paquetes para la pila de habilitación de hardware e intente este comando ...

5  ¿Equivalente a la historia de Yum?  ( Equivalent to yum history ) 
¿Hay un equivalente a yum history en Ubuntu? Soy consciente de que puedo mirar los registros de Apt, pero estoy buscando algo que lo enumere a todos en la l...

1  / usr / local / bin / Bower: No hay dicho archivo o directorio después de reinstalar node.js y Bower  ( Usr local bin bower no such file or directory after reinstalling node js and b ) 
Reinstalé nodejs ( node , abcdefhijklmnabcdefghijklmn6 ) Debido a una antigua configuración corruptida. De lo que instalé bower ABCDEFGHIJKLMNABCDEFGH...

1  Ubuntu 20.04.1 LTS: "Ubuntu-Security-Status" afirma "0 Recibe actualizaciones de paquetes con LTS". ¿Tengo que preocuparme?  ( Ubuntu 20 04 1 lts ubuntu security status states 0 receive package updates w ) 
Probablemente esté roto. En mi máquina veo esto: # ubuntu-security-status 2131 packages installed, of which: 0 receive package updates with LTS until 4...

2  ¿Qué pasa con los paquetes de Taskel Ubuntustudio?  ( Whats wrong with tasksel ubuntustudio packages ) 
Tratando de instalar cualquiera de las "tareas" de Ubuntustudio- (Ubuntustudio-Audio-Audio-Audio, Ubuntustudio-Audio-Audio, Ubuntustudio-Font-Meta, etc.) con ...

3  No se pueden instalar controladores para mi tarjeta WiFi Realtek RTL8723BE en Ubuntu 16.10  ( Cannot install drivers for my realtek rtl8723be wifi card in ubuntu 16 10 ) 
intentado $ sudo add-apt-repository ppa:hanipouspilot/rtlwifi $ sudo apt-get update $ sudo apt-get install rtlwifi-new-dkms linux-firmware pero dand...

1  ¿Cómo instalar BillReminder 0.4.0?  ( How to install billreminder 0 4 0 ) 
Me gustaría probar el programa billreminder 0.4.0 . Pero necesito un poco de ayuda para instalarlo. No parece haber un paquete .deb disponible en el centro d...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos