Luchando para crear paquetes de Debian Python3 -- python3 campo con deb campo con packaging camp askubuntu Relacionados El problema

Struggling to create python3 debian packages


0
vote

problema

Español

Configuré https://github.com/mirahezebots/mirahezebots/pull/436 que debe ejecutar Make-Deb, entonces DPKG-BuildPackage -US -UC, pero eso no parece funcionar por https://github.com/mirahezebots/mirahezebots/pull/436/checks?check_run_id=1919896022

Cuando lo ejecuto localmente, el registro de cambios no parece estar bien generado, pero también veo menciones de Python2.

es un funcionario de GAIN-DEB o ¿hay una manera de crear unOG de Debian, basado en mi archivo Changelog / una buena manera de formatearlo?

¿Cómo puedo asegurarme de que el paquete preferirá Python3?

¡Gracias de antemano!

Original en ingles

I setup https://github.com/MirahezeBots/MirahezeBots/pull/436 which should run make-deb then dpkg-buildpackage -us -uc but that doesn't seem to work per https://github.com/MirahezeBots/MirahezeBots/pull/436/checks?check_run_id=1919896022

When I run it locally, the changelog doesn't seem to be well generated but I also see mentions of python2.

Is make-deb still functional or is there a way to create a debian changelog based off my changelog file / a good way to format it?

How do I also ensure the package will prefer python3?

Thanks in advance!

        
 
 

Lista de respuestas


Relacionados problema

4  ¿Cómo puedo hacer un programa (usando SDL) construido sobre el trabajo de Ubuntu en otros sistemas?  ( How can i make a program using sdl built on ubuntu work on other systems ) 
Estoy escribiendo un programa que usa Openal. Cuando vengo contra esto (estoy usando Cmake), también se enlaza contra Libpulse - PulseAudio. Esto resulta en e...

128  ¿Cómo obtener mi software en Ubuntu?  ( How to get my software into ubuntu ) 
Como desarrollador de software libre, quiero obtener mi solicitud en Ubuntu. ¿Debo proporcionar un tarball de origen y pedir envases? ¿O debería crear un pa...

6  Embalaje de Ubuntu en BZR  ( Ubuntu packaging in bzr ) 
Hace un tiempo hubo hablar de mover todos (o al menos algunos?) Del esfuerzo de embalaje a las sucursales BZR en launchpad. Parece que recuerdo que hubo una s...

7  Utilizando el controlador Beta de NVIDIA 302.XX habilitado para RANDR en 12.04 con un kernel en tiempo real  ( Using the randr enabled nvidia 302 xx beta driver in 12 04 with a realtime kerne ) 
¿Cómo puedo usar la versión beta reciente de la versión 302 del controlador NVIDIA (que finalmente apoya la extensión RANDR!) Con un kernel en tiempo real en ...

1  Crear paquete fuente PPA del paquete .DEB existente  ( Create ppa source package from existing deb package ) 
Quiero modificar algunos archivos en el paquete .deb y cargarlo a mi PPA, ¿Es eso posible y cómo? Gracias de antemano ...

15  ¿Cómo tener un embalaje Debian generar dos paquetes dado un archivo fuente ascendente?  ( How to have debian packaging generate two packages given an upstream source arch ) 
Estoy envasando algo para mi PPA. La fuente ascendente es un archivo .tar.gzDefghijklmn4 que está basado en makefile. Dado que este paquete tiene una cant...

1  Instale Python2.7 Problemas de dependencias insatisfechas - Ubuntu 18.04  ( Install python2 7 unmet dependencies problems ubuntu 18 04 ) 
Recientemente limpio, reinstaló Ubuntu 18.04 y ahora quería instalar Python2.7 para varias otras dependencias, sin embargo, no puedo hacerlo. Correr sudo apt...

1  ignora rápidamente la subcarpeta  ( Quickly ignores subfolder ) 
Tengo un problema con el embalaje rápidamente. Tengo un proyecto foo: foo / foo / bar / foo_lib / DATOS / cuando corro ABCDEFGHIJKLMNABCDEFGHI...

18  ¿Cómo involucrar a más personas en mejorar X.org para Ubuntu? [cerrado]  ( How to get more people involved in improving x org for ubuntu ) 
cerrado . Esta pregunta debe ser más enfocado . Actualmente no está aceptando respuestas. ...

6  ¿Cuál es la forma correcta de crear tus propios paquetes para la instalación local?  ( What is the correct way to create your own packages for local installation ) 
Estoy ejecutando un servidor Ubuntu 12.04 LTS. Actualmente tengo un problema donde uno de mis paquetes usados ​​tiene un error molesto. En lugar de eliminarlo...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos