¿Pueden los liberaciones de LTS dar lugar a ponerse "atascado" sin una forma de actualizar? -- apt campo con upgrade campo con lts camp askubuntu Relacionados El problema

Can LTS releases result in getting “stuck” without a way to upgrade?


0
vote

problema

Español

Hace aproximadamente un año, invierno de 2020, instalé Kubuntu 19.10 y se mantuvo con actualizaciones periódicas a través de la GUI "Discovery". Pero nunca me notificó acerca de la necesidad de actualizar a 20.04 y ahora estoy atascado con un ABCDEFGHIJKLMNABCDEFGHIJKLMNEBCDEFGHIJKLMN0 Necesito pasar por un proceso particular (que preferiría que no tener que hacer) para EOL actualizaciones.

¿Es esta situación única a lanzamientos impares (como 19.10, 17.04, etc.)?

¿Puede esta situación también se produce cuando en un lanzamiento de LTS? LTS Lanzamientos Tomar más tiempo para llegar a EOL, pero ¿qué sucede entonces? ¿Puede este estado estancado / roto / roto ?

Original en ingles

About a year ago, Winter of 2020, I installed Kubuntu 19.10 and kept up with regular updates through the "Discovery" gui. But it never notified me about the need to upgrade to 20.04 and now I'm stuck with a broken apt in need of going through a particular process(which I would much prefer not having to do) for EOL upgrades.

Is this situation unique to odd-numbered releases (like 19.10, 17.04 etc)?

Can this situation also occur when on an LTS release? LTS releases take longer to reach EOL, but what happens then? Can this stuck/broken state still occur?

        
 
 

Lista de respuestas

1
 
vote

La situación puede ocurrir en cualquier liberación de Ubuntu, ya que un apartamento estancado / roto suele ser causado por la locura del humano.

Por mucho, las causas más comunes de un APT estancado / roto son repositorios de terceros (no ubuntu), PPA, repositorios de versiones incorrectas y / o paquetes descargados manualmente.

La causa más común de la liberación atascada por A-Missed es que hizo clic en "No me recuerdes nuevamente" cuando el sistema le indicó que se dispone de una versión más nueva de Ubuntu. Eso también cuenta como la locura humana.

Evitar aquellos, y no tendrás un apartamento atascado.

Si está utilizando una versión de 32 bits (I386) de Ubuntu 18.04, no obtendrá las indicaciones de actualización para 20.04 o versiones más nuevas. Ubuntu ha bajado la pila de escritorio de 32 bits desde 18.04. Sin embargo, simplemente debe obtener una notificación de este caso en lugar de un apartamento estancado / roto. Los libs de 32 bits para vapor y vino y otros casos continúan actualizados normalmente en sistemas de 64 bits (AMD64).

  • Si puede reproducir un apartamento atascado / roto en una instalación de acciones de Ubuntu utilizando solo paquetes en la versión correcta de los repositorios de Ubuntu (y sin usar Device Start End Sectors Size Type /dev/nvme0n1p1 2048 2000895 1998848 976M EFI System /dev/nvme0n1p2 2000896 936214527 934213632 445.5G Linux filesystem /dev/nvme0n1p3 936214528 1000214527 64000000 30.5G Linux swap 4 ), presente un error Informe para que podamos arreglarlo.

  • Si puede reproducir el sistema, nunca se le solicite a la actualización en una instalación de acciones de la versión anterior (que aún se admite), luego presente un informe de errores. Los desarrolladores de Ubuntu definitivamente quieren saber, paso a paso, cómo logró eso.

  • apt proporciona mucha salida de resolución de problemas. Consejo: Léelo. Cada vez.

 

The situation can occur on ANY release of Ubuntu, since a stuck/broken apt is usually caused by the human's folly.

By far, the most common causes of a stuck/broken apt are third-party (non-Ubuntu) repositories, PPAs, wrong-version repositories, and/or manually downloaded packages.

The most common cause of stuck-by-a-missed release is that you clicked "do not remind me again" when the system DID prompt you that a newer release of Ubuntu is available. That also counts as human folly.

Avoid those, and you won't have a stuck apt.

If you are using a 32-bit (i386) version of Ubuntu 18.04, you won't get upgrade prompts for 20.04 or newer releases. Ubuntu has dropped the 32-bit Desktop stack since 18.04. However, you should simply get a notification from this case instead of a stuck/broken apt. 32-bit libs for steam and wine and other cases continue to be upgraded normally on 64-bit (amd64) systems.

  • If you can reproduce a stuck/broken apt on a stock install of Ubuntu using only packages in the correct version of the Ubuntu repositories (and without using --force), please file a bug report so we can fix it.

  • If you can reproduce system-never-prompted-me-to-upgrade on a stock install of the previous release (that is still supported), then please file a bug report. The Ubuntu developers definitely want to know, step-by-step, how you accomplished that.

  • Apt provides lots of troubleshooting output. Advice: Read it. Every time.

 
 
   
   
0
 
vote

si. Los repositorios para versiones anteriores que no son compatibles se mueven a un servidor de archivo. Esto sucede más rápido en versiones no LTS.

https://ubuntu.com/about/release-cycle

Para corregir APT, debe actualizar su archivo Sources.List para preparar old-releases como se explica en

Cómo instalar software o actualizar de ¿Una antigua liberación no compatible?

 

Yes. The repositories for older releases that are not supported get moved to an archive server. This happens quicker in non LTS versions.

https://ubuntu.com/about/release-cycle

To fix apt, you need to update your sources.list file to prepend old-releases as explained in

How to install software or upgrade from an old unsupported release?

 
 

Relacionados problema

0  Ubuntu 18.04.4 LTS lento en AMD 4300 8GB RAM  ( Ubuntu 18 04 4 lts slow on amd 4300 8gb ram ) 
He instalado la versión Ubuntu 18.04.4 LTS en una PC de escritorio con procesador AMD 4300 Quad Core, 8GB RAM y HDD HDD de 160 GB. lleva más de dos minutos ...

2  Instale paquetes de la pila de habilitación de hardware LTS para Ubuntu 14.04.3 tiene dependencias no satisfechas  ( Install packages from lts hardware enablement stack for ubuntu 14 04 3 has unmet ) 
Pude instalar el nuevo kernel, 3.19, sin embargo, cuando intento obtener los nuevos paquetes para la pila de habilitación de hardware e intente este comando ...

0  No puedo obtener nuevas actualizaciones [duplicar]  ( I cannot get new updates ) 
Esta pregunta ya tiene respuestas aquí : ¿Cómo lo hacen? Arreglo un error "Problema con Mergelist" o...

15  Ruta sana a las actualizaciones de distribución  ( Sane path to distribution upgrades ) 
Estoy usando Hardy (servidor) en bastantes máquinas y me gustaría actualizar a los últimos LTS. ¿Es seguro editar mi archivo ubuntu-security-status7 para ap...

2  Al despertar esta computadora, aparecieron personajes de la cara de Blue Wierd  ( When waking up this computer blue wierd face characters appeared ) 
Estoy ejecutando Ubuntu 18.04.3 LTS (GNU / Linux 4.15.0-62-genérico i686) y cada vez que se cierra la tapa de la computadora, se va a dormir y luego se despie...

0  LDAP y clientes delgados  ( Ldap and thin clients ) 
Actualmente tengo una configuración de Sun / Oracle Enterprise Directory Server. Quiero, si es posible, autenticar mis finos clientes LTS para evitar la carga...

9  ¿Necesito tomar medidas en un servidor de 10.04 LTS para evitar la vulnerabilidad hiedra?  ( Do i need to take action on a 10 04 lts server to avoid the heartbleed vulnerabi ) 
Desde el sitio web de HeartBleed.com, veo que OpenSSL 0.9.8 no es vulnerable, que es la versión que está disponible en 10.04. Eso debería significar que realm...

2  Crear accesos directos de escritorio para transmisiones de medios  ( Create desktop shortcuts for media streams ) 
DESAFÍO: Creación de 7 accesos directos diferentes para flujos de audio como este: http://live-icy.gss.dr.dk /A/a03h.mp3.m3u Unos años atrás cuando busq...

0  Drivers AMDGPU y Ubuntu 16.04.04 LTS  ( Amdgpu drivers and ubuntu 16 04 04 lts ) 
Así que he intentado instalar AMDGPU y al sitio en una nueva instalación de Ubuntu 16.04.04 LTS para obtener mi Rx Vega 64 que trabaja y no funciona como se e...

4  Versiones de software de LTS y lanzamientos no LTS sincronizados de Debian  ( Software versions of lts and non lts releases synced from debian ) 
Leí que los lanzamientos de LTS se basan en las pruebas de Debian, mientras que las liberaciones no LTS se basan en Debian inestable. Dado el ciclo de liberac...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos