PHP FPM funcionando, pero ignorando la versión de SetHandler -- apache2 campo con php campo con php5-fpm camp askubuntu Relacionados El problema

PHP FPM Working, but ignoring version from SetHandler


0
vote

problema

Español

Nuestro servidor es Ubuntu 18.04.5 LTS (GNU / Linux 4.15.0-135-Genérico X86_64).

seguimos las instrucciones desde https://tecadmin.net/installall - Multiple-PHP-Version-Apache-Ubuntu / A GURANTE y obtuvo PHP 5.6 y 7.2 Correr cuando 7.2 fue nuevo y ha actualizado y agregado 7.3 y 7.4 sin problemas hasta esta mañana. Ayer funcionó bien, pero hoy no lo es. Apagamos la actualización a principios de ayer, pero no requirió un reinicio y no lo creo que reinicie durante la noche por sí sola como uptime dice que estamos cerca de 15 días.

Así que hoy nos ponemos en marcha por el proceso y lo han hecho, reiniciando Apache2 después de cada paso:

Probado: ABCDEFGHIJKLMNABCDEFGHIJKLMN7 y GOT: ERROR: ¡El módulo FCGID no existe!

hice apt install apache2 libapache2-mod-fcgid y que trabajó y agregó el paquete.

hice a2enmod actions fcgid alias proxy_fcgi y dijo todo ya habilitado .

Controlado FREF FILE IN / etc / apache2 / sites-habilitado :

  root0  

intentado phpinfo () página y obtuvo PHP 7.4.15 en lugar de esperado 5.6.40. Hicimos lo mismo con un 7.3 y obtuvimos lo mismo 7.4 en PhpInfo () con SetHandler de PHP7.3 también.

luego intentado systemctl status php5.6-fpm y php7.4-fpm y ambos activos (en ejecución)

Mi archivo /etc/apache2/conf/php5.6-fpm.conf está aquí para empezar, y el para PHP7.4-FPM.conf es el mismo, excepto MOD_PHP5 / 7 y la versión de SetHandler:

  root1  

¿Hay algún error aquí o en algún otro lugar que deba mirar?

FWIW, tenemos otro servidor con una configuración similar y está teniendo el mismo problema, pero solo necesitamos la aplicación 5.6 heredada en ese servidor en este momento para que simplemente desactivemos 7.4 al eliminar el archivo puntero en / etc / apache2 /conf-enabled/php7.4-fpm.conf y reiniciando Apache2. Sin embargo, este servidor necesita varias versiones.

Original en ingles

Our server is Ubuntu 18.04.5 LTS (GNU/Linux 4.15.0-135-generic x86_64).

We followed the directions from https://tecadmin.net/install-multiple-php-version-apache-ubuntu/ a while back and got PHP 5.6 and 7.2 running back when 7.2 was new, and have upgraded and added 7.3 and 7.4 with no problems until this morning. Yesterday it worked fine but today it is not. We package update early yesterday but it didn't require a reboot and don't believe it rebooted overnight on its own as uptime says we're close to 15 days.

So today we set about going through the process again and have done this, restarting apache2 after every step:

Tried: a2enmod actions fcgid alias proxy_fcgi and got: ERROR: Module fcgid does not exist!

Did apt install apache2 libapache2-mod-fcgid and that worked and added the package.

Did a2enmod actions fcgid alias proxy_fcgi and it said everything already enabled.

Checked conf file in /etc/apache2/sites-enabled:

<FilesMatch \.php$>     SetHandler "proxy:unix:/var/run/php/php5.6-fpm.sock|fcgi://localhost" </FilesMatch> 

Tried phpinfo() page and got PHP 7.4.15 instead of expected 5.6.40. We did the same with a 7.3 and got the same 7.4 on phpinfo() using SetHandler of php7.3 as well.

Then tried systemctl status php5.6-fpm and php7.4-fpm and both active (running)

My /etc/apache2/conf/php5.6-fpm.conf file is here for starters, and the one for php7.4-fpm.conf is the same except for mod_php5/7 and the SetHandler version:

# Redirect to local php-fpm if mod_php is not available <IfModule !mod_php5.c> <IfModule proxy_fcgi_module>     # Enable http authorization headers     <IfModule setenvif_module>     SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1     </IfModule>      <FilesMatch ".+\.ph(ar|p|tml)$">         <If "-f %{REQUEST_FILENAME}">             SetHandler "proxy:unix:/run/php/php5.6-fpm.sock|fcgi://localhost"         </If>     </FilesMatch>     <FilesMatch ".+\.phps$">         # Deny access to raw php sources by default         # To re-enable it's recommended to enable access to the files         # only in specific virtual host or directory         Require all denied     </FilesMatch>     # Deny access to files without filename (e.g. '.php')     <FilesMatch "^\.ph(ar|p|ps|tml)$">         Require all denied     </FilesMatch> </IfModule> </IfModule> 

Is there an error here or somewhere else I should look?

FWIW, we have another server with a similar setup and it is having the same issue, but we only need the 5.6 legacy application on that server at this time so we just disabled 7.4 by removing the pointer file in /etc/apache2/conf-enabled/php7.4-fpm.conf and restarting apache2. However, this server needs multiple versions.

        

Lista de respuestas


Relacionados problema

0  No se inicia la página MyPHPADMIN, me da 404 error. ¿Cómo lo resolverá?  ( Myphpadmin page is not started it gives me 404 error how to solve it ) 
Instalé todos los paquetes Apache, MySQL, PHP.Phut My PhpMyAdmin no es trabajo. mitesh@mitesh-Inspiron-N5010:~$ sudo apt-get install phpmyadmin [sudo] pas...

3  ¿Cómo permitir que PHP5-FPM ejecute archivos de usuario sin cambiar implícitamente los permisos cada vez?  ( How to allow php5 fpm to execute user files without implicitly changing permissi ) 
Recientemente cambié a Ubuntu. Una de las herramientas que utilicé con frecuencia fue XAMPP. Cuando instalé la pila de lámpara en Ubuntu, noté un aumento impo...

0  Cómo instalar PHP FASTCGI en el servidor Ubuntu 17.4  ( How to install php fastcgi on ubuntu 17 4 server ) 
Cómo instalar PHP FASTCGI en el servidor Ubuntu 17.4 para la versión PHP 5.6. Por defecto, ha instalado PHP 7.1. Tengo pocos sitios que no son compatibles con...

0  El código PHP viene como está en el navegador  ( Php code comes as it is in browser ) 
He instalado PHP como se indica en el enlace Instalación de PHP 5.3 en Ubuntu 14.04 , El comando php -v muestra la versión correcta al comando, pero cuando e...

1  Ubuntu 14 / Apache 2.4 con PHP5-FPM a través de MOD_PROXY_FCGI RETRENDE CODIFICACIÓN MUERTE CODIFICADA  ( Ubuntu 14 apache 2 4 with php5 fpm via mod proxy fcgi return wrong chunked enc ) 
No vio ningún informe de este problema en ninguna parte. Cuando se utiliza Apache 2.4 con PHP5-FPM usando MOD_PROXY_FCGI, el contenido codificado, el último b...

1  Cómo instalar CakePHP en Ubuntu 14.04  ( How to install cakephp in ubuntu 14 04 ) 
Estoy usando Ubuntu 14.04 para y la configuración de la lámpara se ejecuta en ella. En algunos proyectos de CakePHP, no mostró algo de contenido o no redirigi...

0  ¿Qué php.ini usando FPM?  ( Which php ini using fpm ) 
Tengo un servidor Ubuntu 16.04 nuevo que estoy instalando una aplicación basada en Symfony. Dice que la fecha. Tiempo necesita para ser establecido. Lo sufici...

2  Error al instalar PHPMYAdmin Package en Ubuntu 14.04 [CERRADO]  ( Error while installing phpmyadmin package in ubuntu 14 04 ) 
cerrado . Esta pregunta necesita detalles o claridad . Actualmente no está aceptando respuestas. ...

2  ¿Cómo actualizar a PHP 5.5.25 (la última versión lanzada de PHP) en Ubuntu 12.04 LTS de 64 bits?  ( How to upgrade to php 5 5 25the latest stable released version of php on ubunt ) 
Intenté seguir los comandos, pero después de ejecutar estos comandos, me pasaron de php 5.5.23 a php 5.5.24 . Quiero actualizar a php 5.5.25 , que es una ...

0  Apache con el trabajador MPM que da un error: su módulo PHP no está compilado para ser Threadsafe. Necesitas volver a compilar PHP  ( Apache with worker mpm giving error your php module is not compiled to be thre ) 
Estoy teniendo Ubuntu 14.10 y Apache 2.4. Actualmente Apache está ejecutando Predeterminado MPM_PREFORK y quiero cambiarlo a MPM_Worker. Seguí este apache ...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos