El servicio FWUPD no se inicia -- 20.10 campo con firmware campo con fwupd camp askubuntu Relacionados El problema

fwupd service fails to start


0
vote

problema

Español

por un tiempo ahora tengo un problema con FWUPD.

Inicialmente noté un mensaje de error cada vez que abro el software Ubuntu. El error lee "Error llamando startservicebyname para org.freedesktop.fwupd: Error al activar el servicio ...". Vea la imagen a continuación para obtener más detalles.

Mensaje de error en Ubuntu Software v3.38.1

Cuando intento iniciar FWUPD a través de terminal usando el siguiente comando:

  Reading package lists... Done Building dependency tree        Reading state information... Done ruby is already the newest version (1:2.5.1). The following packages were automatically installed and are no longer required:   command-not-found-data gcc-5-base gir1.2-gst-plugins-base-1.0   gir1.2-gstreamer-1.0 gir1.2-rb-3.0 gir1.2-totem-1.0 gir1.2-totemplparser-1.0   gyp libdmapsharing-3.0-2 libgpod-common libgpod4 libgsoap-2.8.60   libhttp-parser2.7.1 libjs-async libjs-inherits libjs-node-uuid libnetplan0   libsgutils2-2 libssl1.0-dev libuv1 libuv1-dev libvncserver1 libxatracker2   libxnvctrl0 libxvmc1 linux-hwe-5.4-headers-5.4.0-42   linux-hwe-5.4-headers-5.4.0-56 linux-hwe-5.4-headers-5.4.0-58   linux-hwe-5.4-headers-5.4.0-59 linux-hwe-5.4-headers-5.4.0-62 node-abbrev   node-ansi node-ansi-color-table node-archy node-async node-balanced-match   node-block-stream node-brace-expansion node-combined-stream node-concat-map   node-cookie-jar node-delayed-stream node-forever-agent node-form-data   node-fs.realpath node-fstream node-fstream-ignore node-github-url-from-git   node-glob node-graceful-fs node-gyp node-hosted-git-info node-inflight   node-inherits node-ini node-isexe node-json-stringify-safe node-lockfile   node-lru-cache node-mime node-minimatch node-mkdirp node-mute-stream   node-node-uuid node-nopt node-npmlog node-once node-osenv   node-path-is-absolute node-pseudomap node-qs node-read node-request   node-retry node-rimraf node-semver node-sha node-slide node-spdx-correct   node-spdx-expression-parse node-spdx-license-ids node-tar node-tunnel-agent   node-underscore node-validate-npm-package-license node-which node-wrappy   node-yallist nodejs-doc pkg-config Use 'sudo apt autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded. 4 not fully installed or removed. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] y Setting up linux-image-5.4.0-65-generic (5.4.0-65.73~18.04.1) ... Setting up linux-headers-5.4.0-65-generic (5.4.0-65.73~18.04.1) ... /etc/kernel/header_postinst.d/dkms:  * dkms: running auto installation service for kernel 5.4.0-65-generic Error! Could not locate dkms.conf file. File:  does not exist.    ...fail! run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4 dpkg: error processing package linux-headers-5.4.0-65-generic (--configure):  installed linux-headers-5.4.0-65-generic package post-installation script subprocess returned error exit status 1 dpkg: dependency problems prevent configuration of linux-headers-generic-hwe-18.04:  linux-headers-generic-hwe-18.04 depends on linux-headers-5.4.0-65-generic; however:   Package linux-headers-5.4.0-65-generic is not configured yet.  dpkg: error processing package linux-headers-generic-hwe-18.04 (--configure):  dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of linux-generic-hwe-18.04:  linux-generic-hwe-18.04 depends on linux-headers-generic-hwe-18.04 (= 5.4.0.65.73~18.04.60); however:   Package linux-headers-generic-hwe-18.04 is not configured yet.  dpkg: error processing package linux-generic-hwe-18.04 (--configure):  dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure.                           No apport report written because the error message indicates its a followup error from a previous failure.                                                     Processing triggers for linux-image-5.4.0-65-generic (5.4.0-65.73~18.04.1) ... /etc/kernel/postinst.d/dkms:  * dkms: running auto installation service for kernel 5.4.0-65-generic Error! Could not locate dkms.conf file. File:  does not exist.    ...fail! run-parts: /etc/kernel/postinst.d/dkms exited with return code 4 dpkg: error processing package linux-image-5.4.0-65-generic (--configure):  installed linux-image-5.4.0-65-generic package post-installation script subprocess returned error exit status 1 No apport report written because MaxReports is reached already                                                               Errors were encountered while processing:  linux-headers-5.4.0-65-generic  linux-headers-generic-hwe-18.04  linux-generic-hwe-18.04  linux-image-5.4.0-65-generic E: Sub-process /usr/bin/dpkg returned an error code (1) 1  

Obtengo el siguiente mensaje:

  Reading package lists... Done Building dependency tree        Reading state information... Done ruby is already the newest version (1:2.5.1). The following packages were automatically installed and are no longer required:   command-not-found-data gcc-5-base gir1.2-gst-plugins-base-1.0   gir1.2-gstreamer-1.0 gir1.2-rb-3.0 gir1.2-totem-1.0 gir1.2-totemplparser-1.0   gyp libdmapsharing-3.0-2 libgpod-common libgpod4 libgsoap-2.8.60   libhttp-parser2.7.1 libjs-async libjs-inherits libjs-node-uuid libnetplan0   libsgutils2-2 libssl1.0-dev libuv1 libuv1-dev libvncserver1 libxatracker2   libxnvctrl0 libxvmc1 linux-hwe-5.4-headers-5.4.0-42   linux-hwe-5.4-headers-5.4.0-56 linux-hwe-5.4-headers-5.4.0-58   linux-hwe-5.4-headers-5.4.0-59 linux-hwe-5.4-headers-5.4.0-62 node-abbrev   node-ansi node-ansi-color-table node-archy node-async node-balanced-match   node-block-stream node-brace-expansion node-combined-stream node-concat-map   node-cookie-jar node-delayed-stream node-forever-agent node-form-data   node-fs.realpath node-fstream node-fstream-ignore node-github-url-from-git   node-glob node-graceful-fs node-gyp node-hosted-git-info node-inflight   node-inherits node-ini node-isexe node-json-stringify-safe node-lockfile   node-lru-cache node-mime node-minimatch node-mkdirp node-mute-stream   node-node-uuid node-nopt node-npmlog node-once node-osenv   node-path-is-absolute node-pseudomap node-qs node-read node-request   node-retry node-rimraf node-semver node-sha node-slide node-spdx-correct   node-spdx-expression-parse node-spdx-license-ids node-tar node-tunnel-agent   node-underscore node-validate-npm-package-license node-which node-wrappy   node-yallist nodejs-doc pkg-config Use 'sudo apt autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded. 4 not fully installed or removed. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] y Setting up linux-image-5.4.0-65-generic (5.4.0-65.73~18.04.1) ... Setting up linux-headers-5.4.0-65-generic (5.4.0-65.73~18.04.1) ... /etc/kernel/header_postinst.d/dkms:  * dkms: running auto installation service for kernel 5.4.0-65-generic Error! Could not locate dkms.conf file. File:  does not exist.    ...fail! run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4 dpkg: error processing package linux-headers-5.4.0-65-generic (--configure):  installed linux-headers-5.4.0-65-generic package post-installation script subprocess returned error exit status 1 dpkg: dependency problems prevent configuration of linux-headers-generic-hwe-18.04:  linux-headers-generic-hwe-18.04 depends on linux-headers-5.4.0-65-generic; however:   Package linux-headers-5.4.0-65-generic is not configured yet.  dpkg: error processing package linux-headers-generic-hwe-18.04 (--configure):  dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of linux-generic-hwe-18.04:  linux-generic-hwe-18.04 depends on linux-headers-generic-hwe-18.04 (= 5.4.0.65.73~18.04.60); however:   Package linux-headers-generic-hwe-18.04 is not configured yet.  dpkg: error processing package linux-generic-hwe-18.04 (--configure):  dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure.                           No apport report written because the error message indicates its a followup error from a previous failure.                                                     Processing triggers for linux-image-5.4.0-65-generic (5.4.0-65.73~18.04.1) ... /etc/kernel/postinst.d/dkms:  * dkms: running auto installation service for kernel 5.4.0-65-generic Error! Could not locate dkms.conf file. File:  does not exist.    ...fail! run-parts: /etc/kernel/postinst.d/dkms exited with return code 4 dpkg: error processing package linux-image-5.4.0-65-generic (--configure):  installed linux-image-5.4.0-65-generic package post-installation script subprocess returned error exit status 1 No apport report written because MaxReports is reached already                                                               Errors were encountered while processing:  linux-headers-5.4.0-65-generic  linux-headers-generic-hwe-18.04  linux-generic-hwe-18.04  linux-image-5.4.0-65-generic E: Sub-process /usr/bin/dpkg returned an error code (1) 2  

Entonces, si ejecuto "systemctl status fwupd.service" entiendo esto:

  Reading package lists... Done Building dependency tree        Reading state information... Done ruby is already the newest version (1:2.5.1). The following packages were automatically installed and are no longer required:   command-not-found-data gcc-5-base gir1.2-gst-plugins-base-1.0   gir1.2-gstreamer-1.0 gir1.2-rb-3.0 gir1.2-totem-1.0 gir1.2-totemplparser-1.0   gyp libdmapsharing-3.0-2 libgpod-common libgpod4 libgsoap-2.8.60   libhttp-parser2.7.1 libjs-async libjs-inherits libjs-node-uuid libnetplan0   libsgutils2-2 libssl1.0-dev libuv1 libuv1-dev libvncserver1 libxatracker2   libxnvctrl0 libxvmc1 linux-hwe-5.4-headers-5.4.0-42   linux-hwe-5.4-headers-5.4.0-56 linux-hwe-5.4-headers-5.4.0-58   linux-hwe-5.4-headers-5.4.0-59 linux-hwe-5.4-headers-5.4.0-62 node-abbrev   node-ansi node-ansi-color-table node-archy node-async node-balanced-match   node-block-stream node-brace-expansion node-combined-stream node-concat-map   node-cookie-jar node-delayed-stream node-forever-agent node-form-data   node-fs.realpath node-fstream node-fstream-ignore node-github-url-from-git   node-glob node-graceful-fs node-gyp node-hosted-git-info node-inflight   node-inherits node-ini node-isexe node-json-stringify-safe node-lockfile   node-lru-cache node-mime node-minimatch node-mkdirp node-mute-stream   node-node-uuid node-nopt node-npmlog node-once node-osenv   node-path-is-absolute node-pseudomap node-qs node-read node-request   node-retry node-rimraf node-semver node-sha node-slide node-spdx-correct   node-spdx-expression-parse node-spdx-license-ids node-tar node-tunnel-agent   node-underscore node-validate-npm-package-license node-which node-wrappy   node-yallist nodejs-doc pkg-config Use 'sudo apt autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded. 4 not fully installed or removed. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] y Setting up linux-image-5.4.0-65-generic (5.4.0-65.73~18.04.1) ... Setting up linux-headers-5.4.0-65-generic (5.4.0-65.73~18.04.1) ... /etc/kernel/header_postinst.d/dkms:  * dkms: running auto installation service for kernel 5.4.0-65-generic Error! Could not locate dkms.conf file. File:  does not exist.    ...fail! run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4 dpkg: error processing package linux-headers-5.4.0-65-generic (--configure):  installed linux-headers-5.4.0-65-generic package post-installation script subprocess returned error exit status 1 dpkg: dependency problems prevent configuration of linux-headers-generic-hwe-18.04:  linux-headers-generic-hwe-18.04 depends on linux-headers-5.4.0-65-generic; however:   Package linux-headers-5.4.0-65-generic is not configured yet.  dpkg: error processing package linux-headers-generic-hwe-18.04 (--configure):  dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of linux-generic-hwe-18.04:  linux-generic-hwe-18.04 depends on linux-headers-generic-hwe-18.04 (= 5.4.0.65.73~18.04.60); however:   Package linux-headers-generic-hwe-18.04 is not configured yet.  dpkg: error processing package linux-generic-hwe-18.04 (--configure):  dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure.                           No apport report written because the error message indicates its a followup error from a previous failure.                                                     Processing triggers for linux-image-5.4.0-65-generic (5.4.0-65.73~18.04.1) ... /etc/kernel/postinst.d/dkms:  * dkms: running auto installation service for kernel 5.4.0-65-generic Error! Could not locate dkms.conf file. File:  does not exist.    ...fail! run-parts: /etc/kernel/postinst.d/dkms exited with return code 4 dpkg: error processing package linux-image-5.4.0-65-generic (--configure):  installed linux-image-5.4.0-65-generic package post-installation script subprocess returned error exit status 1 No apport report written because MaxReports is reached already                                                               Errors were encountered while processing:  linux-headers-5.4.0-65-generic  linux-headers-generic-hwe-18.04  linux-generic-hwe-18.04  linux-image-5.4.0-65-generic E: Sub-process /usr/bin/dpkg returned an error code (1) 3  

Como puede ver, estoy usando una computadora portátil HP (mala decisión), que tiene un Core I5 ​​Intel y está ejecutando Ubuntu 20.10 Groovy. (Puedo proporcionar más información si es necesario).

Si ejecuto "Sudo APT Update - Failing-Failing & Amp; & amp; sudo apt actualizar", muestra que todos los paquetes están actualizados.

¿Alguna idea por favor?

Original en ingles

For a while now I have a problem with fwupd.

Initially I noticed an error message every time I open Ubuntu Software. The error reads "Error calling StartServiceByName for org.freedesktop.fwupd: Failed to activate service...". See image below for more details.

Error message on Ubuntu Software v3.38.1

When I try to start fwupd via terminal using the following command:

$ sudo service fwupd start 

I get the following message:

Job for fwupd.service failed because the control process exited with error code. See "systemctl status fwupd.service" and "journalctl -xe" for details. 

So if I run "systemctl status fwupd.service" I get this:

######@HP-ENVY-Notebook:~$ systemctl status fwupd.service  xe2x97x8f fwupd.service - Firmware update daemon      Loaded: loaded (/lib/systemd/system/fwupd.service; static)      Active: failed (Result: exit-code) since Mon 2021-02-15 19:35:23 GMT; 7s ago        Docs: https://fwupd.org/     Process: 6237 ExecStart=/usr/libexec/fwupd/fwupd (code=exited, status=127)    Main PID: 6237 (code=exited, status=127)  Feb 15 19:35:23 HP-ENVY-Notebook systemd[1]: Starting Firmware update daemon... Feb 15 19:35:23 HP-ENVY-Notebook fwupd[6237]: /usr/libexec/fwupd/fwupd: symbol lookup error: /lib/x86_64-linux-gnu/libgusb.so.2: undefined symbol: libusb_get_parent Feb 15 19:35:23 HP-ENVY-Notebook systemd[1]: fwupd.service: Main process exited, code=exited, status=127/n/a Feb 15 19:35:23 HP-ENVY-Notebook systemd[1]: fwupd.service: Failed with result 'exit-code'. Feb 15 19:35:23 HP-ENVY-Notebook systemd[1]: Failed to start Firmware update daemon. 

As you can see I am using a HP laptop (bad decision), which has an Intel Core i5 and is running Ubuntu 20.10 groovy. (I can provide more information if needed.)

If I run "sudo apt update --fix-missing && sudo apt upgrade" it shows that all packages are up-to-date.

Any ideas please?

        
 
 

Lista de respuestas


Relacionados problema

1  Ubuntu 17.10 Keyboard no funciona en MacBook Air incluso después de eliminar el FWUPD  ( Ubuntu 17 10 keyboard doesnt work on macbook air even after removing fwupd ) 
Tengo un aire MacBook que instalé Ubuntu 16.04 y luego actualizé a 17.10 (versión GNOME) la semana pasada. Sin embargo, desde la actualización, en la pantalla...

1  FWUPD DEL XPS 13 9370  ( Fwupd dell xps 13 9370 ) 
Tengo un Dell XPS 13 9370 con NVME SSD y estoy ejecutando Ubuntu 18.10, Gnome 3.30.1. Estoy ejecutando firmware 1.6.3 y quiero actualizar a los 1.7.3 recien...

11  No se puede actualizar Logitech Unificar firmware utilizando FWUPD  ( Cant upgrade logitech unify firmware using fwupd ) 
Cuando ejecuto el comando para actualizar el firmware, se declare manualmente en modo de actualización. He buscado una explicación, pero no puedo encontrar na...

1  ¿Por qué no puedo actualizar el firmware en mi ThinkPad después de la actualización de 20.04 a 20.10?  ( Why cant i upgrade firmware on my thinkpad after upgrade from 20 04 to 20 10 ) 
Actualicé mi computadora portátil ThinkPad de Ubuntu 20.04 a 20.10. Todo fue bien. Sin embargo, ahora hay actualizaciones de firmware disponibles, pero cuando...

8  No se puede obtener una lista de actualizaciones: Remote LVFS no tiene firma de caché  ( Unable to get a list of updates remote lvfs has no cache signature ) 
Software Ubuntu (AKA GNOME Software) en Ubuntu 18.04 ha comenzado a administrar el mensaje de error: No se puede obtener una lista de actualizaciones: Remote...

2  Firmware Update Daemon Service Colgando durante la ejecución 'Software Updater'  ( Firmware update daemon service hanging during software updater execution ) 
Tengo un Dell PowerEdge T330 que compré sin ningún sistema operativo existente. Instalé Ubuntu 18.04 LTS. Cuando LivePatch usó el actualizador del sistema par...

3  Pantalla negra + "Por favor, espere mientras instalamos una actualización del sistema"  ( Black screen please wait while we install a system update ) 
Hace unos momentos que quería cerrar mi computadora portátil y obtuve la pregunta estándar si me gustaría instalar las actualizaciones en el proceso. Revisé l...

2  Cómo actualizar el propio FWUPDMGR  ( How to update fwupdmgr itself ) 
Estoy tratando de actualizar mi firmware en Ubuntu 18.04. Cuando intento ver las actualizaciones con ABCDEFGHIJKLMNABCDEFGHIJKLMN2 Veo lo siguiente: ...

4  No se puede actualizar Logitech Unificy Receptor (versión de org.freedesktop.fwupd incorrecta: Falló el predicado [0.9.2 GE 0.8.1])  ( Cannot update logitech unifying receiver version of org freedesktop fwupd incor ) 
ACTUALIZACIÓN DE SEGURIDAD PARA EL RECEPTOR UNIFICANTE DE LOGITECH (ver captura de pantalla). Al hacer clic en el botón no hace nada. Me encontré con e...

0  FWUPD no actualizará el firmware del receptor unificador  ( Fwupd wont update unifying receiver firmware ) 
LVFS dice que hay una actualización de firmware para mi receptor de unificación de Logitech, RQR12.10_B0032 Subido 2019-9-19 y la alta urgencia nominal. El ...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos