Cómo actualizar PIP3 a 21.0 de los últimos paquetes instalados de Python3.9 DIST -- package-management campo con upgrade campo con pip camp askubuntu Relacionados El problema

How to upgrade pip3 to 21.0 from latest installed python3.9 dist-packages


0
vote

problema

Español

Habiendo podido solucionar el choque repentino en pip y abcdefhijklmnabcdefghijklmn3 como resultado de pip3 install --upgrade pip que realizó el daño en Ubuntu 16.04. Parece que otro intento de actualizar pip3 a 21.0 usando pip3 install --upgrade pip se romperá el abcdefhijklmnabcdefghijklmn8 .

Entonces, cuando se usa python3 -m pip install --user --upgrade pip3 devolución de error usando openssh-server0 tal que

  openssh-server1  

Mi pregunta es, ¿cómo puedo actualizar openssh-server2 a openssh-server3 para abcdefghijklmnabcdefghijklmnabcdefhijklmn14 que actualmente se instala de manera que utiliza abcdefghijklmn15 < / Código> Sin dañar el ABCDEFGHIJKLMNABCDEFGHIJKLMN16

¡Gracias!

Original en ingles

Having been able to fix the sudden crash in pip and pip3 as a result of pip3 install --upgrade pip which made the damage in Ubuntu 16.04. It appears that another attempt to upgrade pip3 to 21.0 using pip3 install --upgrade pip will break the existing pip from /usr/local/lib/python3.5/site-packages (python 3.5).

So when use python3 -m pip install --user --upgrade pip3 return error using pip from /usr/local/lib/python3.5/site-packages (python 3.5) such that

user@ubuntu:~$ python3 -m pip install --user --upgrade pip DEPRECATION: Python 3.5 reached the end of its life on September 13th, 2020. Please upgrade your Python as Python 3.5 is no longer maintained. pip 21.0 will drop support for Python 3.5 in January 2021. pip 21.0 will remove support for this functionality. Requirement already satisfied: pip in /usr/local/lib/python3.5/dist-packages (20.3.4) Collecting pip   Downloading pip-20.3.4-py2.py3-none-any.whl (1.5 MB)      |xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88| 1.5 MB 90 kB/s    Downloading pip-20.3.3-py2.py3-none-any.whl (1.5 MB)      |xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88xe2x96x88| 1.5 MB 31 kB/s  user@ubuntu:~$ python3 -m pip -V pip 20.3.4 from /usr/local/lib/python3.5/dist-packages/pip (python 3.5) user@ubuntu:~$ which python3 -m pip /usr/bin/python3 /usr/local/bin/pip oshebase@ubuntu:~$ which python3 -m pip3 /usr/bin/python3 /usr/local/bin/pip3 user@ubuntu:~$ python3 -m pip install --user --upgrade pip3 DEPRECATION: Python 3.5 reached the end of its life on September 13th, 2020. Please upgrade your Python as Python 3.5 is no longer maintained. pip 21.0 will drop support for Python 3.5 in January 2021. pip 21.0 will remove support for this functionality. ERROR: Could not find a version that satisfies the requirement pip3 ERROR: No matching distribution found for pip3 user@ubuntu:~$  

My question is, how can i upgrade pip3 to 21.0 for python3.9 that is currently installed such that it uses pip in /usr/local/lib/python3.9/dist-packages without damaging the existing pip in /usr/local/lib/python3.5/dist-packages (20.3.4)

Thank you!

        
 
 

Lista de respuestas


Relacionados problema

2  ¿Por qué Pip no instala el último cmake en Ubuntu?  ( Why does pip not install the latest cmake on ubuntu ) 
Como puede ver en https://pypi.org/project/cmake/ , Esta no es la última versión. En Windows, es trabajo como se esperaba. ¿Es un error o algo? root@85aca...

0  ¿Por qué Ubuntu 16.04 viene con Python 3.5 pero no PIP3?  ( Why does ubuntu 16 04 come with python 3 5 but not pip3 ) 
Esta es probablemente una pregunta básica, pero soy bastante nuevo en Ubuntu. Por lo que entiendo, Ubuntu 16.04 (y las siguientes versiones) vienen con Python...

51  ¿Sigue siendo una práctica rota?  ( Is sudo pip install still a broken practice ) 
Soy nuevo en Ubuntu, así que por favor soporta conmigo. Instalé ABCDEFGHIJKLMNABCDEFGHIJKLMN8 Uso de este comando: ABCDEFGHIJKLMNABCDEFGHIJKLMN9 . Luego in...

0  Reinstale / actualice todos los paquetes de Python User-Site y no Ubuntu Global Ones  ( Reinstall upgrade all python user sites packages and not ubuntu global ones ) 
Cuando instalé Ubuntu (16.04 LTS), no me di cuenta de que (en general) no es una buena idea instalar Paquetes de Python a través de pip usando sudo : su...

1  ¿Cómo realizo una reinstalación completa de PIP y PIP3?  ( How do i perform a full reinstallation of pip and pip3 ) 
Quiero de mi computadora lo que todos los demás quieren: para que funcione correctamente. Ahora en el problema: estaba tratando de instalar un paquete a tra...

0  No se puede instalar y actualizar los paquetes de Python en Ubuntu 14.04 [duplicado]  ( Cannot install and upgrade python packages on ubuntu 14 04 ) 
Esta pregunta ya tiene una respuesta aquí : Error en PIP: Tipo (s) de operandos no compatibles para ...

2  Problemas al instalar el paquete EDX-DL con PIP  ( Issues while installing edx dl package with pip ) 
QUERÍO DESEAR A BULT Descargar alguna conferencia de YouTube y EDX, así que eché un vistazo al proyecto aquí: https://github.com/coursera-dl/edx-dl < / p>...

-2  Quiero saber sobre los administradores de paquetes en Ubuntu [CERRADO]  ( I want to know about package managers in ubuntu ) 
cerrado . Esta pregunta necesita detalles o claridad . Actualmente no está aceptando respuestas. ...

0  Obtenga un error de importación después de instalar paquetes a través de Conda  ( Getting import error after installing packages through conda ) 
Acabo de instalar ABCDEFGHIJKLMNABCDEFGHIJKLMN2 , ABCDEFGHIJKLMNABCDEFGHIJKLMN3 , ABCDEFGHIJKLMNABCDEFGHIJKLMN4 Junto a ABCDEFGHIJKLMNABCDEFGHIJKLMN5 Di...

0  PIP3 no está trabajando en Ubuntu  ( Pip3 is not working in ubuntu ) 
obtuve el siguiente error al usar pip3 en Ubuntu: mt@mt:~$ pip3 -V pip 9.0.1 from /usr/local/lib/python3.5/dist-packages (python 3.5) mt@mt:~$ python3 Py...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos