Kubuntu 20.04: ¿Cómo forzar mi perfil de unidad de auriculares Bluetooth a HSP / HFP? -- 20.04 campo con bluetooth campo con pulseaudio campo con headphones camp askubuntu Relacionados El problema

Kubuntu 20.04: how to force my Bluetooth headset unit profile to HSP/HFP?


1
vote

problema

Español

Desde que actualizé a Kubuntu 20.04, tengo el siguiente problema: cuando conecto mi auricular USB, se configura automáticamente en el perfil A2DP, mientras que necesito usarlo en el perfil HSP / HFP para hacer llamadas telefónicas. Por razones fuera del alcance de esta pregunta, la conmutación automática de A2DP al perfil HSP / HFP no funciona con el programa que estoy usando, tampoco con la opción predeterminada auto_switch=1 de module-bluetooth-policy , NOR CON ABCDEFGHIJKLMNABCDEFGHIJKLMN2 (El problema principal es que este programa, que es Linfone , necesita que los sumideros de audio estén presentes en el inicio, antes de que comience el audio, para que se inicie Audio. Haz que sean seleccionables para la entrada y salida). Por lo tanto, tengo que cambiar el perfil de auriculares en la configuración del sistema de audio desde A2DP a HSP / HFP siempre que conecto mis auriculares y antes de comenzar Linfone .

Entonces, después de la investigación profunda (hay muchas preguntas similares que se describen aquí y en otros sitios) terminé con el siguiente comando:

  pactl set-card-profile <my_card_name> headset_head_unit   

que funciona cuando se ejecuta desde la línea de comandos. Sin embargo, cuando lo agrego a /etc/pulse/default.pa como este:

  ABCDEFGHIJKLMNABCDEFGHIJKLMN5   

No funciona, probablemente porque ese archivo está analizado y se ejecuta en PulseAudio Server Startup, que es demasiado pronto. Por lo tanto, necesitaría ejecutar ese comando tan pronto como el auricular esté enchufado. Probablemente se necesita una regla de Udev, pero está más allá de mis habilidades.

O, alguna forma de cambiar la prioridad del perfil en PulseAudio también haría el truco sin ninguna regla de Udev; ABCDEFGHIJKLMNABCDEFGHIJKLMN6 Shows (traduciendo desde italiano):

  Card #3         Name: <my_card_name>         Driver: module-bluez5-device.c         Owning module: 24         Properties:                 device.description = "Mpow M5"                 device.string = "<MAC address>"                 device.api = "bluez"                 device.class = "sound"                 device.bus = "bluetooth"                 device.form_factor = "headset"                 bluez.path = "/org/bluez/hci0/dev_<MAC address>"                 bluez.class = "0x240404"                 bluez.alias = "Mpow M5"                 device.icon_name = "audio-headset-bluetooth"                 device.intended_roles = "phone"         Profiles:                 headset_head_unit: Headset head unit (HSP/HFP) (sink: 1, sources: 1, priority: 30, available: yes)                 a2dp_sink: High-fidelity playback (sink A2DP) (sink: 1, sources: 0, priority: 40, available: yes)                 off: Off (sink: 0, sources: 0, priority: 0, available: yes)         Active profile: headset_head_unit         Ports:                 headset-output: Headphones with microphone (priority: 0, latency offset: 0 usec, available)                         Profiles: headset_head_unit, a2dp_sink                 headset-input: Headphones with microphone (priority: 0, latency offset: 0 usec, available)                         Profiles: headset_head_unit   

Tal vez, si pudiera cambiar ese ABCDEFGHIJKLMNABCDEFGHIJKLMN8 A (DIGA) ABCDEFGHIJKLMNABCDEFGHIJKLMN9 , podría decirle a PulseAudio que prefiera el perfil HSP / HFP sobre A2DP. Sin embargo, no pude encontrar ninguna sugerencia en la documentación de PulseAudio o en la red sobre cómo cambiar ese valor.

Original en ingles

Since I upgraded to Kubuntu 20.04 I have the following problem: when I connect my USB headset, it's automatically configured in A2DP profile, while I need to use it in HSP/HFP profile in order to make phone calls. For reasons outside the scope of this question, the automatic switching from A2DP to HSP/HFP profile does not work with the program I'm using, neither with the default option auto_switch=1 of module-bluetooth-policy, nor with auto_switch=2 (the main problem is that this program, which is Linphone, needs the audio sinks be present on startup, before audio even starts, in order to make them selectable for input and output). Therefore, I have to change the headphones profile in the audio system settings from A2DP to HSP/HFP whenever I plug in my headphones and before starting Linphone.

So, after deep investigation (there are many similar questions described here and on other sites) I ended up with the following command:

pactl set-card-profile <my_card_name> headset_head_unit 

which works when run from the command line. However, when I add it to /etc/pulse/default.pa like this:

.ifexists <my_card_name> pactl set-card-profile <my_card_name> headset_head_unit .endif 

it does not work, probably because that file is parsed and run on PulseAudio server startup, which is too early. So, I would need to execute that command as soon as the headset is plugged in. Probably a UDEV rule is needed, but it's beyond my skills.

Or, some way to change the profile priority in PulseAudio would also make the trick without any UDEV rule; pactl list shows (translating from Italian):

Card #3         Name: <my_card_name>         Driver: module-bluez5-device.c         Owning module: 24         Properties:                 device.description = "Mpow M5"                 device.string = "<MAC address>"                 device.api = "bluez"                 device.class = "sound"                 device.bus = "bluetooth"                 device.form_factor = "headset"                 bluez.path = "/org/bluez/hci0/dev_<MAC address>"                 bluez.class = "0x240404"                 bluez.alias = "Mpow M5"                 device.icon_name = "audio-headset-bluetooth"                 device.intended_roles = "phone"         Profiles:                 headset_head_unit: Headset head unit (HSP/HFP) (sink: 1, sources: 1, priority: 30, available: yes)                 a2dp_sink: High-fidelity playback (sink A2DP) (sink: 1, sources: 0, priority: 40, available: yes)                 off: Off (sink: 0, sources: 0, priority: 0, available: yes)         Active profile: headset_head_unit         Ports:                 headset-output: Headphones with microphone (priority: 0, latency offset: 0 usec, available)                         Profiles: headset_head_unit, a2dp_sink                 headset-input: Headphones with microphone (priority: 0, latency offset: 0 usec, available)                         Profiles: headset_head_unit 

Perhaps, if I could change that priority: 30 to (say) priority: 50, I could tell PulseAudio to prefer HSP/HFP profile over A2DP. However, I could not find any hint on PulseAudio documentation or on the net on how to change that value.

           
 
 

Lista de respuestas


Relacionados problema

0  No hay sonido de los auriculares Bluetooth  ( No sound from bluetooth headset ) 
Estoy ejecutando Kubuntu 18.04. Mi auricular (MPOW H10) está conectado y emparejado, según lo verificado por bluetoothmgr . Configuración del sistema / Multi...

10  No hay salida de sonido de auriculares Jack Ubuntu12.04  ( No sound output from headphone jack ubuntu12 04 ) 
Acabo de comprar una nueva computadora ASUS U47VC. He instalado Ubuntu 12.04 en él junto con Windows 7 sin problemas, así que nunca. HowEvr, hay un problema q...

52  Detener el sonido de los altavoces al conectar los auriculares  ( Stop sound from speakers when connecting headphones ) 
Supongo que esta pregunta ya tenía la respuesta aquí, pero no puedo encontrarla. Estoy usando 12.04. Actualización: El problema es que puedo escuchar el s...

3  No hay altavoces disponibles tan pronto como los auriculares están en Dell XPS 15  ( No speakers available as soon as headphones are in dell xps 15 ) 
Estoy experimentando problemas con el dispositivo de audio en mi Dell XPS 15. La diferenciación entre los auriculares y los altavoces portátiles falla. Cuando...

51  Ruido extraño en los auriculares cuando no se juega ningún sonido  ( Strange noise in headphones when no sound is played ) 
Hay un ruido extraño de mis auriculares en Lenovo T440. El sonido es como cuando afina tu radio, pero obtienes una frecuencia incorrecta y escuchas un ruido d...

0  No se pueden conectar auriculares Bose SoundLink AE2  ( Unable to connect bose soundlink ae2 headphones ) 
Esta es mi primera pregunta aquí, lo siento, lo siento si hay algo malo en las reglas. Acabo de instalar Kubuntu 15.04 y traté de conectar mis auriculares B...

1  Crackling Audio a través de auriculares  ( Crackling audio through headphones ) 
Recientemente he comprado una asus zenbook 3 e instaló Ubuntu en él. Dado que todavía soy bastante nuevo en Ubuntu, no estoy seguro de cómo depurar temas co...

3  Sin sonido para auriculares  ( No sound for headphones ) 
Estaba intentando algunas de las soluciones publicadas en este foro para el mismo problema, pero solo uno en particular el trabajo para mí: agregue la línea d...

16  El sonido sale de mis altavoces, incluso cuando los auriculares están enchufados [cerrados]  ( Sound comes out of my speakers even when headphones are plugged in ) 
Es poco probable que esta pregunta ayude a cualquier visitante futuro; Solo es relevante para un pequeño área geográfica, u...

0  Ubuntu 14.04 Sin sonido ni headfones ni altavoz portátil  ( Ubuntu 14 04 no sound neither headfones nor laptop speaker ) 
Ubuntu 14.04 Sin sonido ni auriculares ni altavoz portátil. No tengo otro sistema operativo Detalles instalados adjuntos. He eliminado y AMP; reinstalar e...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos