Instale el viejo controlador AMD con dependencias obsoletas -- drivers campo con apt campo con laptop campo con amd-graphics campo con fglrx camp askubuntu Relacionados El problema

Install old AMD driver with obsolete dependencies


0
vote

problema

Español

Estoy tratando de instalar un viejo controlador de AMD para mi computadora portátil en Kubuntu (Ubuntu 20.10 - Groovy), pero recibo "Siguiendo los paquetes tienen problemas de dependencias insatisfechas" para libqtcore4 y abcdefhijklmnabcdefghijklmn1 < / Código>.

Detalles

He descargado los archivos DEB de El sitio web oficial de AMD , y he escrito este script para instalarlos.

  sudo apt-get update sudo apt-get install build-essential sudo apt-get install dkms sudo apt-get install ./fglrx-core_15.201-0ubuntu1_amd64_UB_14.01.deb ./fglrx_15.201-0ubuntu1_amd64_UB_14.01.deb ./fglrx-dev_15.201-0ubuntu1_amd64_UB_14.01.deb ./fglrx-amdcccle_15.201-0ubuntu1_amd64_UB_14.01.deb   

Sin embargo, obtengo estos errores:

   The following packages have unmet dependencies:  lib32gcc1 : Depends: gcc-10-base (= 10.2.0-5ubuntu1~20.04) but 10.2.0-13ubuntu1 is to be installed E: Unable to correct problems, you have held broken packages. ... The following packages have unmet dependencies:  fglrx : Depends: libqtcore4 (>= 4:4.7.0~beta2) but it is not installable  fglrx-core : Depends: lib32gcc1 but it is not installable E: Unable to correct problems, you have held broken packages.    

¿Cómo puedo instalar estas dependencias? ¿Hay un paquete no oficial que me permita hacer esto?

Mi tarjeta gráfica es una serie Dual Radeon HD 6400M / 7400M + Intel HD 3000. Actualmente, la tarjeta gráfica Intel se elige utilizando los controladores MESA, pero quiero cambiar a AMD. Estoy bien con cualquier conductor no oficial que funcione.

Original en ingles

I am trying to install an old AMD driver for my laptop on Kubuntu (Ubuntu 20.10 - groovy), but I get "following packages have unmet dependencies" issues for libqtcore4 and lib32gcc1.

Details

I have downloaded the deb files from the official AMD website, and I have written this script to install them.

sudo apt-get update sudo apt-get install build-essential sudo apt-get install dkms sudo apt-get install ./fglrx-core_15.201-0ubuntu1_amd64_UB_14.01.deb ./fglrx_15.201-0ubuntu1_amd64_UB_14.01.deb ./fglrx-dev_15.201-0ubuntu1_amd64_UB_14.01.deb ./fglrx-amdcccle_15.201-0ubuntu1_amd64_UB_14.01.deb 

However, I get these errors:

 The following packages have unmet dependencies:  lib32gcc1 : Depends: gcc-10-base (= 10.2.0-5ubuntu1~20.04) but 10.2.0-13ubuntu1 is to be installed E: Unable to correct problems, you have held broken packages. ... The following packages have unmet dependencies:  fglrx : Depends: libqtcore4 (>= 4:4.7.0~beta2) but it is not installable  fglrx-core : Depends: lib32gcc1 but it is not installable E: Unable to correct problems, you have held broken packages.  

How can I install these dependencies? Is there an unofficial package that allows me to do this?

My graphic card is a dual Radeon HD 6400M/7400M series + Intel HD 3000. Currently, the Intel graphic card is chosen using Mesa drivers, but I want to switch to AMD. I am OK with any unofficial driver that works.

              
       
       

Lista de respuestas


Relacionados problema

0  Gráficos inutilizables con fglrx  ( Graphics unusable with fglrx ) 
Estoy teniendo problemas gráficos con una instalación de 1 día de edad de 12.10 en un Sony VAIO VGN-FW139E con una movilidad ATI Radeon HD 3400. No pude obt...

1  ¿Estas brechas DMESG hacen que mi 12.04 se inicie lentamente?  ( Are these dmesg gaps causing my 12 04 to boot up slowly ) 
Estoy teniendo una bota realmente lenta en Ubuntu 12.04. a continuación es mi dmesg Logs principales de registro: [3.704928] Ext4-FS (SDA6): sistema de a...

0  Pantalla negra después de instalar GFLRX en Ubuntu 13.10  ( Black screen after installing gflrx on ubuntu 13 10 ) 
Estoy ejecutando Ubuntu 13.10 en mi PC con 2x Sapphire Radeon HD 7950. Después de instalar FGLRX, RAN ABCDEFGHIJKLMNABCDEFGHIJKLMN0 y reiniciado, recibo una...

2  ATI Radeon 5650M FGLRX Screen Black Ubuntu (todas las versiones)  ( Ati radeon 5650m fglrx black screen ubuntu all versions ) 
Estoy tratando de instalar los controladores HD de AMD Radeon para mi ATI 5650M / Intel, pero cada vez que la arranque no funciona. Mi pantalla es negra y nec...

9  ¿Cómo puedo resolver las fallas y el mal desempeño con el controlador ATI FGLRX en mi THINKPAD X100E?  ( How can i solve display glitches and poor performance with ati fglrx driver on m ) 
Noté que el rendimiento de video en mi ThinkPad X100E era muy pobre en comparación con Windows 7, por lo que instalé los controladores patentados ATI FGLRX ut...

0  Después de desinstalar los controladores ATI FGLRX, Ubuntu 11.10 no arranque  ( After uninstalling ati fglrx drivers ubuntu 11 10 wont boot ) 
En primer lugar, este sitio ha sido tan útil que he resuelto todos mis problemas sin siquiera tener que hacer ninguna pregunta, pero esta vez estoy perplejo. ...

2  Error de modo de gráficos bajo en el controlador de código abierto  ( Low graphics mode error on open source driver ) 
Recientemente hice una actualización de Software Manager, que estaba conteniendo durante un mes (~ 250 MB), me impulsó un reinicio después de que se instalara...

1  Pantalla negra con FGLRX-Actualizaciones (14.10)  ( Black screen with fglrx updates 14 10 ) 
El camino era largo y doloroso hasta aquí, pero ... verás La historia: quería actualizar mi laptop de Ubuntu 14.04 a 14.10. Después de aplicar la actualizaci...

18  Google Chrome "parpadeando"  ( Google chrome flickering ) 
Estoy teniendo un problema con Google Chrome en Ubuntu 12.10 64. En alrededor del 20-30% de los sitios web, la página aparece la página y comienza "parpadea...

7  ¿Cuál es la última versión de Ubuntu 14.04 en la que se puede instalar FGLRX para AMD?  ( What is the latest version of ubuntu 14 04 on which fglrx for amd can be install ) 
Tengo una tarjeta de gráficos de AMD Radeon HD 8730M. Después de alguna investigación en línea, descubrí que FGLRX (conductor propietario de AMD) no es compat...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos