Problema de sonido en Arecord -- server campo con sound campo con pulseaudio campo con alsa camp askubuntu Relacionados El problema

Sound issue in arecord


0
vote

problema

Español

Tengo un trabajo de Cron que ejecuta el siguiente script una vez al día:

  cd /home/me/myaudiodir chmod 777 /dev/snd chmod 777 /dev/snd/* echo "/dev/snd/*:" > audiorec.log ls -al /dev/snd >> audiorec.log echo "/dev/snd:" >> audiorec.log ls -al /dev | grep snd >> audiorec.log echo "arecord -l:" >> audiorec.log arecord -l >> audiorec.log echo "-----------------------------------------------------------" >> audiorec.log arecord -D hw:SIZHENG,0 -f S16_LE -r 44100 -d 28800 camera/audio-`date +%A`.wav 1>> audiorec.log 2>> audiorec.log echo Bye! >> audiorec.log   

El equipo es un micrófono Sizheng.

Sin embargo, cuando se ejecuta, le da un error, que se puede ver en el archivo ABCDEFGHIJKLMNABCDEFGHIJKLMN5 :

  /dev/snd/*: total 0 drwxr-xr-x  4 root root      300 Feb 13 18:54 . drwxr-xr-x 20 root root     4080 Feb 13 18:54 .. drwxr-xr-x  2 root root       60 Feb 13 18:54 by-id drwxr-xr-x  2 root root       80 Feb 13 18:54 by-path crw-rw----  1 root audio 116,  2 Feb 13 11:51 controlC0 crw-rw----  1 root audio 116,  9 Feb 13 18:54 controlC1 crw-rw----  1 root audio 116,  4 Feb 13 21:19 pcmC0D0c crw-rw----  1 root audio 116,  3 Feb 13 21:19 pcmC0D0p crw-rw----  1 root audio 116,  5 Feb 13 11:51 pcmC0D1c crw-rw----  1 root audio 116,  6 Feb 13 11:51 pcmC0D2c crw-rw----  1 root audio 116,  7 Feb 13 11:51 pcmC0D3c crw-rw----  1 root audio 116,  8 Feb 13 17:41 pcmC0D4p crw-rw----  1 root audio 116, 10 Feb 13 18:54 pcmC1D0c crw-rw----  1 root audio 116,  1 Feb 13 11:51 seq crw-rw----  1 root audio 116, 33 Feb 13 11:51 timer /dev/snd: drwxr-xr-x  4 root root         300 Feb 13 18:54 snd arecord -l: **** List of CAPTURE Hardware Devices **** card 0: ICH6 [Intel ICH6], device 0: Intel ICH [Intel ICH6]   Subdevices: 0/1   Subdevice #0: subdevice #0 card 0: ICH6 [Intel ICH6], device 1: Intel ICH - MIC ADC [Intel ICH6 - MIC ADC]   Subdevices: 1/1   Subdevice #0: subdevice #0 card 0: ICH6 [Intel ICH6], device 2: Intel ICH - MIC2 ADC [Intel ICH6 - MIC2 ADC]   Subdevices: 1/1   Subdevice #0: subdevice #0 card 0: ICH6 [Intel ICH6], device 3: Intel ICH - ADC2 [Intel ICH6 - ADC2]   Subdevices: 1/1   Subdevice #0: subdevice #0 card 1: SIZHENG [SIZHENG], device 0: USB Audio [USB Audio]   Subdevices: 0/1   Subdevice #0: subdevice #0 ----------------------------------------------------------- arecord: main:788: audio open error: Device or resource busy Bye!   

Como se puede ver, el error es ABCDEFGHIJKLMNABCDEFGHIJKLMN7 . También tengo pulseaudio instalado ...

Busqué en el syslog y yo obtuve:

  5.4.0-1028-raspi #31-Ubuntu SMP PREEMPT Wed Jan 20 11:30:45 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux0  

Cuando intento ejecutar ABCDEFGHIJKLMNABCDEFGHIJKLMN11 En la línea de comandos, a veces se ejecuta, otras veces, da el error anterior. Sin embargo, después de ejecutar jugar una canción con 5.4.0-1028-raspi #31-Ubuntu SMP PREEMPT Wed Jan 20 11:30:45 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux2 parece funcionar bien ...

Original en ingles

I have a cron job that runs the following script once a day:

cd /home/me/myaudiodir chmod 777 /dev/snd chmod 777 /dev/snd/* echo "/dev/snd/*:" > audiorec.log ls -al /dev/snd >> audiorec.log echo "/dev/snd:" >> audiorec.log ls -al /dev | grep snd >> audiorec.log echo "arecord -l:" >> audiorec.log arecord -l >> audiorec.log echo "-----------------------------------------------------------" >> audiorec.log arecord -D hw:SIZHENG,0 -f S16_LE -r 44100 -d 28800 camera/audio-`date +%A`.wav 1>> audiorec.log 2>> audiorec.log echo Bye! >> audiorec.log 

The equipment is a microphone SIZHENG.

However, when it runs, it gives an error, which may be seen in the file audiorec.log:

/dev/snd/*: total 0 drwxr-xr-x  4 root root      300 Feb 13 18:54 . drwxr-xr-x 20 root root     4080 Feb 13 18:54 .. drwxr-xr-x  2 root root       60 Feb 13 18:54 by-id drwxr-xr-x  2 root root       80 Feb 13 18:54 by-path crw-rw----  1 root audio 116,  2 Feb 13 11:51 controlC0 crw-rw----  1 root audio 116,  9 Feb 13 18:54 controlC1 crw-rw----  1 root audio 116,  4 Feb 13 21:19 pcmC0D0c crw-rw----  1 root audio 116,  3 Feb 13 21:19 pcmC0D0p crw-rw----  1 root audio 116,  5 Feb 13 11:51 pcmC0D1c crw-rw----  1 root audio 116,  6 Feb 13 11:51 pcmC0D2c crw-rw----  1 root audio 116,  7 Feb 13 11:51 pcmC0D3c crw-rw----  1 root audio 116,  8 Feb 13 17:41 pcmC0D4p crw-rw----  1 root audio 116, 10 Feb 13 18:54 pcmC1D0c crw-rw----  1 root audio 116,  1 Feb 13 11:51 seq crw-rw----  1 root audio 116, 33 Feb 13 11:51 timer /dev/snd: drwxr-xr-x  4 root root         300 Feb 13 18:54 snd arecord -l: **** List of CAPTURE Hardware Devices **** card 0: ICH6 [Intel ICH6], device 0: Intel ICH [Intel ICH6]   Subdevices: 0/1   Subdevice #0: subdevice #0 card 0: ICH6 [Intel ICH6], device 1: Intel ICH - MIC ADC [Intel ICH6 - MIC ADC]   Subdevices: 1/1   Subdevice #0: subdevice #0 card 0: ICH6 [Intel ICH6], device 2: Intel ICH - MIC2 ADC [Intel ICH6 - MIC2 ADC]   Subdevices: 1/1   Subdevice #0: subdevice #0 card 0: ICH6 [Intel ICH6], device 3: Intel ICH - ADC2 [Intel ICH6 - ADC2]   Subdevices: 1/1   Subdevice #0: subdevice #0 card 1: SIZHENG [SIZHENG], device 0: USB Audio [USB Audio]   Subdevices: 0/1   Subdevice #0: subdevice #0 ----------------------------------------------------------- arecord: main:788: audio open error: Device or resource busy Bye! 

As may be seen, the error is arecord: main:788: audio open error: Device or resource busy. I have also pulseaudio installed...

I searched in the syslog and I obtained:

Feb 13 23:00:01 server pulseaudio[2325]: [pulseaudio] server-lookup.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11 Feb 13 23:00:01 server pulseaudio[2325]: [pulseaudio] main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11  

When I try to run arecord from the command-line, sometimes it runs, other times, it gives the above error. However, after I run play a song with aplay it appears to function well...

           

Lista de respuestas


Relacionados problema

10  No hay salida de sonido de auriculares Jack Ubuntu12.04  ( No sound output from headphone jack ubuntu12 04 ) 
Acabo de comprar una nueva computadora ASUS U47VC. He instalado Ubuntu 12.04 en él junto con Windows 7 sin problemas, así que nunca. HowEvr, hay un problema q...

10  El sonido no funciona después de 12.04 instalar  ( Sound not working after 12 04 install ) 
He instalado recientemente 12.04, pero el sonido no funciona desde los altavoces internos, y de los auriculares cuando los conecto. He seguido las instrucci...

0  ¿Cómo fijo un dispositivo de entrada ruidosa (micrófono interno)? snd_hda_intel - depuración incluida  ( How do i fix a noisy input device internal mic snd hda intel debug included ) 
Como dice el título, tengo problemas con un dispositivo de entrada de audio muy ruidoso: el micrófono interno o cualquier MICS enchufado. Hasta ahora lo he ...

9  Ruido estático al jugar sonido  ( Static noise when playing sound ) 
De vez en cuando obtengo mucho ruido estático al jugar sonido. Se detiene cuando se reproduce ningún sonido (por ejemplo, cuando se detiene la reproducción de...

2  Buzz intermitente / audio HDMI  ( Intermittent buzz hdmi audio ) 
Tengo un HTPC con una placa base ASUS P7H57D-V EVO y un procesador I5 / GPU. Estoy usando audio HDMI a un televisor Panasonic. HTPC está ejecutando Ubuntu 12....

0  Ubuntu 14.04 Sin sonido ni headfones ni altavoz portátil  ( Ubuntu 14 04 no sound neither headfones nor laptop speaker ) 
Ubuntu 14.04 Sin sonido ni auriculares ni altavoz portátil. No tengo otro sistema operativo Detalles instalados adjuntos. He eliminado y AMP; reinstalar e...

1  Ubuntu 20.04 no reconoce el micrófono auricular  ( Ubuntu 20 04 does not recognize headset microphone ) 
Tengo un cuaderno acer E5-574-307M y tengo instalado Ubuntu 20.04, pero no puede reconocer mi micrófono auricular (Xiaomi Piston 3). Busqué en Internet y en...

186  ¿Hay algún potenciador / ecualizador de sonido?  ( Is there any sound enhancers equalizer ) 
Lo que estoy buscando es tener sistema de ancho de mejoras de sonido como refugios de bajos, ecos, fidelidad, mejora estéreo y así sucesivamente. Los repr...

1  Uso de Ubuntu 12.04 LTS Sin sonido en aplicaciones seleccionadas  ( Using ubuntu 12 04 lts no sound in select apps ) 
Tengo Ubuntu 12.04 LTS y por alguna razón no tengo ningún sonido en algunos programas. VLC, hidrógeno, gnomo mplayer y películas de películas funcionan bien, ...

3  Volumen de sonido después de la bota siempre al nivel más fuerte  ( Sound volume after boot always at loudest level ) 
He instalado 10.04 hace un par de semanas. Mi sistema operativo principal es Windows y no pude instalar Linux hasta muy recientemente debido a la falta de sop...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos