Herramientas Kali instaladas con Kalmoolin3 en Ubuntu 20.04 y ahora Ubuntu solo arrancará a la línea de comandos -- apt campo con gnome campo con package-management campo con 20.04 campo con dependencies camp askubuntu Relacionados El problema

Installed Kali Tools with kaltoolin3 on Ubuntu 20.04 and now Ubuntu will only boot to command line


0
vote

problema

Español

Herramientas Kali instaladas con Kalloolin3 en Ubuntu 20.04 y ahora Ubuntu solo arrancará a la línea de comandos.

Ctrl + Alt + F7 no hace nada.
He intentado sudo apt-get install --reinstall ubuntu-desktop pero obtengo el error:

Los siguientes paquetes tienen dependencias no satisfechas:
Ubuntu-Desktop: depende: GDM3, pero no se va a instalar
........................... depende: gnome-control-center pero no se va a instalar
........................... depende: gnome-ajustes-demonio, pero no se va a instalar
........................... depende: gnome-shell, pero no se va a instalar
........................... depende: gnome-shell-extension-appindicator, pero no se va a instalar
........................... depende: gnome-shell-extensiones-escritorio-escritorio-escritorio -ktop-iconos, pero no se va a instalar
........................... depende: gnome-shell-extension-ubuntu-dock, pero no se va a instalar
........................... depende: ubuntu-desktop-minimal, pero no se va a instalar
........................... depende: ubuntu-session, pero no se va a instalar
............................ recomienda: gnome-inicial-instalación, pero no se va a instalar
E: No se puede corregir problemas, ha mantenido paquetes rotos.

Obtengo el mismo tipo de errores cuando intento instalar cada uno de esos paquetes individualmente.

También he intentado sudo systemctl set-default graphical.target y reiniciar, pero se remonta a la línea de comandos.
ABCDEFGHIJKLMNABCDEFGHIJKLMN2 FALLA CORRESS, DANDO EL ERROR:

ERROR XAUTH


He intentado seguir los comentarios sobre [esta página] [2] para no aprovechar.
Probé estos comandos con errores similares a la anterior:
  sudo apt-get update sudo apt-get dist-upgrade sudo apt-get autoremove sudo apt-get autoclean sudo apt-get install gnome-shell gnome-shell-extensions   

... básicamente mismos problemas que aquí .


Intenté la respuesta en esta página , otra vez , sin suerte.
mismo aquí .

Original en ingles

Installed Kali Tools with kaltoolin3 on Ubuntu 20.04 and now Ubuntu will only boot to the command line.

Ctrl + Alt + F7 doesn't do anything.
I've tried sudo apt-get install --reinstall ubuntu-desktop but I get the error:

The following packages have unmet dependencies:
ubuntu-desktop : Depends: gdm3 but it is not going to be installed
...........................Depends: gnome-control-center but it is not going to be installed
...........................Depends: gnome-settings-daemon but it is not going to be installed
...........................Depends: gnome-shell but it is not going to be installed
...........................Depends: gnome-shell-extension-appindicator but it is not going to be installed
...........................Depends: gnome-shell-extension-desktop-icons but it is not going to be installed
...........................Depends: gnome-shell-extension-ubuntu-dock but it is not going to be installed
...........................Depends: ubuntu-desktop-minimal but it is not going to be installed
...........................Depends: ubuntu-session but it is not going to be installed
...........................Recommends: gnome-initial-setup but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I get the same type of errors when I try to install each of those packages individually.

I've also tried sudo systemctl set-default graphical.target and rebooting, but it goes back to command line.
sudo startx fails as well, giving the error:

xauth error


I've tried following the comments on [this page][2] to no avail.
Tried these commands with similar errors as above:
sudo apt-get update sudo apt-get dist-upgrade sudo apt-get autoremove sudo apt-get autoclean sudo apt-get install gnome-shell gnome-shell-extensions 

... basically same issues as here.


I tried the answer on this page, again, no luck.
Same here too.

              
       
       

Lista de respuestas

1
 
vote

Aparentemente ha roto su sistema, como se menciona en la página GitHub para Katoolin3:

Advertencia para los usuarios de Ubuntu

Instalación de programas de repositorios para diferentes sistemas operativos ¡Generalmente se considera peligroso! Algunos paquetes podrían (y probablemente Will) romperá su sistema. Tenga cuidado al instalar las herramientas y No culpes a Katoolin3 por ningún inconveniente. La solución óptima es Para instalar herramientas específicas de Tools.kali.org. No se recomienda Para instalar todas las herramientas.

Podría verificar esto preguntando qué operativo está ejecutando ( uname -a ), pero es probable que su sistema sea ahora una mezcla de Ubuntu y Kali, y desafortunadamente, no siempre funciona en el Manera que tiene la intención de OS.

Es posible que con un esfuerzo, podría volver a un lugar estable de Ubuntu 20.04, pero el consenso de una búsqueda en este sitio para "eliminar las herramientas de Katoolin" generalmente se devuelve en "Reinstall Ubuntu"

 

You have apparently broken your system, as referred to in the github page for katoolin3:

Warning for Ubuntu users

Installing programs from repositories for different operating systems is generally considered dangerous! Some packages might (and probably will) break your system. Be careful when installing the tools and don't blame katoolin3 for any inconveniences. The optimal solution is to install specific tools from tools.kali.org. It is not recommended to install all tools.

You could check this by asking what OS you are running (uname -a) but it is likely that your system is now a mix of Ubuntu and Kali, and unfortunately that don't always work in the way that either OS intends.

It is possible that with a some effort, you could get back to a stable Ubuntu 20.04 but the consensus of a search on this site for "remove katoolin tools" generally devolves into "reinstall Ubuntu"

 
 
 
 

Relacionados problema

0  Las dependencias del paquete no se pueden resolver Ayuda [DUPLICADO]  ( Package dependencies cannot be resolved help ) 
Esta pregunta ya tiene respuestas aquí : ¿Cómo resuelvo las dependencias no satisfechas después de a...

592  ¿Cómo resuelvo las dependencias no satisfechas después de agregar un PPA?  ( How do i resolve unmet dependencies after adding a ppa ) 
Ocasionalmente, cuando estoy instalando cosas, recibo un error como lo siguiente: Some packages could not be installed. This may mean that you have request...

0  No se puede instalar nada debido al problema de dependencia  ( Unable to install anything due to dependency problem ) 
Este mensaje se muestra cada vez que intento instalar cualquier cosa. Por favor, buenas personas, cuento con Ubuntu. No puedo volver a Windows. Por favor ayu...

0  ¿Cómo instalar las dependencias de WebSocket ++?  ( How to install websocket dependencies ) 
Estoy tratando de desarrollar aplicaciones websocket en C ++. He elegido usar WebSocket ++ ya que es un ABCDEFGHIJKLMNABCDEFGHIJKLMN5 que no intenta retro...

2  LIBETPAN15 no está instalable al intentar instalar el Dock de El Cairo  ( Libetpan15 not installable when trying to install cairo dock ) 
Al agregar el Dock Cairo a Ubuntu 12.04, recibo este mensaje que me dice que necesito una dependencia. ¿Qué hago ahora para continuar con la instalación? T...

0  Sudo apt-get -f Instale error GCC-6-Base  ( Sudo apt get f install error gcc 6 base ) 
No puedo instalar anualmente en mi compuerta, obteniendo este error, incluso si intento instalar sudo apt-get -f. Utilizando Ubuntu 17.04 64 bits dpkg: dep...

3  No se puede instalar la oficina de WPS [duplicar]  ( Cannot install wps office ) 
Esta pregunta ya tiene respuestas aquí : e: paquete 'libpng12-0' no tiene Candidato de la instalació...

2  Dependencia rota libgcrypt11  ( Broken libgcrypt11 dependency ) 
He ejecutado un comando apt-get update && apt-get upgradeDefghijklmn8Defghijklmn8. El proceso completado (con un error): ABCDEFGHIJKLMNABCDEFGHIJKLMN9 a...

1  Instale Python2.7 Problemas de dependencias insatisfechas - Ubuntu 18.04  ( Install python2 7 unmet dependencies problems ubuntu 18 04 ) 
Recientemente limpio, reinstaló Ubuntu 18.04 y ahora quería instalar Python2.7 para varias otras dependencias, sin embargo, no puedo hacerlo. Correr sudo apt...

2  12.04 Actualización MI SISTEMA  ( 12 04 upgrade hosed my system ) 
Desearía poder ser más específico. Instalé la actualización del administrador de actualizaciones y después de reiniciar la computadora, encontré que no podía ...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos