La prueba de altavoz devuelve los 6 canales a los altavoces frontales -- sound campo con kubuntu campo con alsa campo con soundcard campo con sound-blaster camp askubuntu Relacionados El problema

speaker-test returns all 6 channels to front speakers


0
vote

problema

Español

OS: KUBUNTU 19.04 Tarjeta de sonido: creativo sanoblaster zxr Configuración de sonido: Frente (izquierda / derecha), centro, bajo, trasero (izquierda / derecha)

Mi problema es que todas las salidas de los altavoces se reproducen en los altavoces delanteros.

Hice lo siguiente:

  • Configurar la configuración del altavoz en la configuración de sonido de plasma a "Surround analógico 5.1-Output + STEREO-INPUT" (GP102 HDMI es mi tarjeta gráfica NVIDIA) ingrese la descripción de la imagen aquí
  • Si hago clic en cualquier altavoz trasero allí, para probar la salida de audio, se reproducen en altavoces frontales. La configuración parece muy defectuosa:
    • derecha derecha: salida en la parte delantera izquierda y derecha al mismo tiempo
    • izquierda trasera: salida en la parte delantera izquierda y derecha al mismo tiempo
    • Centro: Salida en la parte delantera izquierda y derecha al mismo tiempo
    • Frente izquierdo: salida en la parte delantera izquierda (uno de los dos altavoces correctos)
    • Frente a la derecha: salida en la parte delantera derecha (uno de los dos altavoces correctos)
  • Luego ejecuté ABCDEFGHIJKLMNABCDEFGHIJKLMN0 y noté que la tarjeta gráfica de NVIDIA se seleccionó inicialmente. Cambié con F6 a mi ZXR y configúré así: ingrese la descripción de la imagen aquí
  • I corrió ABCDEFGHIJKLMNABCDEFGHIJKLMN1 . Apareció un mensaje de error y no pudo realizar el comando: Error al abrir el dispositivo: -2
  • I Googled Cómo configurar el dispositivo predeterminado y, por lo tanto, lo hice cat /proc/asound/cards :
   0 [NVidia         ]: HDA-Intel - HDA NVidia                       HDA NVidia at 0xdf080000 irq 17  1 [Creative       ]: HDA-Intel - HDA Creative                       HDA Creative at 0xdf204000 irq 19   

con kate ~/.asoundrc i Fije mi dispositivo predeterminado:

  ABCDEFGHIJKLMNABCDEFGHIJKLMN5   
  • Después de un reinicio ABCDEFGHIJKLMNABCDEFGHIJKLMN6 estaba funcionando: Lamentablemente, la salida izquierda trasera está en la parte delantera izquierda, la salida trasera derecha está en la parte delantera derecha, el centro parece estar en los altavoces delanteros (izquierda / derecha)

¿Alguien tiene alguna idea de cómo puedo arreglar esto?


Actualización: La mayoría de los tutoriales que se encuentran en la salida de audio de ALSA y PULSE a través de HDMI o S / PDIF. Esto no se aplica a mi configuración. Coberté tres tomas de 3.5 mm a mi tarjeta de sonido: (izquierda / derecha), (centro / subwoofer), (trasera izquierda / trasera derecha). Esta es la razón por la que configuro mi configuración de audio para "Surround Surround 5,1" analógico. Lamentablemente, no he encontrado mi caso en la Web ni en el caso donde se jueguen todas las salidas de audio en los altavoces frontales.

Original en ingles

OS: KUBUNTU 19.04 Soundcard: Creative Soundblaster ZxR Sound Setup: front (left/right), center, bass, rear (left/right)

My problem is, that all speaker outputs are played at the front speakers.

I did the following:

  • Set speaker setup at Plasma sound settings to "Analog Surround 5.1-Output + Analog Stereo-Input" (GP102 HDMI is my NVIDIA Graphics Card) enter image description here
  • If I click on any rear speaker there, to test audio output, they are played on front speakers. The setup seems very faulty:
    • rear right: output on front left and right at the same time
    • rear left: output on front left and right at the same time
    • center: output on front left and right at the same time
    • front left: output on front left (one of two correct speakers)
    • front right: output on front right (one of two correct speakers)
  • I then executed alsamixer and noticed that my NVIDIA Graphics card was initially selected. I switched with F6 to my ZxR and set it up like this: enter image description here
  • I ran speaker-test -Dplug:surround51 -c6 -twav. An error message appeared and I was unable to perform the command: Error when opening the device: -2
  • I googled how to set the default device and so I did cat /proc/asound/cards:
 0 [NVidia         ]: HDA-Intel - HDA NVidia                       HDA NVidia at 0xdf080000 irq 17  1 [Creative       ]: HDA-Intel - HDA Creative                       HDA Creative at 0xdf204000 irq 19 

with kate ~/.asoundrc I set my default device:

defaults.pcm.card 1 defaults.ctl.card 1 defaults.timer.card 1 
  • after a restart speaker-test -Dplug:surround51 -c6 -twav was working: Unfortunately rear left output is on front left, rear right output is on front right, center appears to be on both front (left/right) speakers

Does anyone have any idea how I can fix this?


Update: Most Tutorials that mess with ALSA and PULSE handle audio output via HDMI or S/PDIF. This does not apply to my setup. I plugged three 3.5mm jacks into my soundcard: (left/right), (Center/Subwoofer), (Rear left/ Rear right). This is the reason why I set my audio config to "Analog Surround 5.1-Output". Unfortunately I haven't found my case in the web nor the case where all audio outputs are played on the front speakers.

              
 
 

Lista de respuestas


Relacionados problema

6  SoundBlaster solo da un buen sonido  ( Soundblaster gives only fizzing sound ) 
Dado que Windows 7 no pudo reconocer mi tarjeta de audio incorporada, pensé que simplemente compraría un bañador de sonido. Al principio todo estaba bien, fun...

3  Sound Blaster Recon3D no funciona  ( Sound blaster recon3d not working ) 
Instalé Ubuntu 12.10 en mi computadora y soy totalmente nuevo en Ubuntu. No puedo hacer que mi tarjeta de sonido funcione, es un Sueno Blaster Recon3D. Leí qu...

0  ¿Tratando de compilar pero faltando encabezados?  ( Trying to compile but missing headers ) 
Así que estoy tratando de actualizar mi controlador de tarjeta de sonido, pero necesito compilar primero. Después de ingresar al comando sudo, me encuentro ...

1  ¿Alguien tiene "Creative SoundBlaster X-Fi Surround 5.1 Pro" - (Interfaz USB) instalada?  ( Has anyone got creative soundblaster x fi surround 5 1 pro usb interface i ) 
¿Alguien ha probado este blaster de sonido USB externo en Ubuntu? http: //us.store.creative .com / Sound-Blaster-XFI-round-5.1-PRO / M / B0044DEDCA.HTM . ...

1  Conductor para Sound Blaster X-Fi HD  ( Driver for sound blaster x fi hd ) 
¿Alguien sabe si hay controladores para Sound Blaster X-Fi HD? y si no, ¿hay alguna otra tarjeta de sonido externa buena que incluya amperios de auriculares...

2  ¿Cómo detectar el sonido creativo Blaster Audigy 2?  ( How to detect creative sound blaster audigy 2 ) 
He instalado una tarjeta de sonido PCI 7.1 Sound Sound Sound Audigy 2, en mi instalación de 10.10 Ubuntu 64 bits. He deshabilitado la tarjeta de sonido a bord...

1  ¿El SoundBlasterx G5 funciona en Ubuntu? [cerrado]  ( Does the soundblasterx g5 work in ubuntu ) 
cerrado . Esta pregunta es basada en opinión . Actualmente no está aceptando respuestas. ¿...

2  No hay "conector: línea analógica" en la pestaña de entrada de las preferencias de sonido, ¿por qué no?  ( There is no connector analog line in on the input tab of sound preferences ) 
Conecté una plataforma de cinta analógica a la entrada de línea analógica de Audigy SoundBlaster. Tengo un cable de 2 a 1 que conecta la cinta a la línea de a...

1  Congelación de sonido (pitidos) - Sound Blaster X-Fi HD  ( Sound freezes beeping sound blaster x fi hd ) 
Tengo el problema que después de escuchar la música (unos 15 minutos), El único sonido que sale es un sonido de pitido. Si conecto el USB, e insértelo de nuev...

2  ¿Alguien ha logrado usar Sound Blasterx AE-5 en Ubuntu?  ( Has any one managed to use sound blasterx ae 5 on ubuntu ) 
¿Hay un conductor para el sonido Blasterx AE-5? ¿Cómo me instalaría estos parches ? ...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos