No se puede instalar TensorFlow usando Comando PIP Instale TensorFlow -- software-installation campo con pip campo con source-packages campo con tensorflow camp askubuntu Relacionados El problema

Cannot install tensorflow using command pip install tensorflow


0
vote

problema

Español

Estoy recibiendo errores siguientes:

  ERROR: Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/usr/local/lib/python2.7/dist-packages/tensorflow-2.0.0.dist-info' Consider using the `--user` option or check the permissions.   

Cuando voy a la carpeta usando el terminal No puedo ver ningún archivo llamado tensorflow-2.0.0.dist-info .

El comando PIP que estoy usando es pip install tensorflow .

  nothing to be done for x86_64_def0  
Original en ingles

I am getting following errors:

ERROR: Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/usr/local/lib/python2.7/dist-packages/tensorflow-2.0.0.dist-info' Consider using the `--user` option or check the permissions. 

When I go to the folder using terminal I cannot see any file named tensorflow-2.0.0.dist-info.

The pip command I am using is pip install tensorflow.

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support Collecting tensorflow   Using cached https://files.pythonhosted.org/packages/17/08/1ff15637a03b1565dd6cb0916b3ca6873db3a1fc69be0ed851be936e5633/tensorflow-2.0.0-cp27-cp27mu-manylinux2010_x86_64.whl Requirement already satisfied: gast==0.2.2 in ./.local/lib/python2.7/site-packages (from tensorflow) (0.2.2) Requirement already satisfied: grpcio>=1.8.6 in ./.local/lib/python2.7/site-packages (from tensorflow) (1.24.1) Requirement already satisfied: numpy<2.0,>=1.16.0 in ./.local/lib/python2.7/site-packages (from tensorflow) (1.16.5) Requirement already satisfied: backports.weakref>=1.0rc1; python_version < "3.4" in ./.local/lib/python2.7/site-packages (from tensorflow) (1.0.post1) Requirement already satisfied: tensorboard<2.1.0,>=2.0.0 in ./.local/lib/python2.7/site-packages (from tensorflow) (2.0.0) Requirement already satisfied: wrapt>=1.11.1 in ./.local/lib/python2.7/site-packages (from tensorflow) (1.11.2) Requirement already satisfied: protobuf>=3.6.1 in ./.local/lib/python2.7/site-packages (from tensorflow) (3.10.0) Requirement already satisfied: keras-preprocessing>=1.0.5 in ./.local/lib/python2.7/site-packages (from tensorflow) (1.1.0) Requirement already satisfied: mock>=2.0.0 in ./.local/lib/python2.7/site-packages (from tensorflow) (3.0.5) Requirement already satisfied: keras-applications>=1.0.8 in ./.local/lib/python2.7/site-packages (from tensorflow) (1.0.8) Requirement already satisfied: wheel in /usr/lib/python2.7/dist-packages (from tensorflow) (0.30.0) Requirement already satisfied: functools32>=3.2.3 in ./.local/lib/python2.7/site-packages (from tensorflow) (3.2.3.post2) Requirement already satisfied: six>=1.10.0 in /usr/lib/python2.7/dist-packages (from tensorflow) (1.11.0) Requirement already satisfied: absl-py>=0.7.0 in ./.local/lib/python2.7/site-packages (from tensorflow) (0.8.1) Requirement already satisfied: opt-einsum>=2.3.2 in ./.local/lib/python2.7/site-packages (from tensorflow) (2.3.2) Requirement already satisfied: termcolor>=1.1.0 in ./.local/lib/python2.7/site-packages (from tensorflow) (1.1.0) Requirement already satisfied: google-pasta>=0.1.6 in ./.local/lib/python2.7/site-packages (from tensorflow) (0.1.7) Requirement already satisfied: enum34>=1.1.6; python_version < "3.4" in /usr/lib/python2.7/dist-packages (from tensorflow) (1.1.6) Requirement already satisfied: tensorflow-estimator<2.1.0,>=2.0.0 in ./.local/lib/python2.7/site-packages (from tensorflow) (2.0.0) Requirement already satisfied: astor>=0.6.0 in ./.local/lib/python2.7/site-packages (from tensorflow) (0.8.0) Requirement already satisfied: futures>=2.2.0; python_version < "3.2" in ./.local/lib/python2.7/site-packages (from grpcio>=1.8.6->tensorflow) (3.3.0) Requirement already satisfied: setuptools>=41.0.0 in ./.local/lib/python2.7/site-packages (from tensorboard<2.1.0,>=2.0.0->tensorflow) (41.4.0) Requirement already satisfied: werkzeug>=0.11.15 in ./.local/lib/python2.7/site-packages (from tensorboard<2.1.0,>=2.0.0->tensorflow) (0.16.0) Requirement already satisfied: markdown>=2.6.8 in ./.local/lib/python2.7/site-packages (from tensorboard<2.1.0,>=2.0.0->tensorflow) (3.1.1) Requirement already satisfied: funcsigs>=1; python_version < "3.3" in ./.local/lib/python2.7/site-packages (from mock>=2.0.0->tensorflow) (1.0.2) Requirement already satisfied: h5py in ./.local/lib/python2.7/site-packages (from keras-applications>=1.0.8->tensorflow) (2.10.0) Installing collected packages: tensorflow ERROR: Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/usr/local/lib/python2.7/dist-packages/tensorflow-2.0.0.dist-info' Consider using the `--user` option or check the permissions.  
           
 
 

Lista de respuestas


Relacionados problema

1  NVIDIA GPU no se está ejecutando  ( Nvidia gpu is not running ) 
Estoy usando Ubuntu 16.04 y mi versión NVIDIA GPU es "GP104 [GEFORCE GTX 1080]". Instalé CUDA y su versión es "CUDA Versión 9.0.176". y al ejecutar el com...

1  Instalación de CUDA 10 y TENSORFLOW 2.0 Ubuntu 19.10  ( Installing cuda 10 and tensorflow 2 0 ubuntu 19 10 ) 
He estado tratando de instalar CUDA 10.0 y TENSRFLOW 2.0 en Ubuntu 19.10 (lo mismo ocurre con las versiones anteriores de Ubuntu), pero no hay uso. Dice que e...

2  Ubuntu 18.04 TensorFlow / KERAS Problemas de instalación, ¿puede alguien ayudar a alguien?  ( Ubuntu 18 04 tensorflow keras installation issues can someone help ) 
Estoy muy interesado en las redes neuronales y actualmente estoy tratando de instalar y obtener TensorFlow y Keras en funcionamiento. Por supuesto, quiero cor...

0  Importar TensorFlow como falla de segmentación de TF (Core Dumped) en Ubuntu 20.04  ( Import tensorflow as tf segmentation fault core dumped in ubuntu 20 04 ) 
Necesito instalar TensorFlow 1.14 para DEEPLABCUT y Tengo una falla de segmentación. ¿Cómo lo arreglo? También prefiero instalar la versión GPU. No estoy se...

1  Instalación de Rocm con Radeon R7 M445 en Ubuntu 20.04  ( Rocm installation with radeon r7 m445 on ubuntu 20 04 ) 
Acabo de hacer una nueva instalación de Ubuntu 20.04 e hizo un intento de instalar ROCM para la computación GPU en AMD Radeon R7 M445. Lo necesito para usar l...

1  Error de importación TensorFlow 1037  ( Tensorflow import error 1037 ) 
Déjame decir esto justo al principio, soy nuevo en esto y no tengo idea de lo que se debe hacer. Estoy usando Ubuntu 19.04. Y estoy seguro de que tengo todo...

1  Instalación del kit de herramientas de CUDA para Ubuntu 18.04  ( Installing cuda toolkit for ubuntu 18 04 ) 
Necesito que CUDA desarrolle un Chatbot como se describe en este Tutorial . Estoy tratando de instalar CUDA usando estos comandos . Tipo de instalación: R...

1  ¿Cuál es la diferencia entre CUDA-TOOLKET-10-1 y NVIDIA-CUDA-TOOLKIT cuando lo instalo en Ubuntu 20.04?  ( What is the difference between cuda toolkit 10 1 and nvidia cuda toolkit when i ) 
Fondo de mis preguntas Tengo una computadora portátil de Lenovo Thinkpad W530 de Lenovo con NVIDIA Corporation GK107GLM [Quadro k1000m ] / Quadro k1000m / ...

0  Ubuntu 18.04.3: Necesito ayuda con Rocm TensorFlow: Error de compilación  ( Ubuntu 18 04 3 need help with rocm tensorflow build error ) 
Tengo una nueva instalación de Ubuntu 18.04.3 y estoy tratando de instalar TensorFlow-Rocm (para AMD GPU) versión 1.14.0. Instalación PIP3 predeterminada Te...

0  Conexión con cable detectada pero sin acceso a Internet en Ubuntu 14.04 LTS  ( Failed to get convolution algorithm error in tensorflow ) 
Error al obtener un error de algoritmo de convolución en TensorFlow 0123456789012345222 Instalé CUDA, CUDANN y TENSORFLOW, siguiendo estrictamente las instr...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos