La instalación de CUDA falla - dependencias no satisfechas -- drivers campo con 18.04 campo con nvidia campo con graphics campo con cuda camp askubuntu Relacionados El problema

CUDA installation fails - unmet dependencies


1
vote

problema

Español

Estoy tratando de instalar CUDA en Ubuntu 18.04.3 LTS de acuerdo con esta documentación de nvidia.

Me encontré con problemas cuando intenté instalar los encabezados de Linux por el siguiente comando.

  sudo apt-get install linux-headers-$(uname -r)   

Recaudó un error Unmet dependencies .

  The following packages have unmet dependencies:  libcuinj64-9.1 : Depends: libcuda1 (>= 387.26) or                            libcuda-9.1-1 E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).   

cuando lo intenté

  ABCDEFGHIJKLMNABCDEFGHIJKLMN5   

tengo

  dpkg: error processing archive /var/cache/apt/archives/libnvidia-compute-430_430.26-0ubuntu0.18.04.2_amd64.deb (--unpack):  trying to overwrite '/usr/lib/x86_64-linux-gnu/libnvidia-ml.so', which is also in package nvidia-340 340.107-0ubuntu0.18.04.3 Errors were encountered while processing:  /var/cache/apt/archives/libnvidia-compute-430_430.26-0ubuntu0.18.04.2_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)   

La salida de terminal completa se puede ver aquí .

Esta es la GPU que tengo

    *-display                         description: VGA compatible controller        product: GM204 [GeForce GTX 970]        vendor: NVIDIA Corporation        physical id: 0        bus info: pci@0000:01:00.0        version: a1        width: 64 bits        clock: 33MHz        capabilities: pm msi pciexpress vga_controller bus_master cap_list rom        configuration: driver=nouveau latency=0        resources: irq:29 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff   

No estoy seguro de dónde ir desde aquí. ¿Alguien puede ayudar?

Original en ingles

I am trying to install CUDA in Ubuntu 18.04.3 LTS according to this documentation from nvidia.

I ran into trouble when I tried to install linux headers by the following command.

sudo apt-get install linux-headers-$(uname -r) 

It raised an Unmet dependencies error.

The following packages have unmet dependencies:  libcuinj64-9.1 : Depends: libcuda1 (>= 387.26) or                            libcuda-9.1-1 E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution). 

When I tried

sudo apt --fix-broken install 

I got

dpkg: error processing archive /var/cache/apt/archives/libnvidia-compute-430_430.26-0ubuntu0.18.04.2_amd64.deb (--unpack):  trying to overwrite '/usr/lib/x86_64-linux-gnu/libnvidia-ml.so', which is also in package nvidia-340 340.107-0ubuntu0.18.04.3 Errors were encountered while processing:  /var/cache/apt/archives/libnvidia-compute-430_430.26-0ubuntu0.18.04.2_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) 

The whole terminal output can be seen here.

This is the gpu I have

  *-display                         description: VGA compatible controller        product: GM204 [GeForce GTX 970]        vendor: NVIDIA Corporation        physical id: 0        bus info: pci@0000:01:00.0        version: a1        width: 64 bits        clock: 33MHz        capabilities: pm msi pciexpress vga_controller bus_master cap_list rom        configuration: driver=nouveau latency=0        resources: irq:29 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff 

I am not sure where to go from here. Can anyone help?

              
   
   

Lista de respuestas

0
 
vote

No tenía instalado ningún controlador NVIDIA propietario. Desde el menú Ubuntu, fui a Software and Updates > Additional Drivers e instalado nvidia-driver-430 .

  foo@42:~$ sudo lshw -C display   *-display                         description: VGA compatible controller        product: GM204 [GeForce GTX 970]        vendor: NVIDIA Corporation        physical id: 0        bus info: pci@0000:01:00.0        version: a1        width: 64 bits        clock: 33MHz        capabilities: pm msi pciexpress vga_controller bus_master cap_list rom        configuration: driver=nvidia latency=0        resources: irq:30 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff   

El conductor cambió de nouveau a nvidia . También instaló .desktop0

  .desktop1  
 

I did not have any proprietary nvidia-driver installed. From the ubuntu menu I went to Software and Updates > Additional Drivers and installed nvidia-driver-430.

foo@42:~$ sudo lshw -C display   *-display                         description: VGA compatible controller        product: GM204 [GeForce GTX 970]        vendor: NVIDIA Corporation        physical id: 0        bus info: pci@0000:01:00.0        version: a1        width: 64 bits        clock: 33MHz        capabilities: pm msi pciexpress vga_controller bus_master cap_list rom        configuration: driver=nvidia latency=0        resources: irq:30 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff 

The driver changed from nouveau to nvidia. It also installed CUDA Version: 10.2

foo@42:~$ nvidia-smi Tue Oct  8 22:27:48 2019        +-----------------------------------------------------------------------------+ | NVIDIA-SMI 430.26       Driver Version: 430.26       CUDA Version: 10.2     | |-------------------------------+----------------------+----------------------+ | GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC | | Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. | |===============================+======================+======================| |   0  GeForce GTX 970     Off  | 00000000:01:00.0  On |                  N/A | |  0%   43C    P8    16W / 200W |    191MiB /  4039MiB |      0%      Default | +-------------------------------+----------------------+----------------------+  +-----------------------------------------------------------------------------+ | Processes:                                                       GPU Memory | |  GPU       PID   Type   Process name                             Usage      | |=============================================================================| |    0      4953      G   /usr/lib/xorg/Xorg                            16MiB | |    0      4998      G   /usr/bin/gnome-shell                          51MiB | |    0      5151      G   /usr/lib/xorg/Xorg                            79MiB | |    0      5392      G   ...ervice-request-channel-token=1831114496    39MiB | 
 
 

Relacionados problema

0  CUDA Y CONDUCTOR: ¿Puedo eliminar el conductor o cambiar la resolución?  ( Cuda and driver can i remove driver or change resolution ) 
Acabo de instalar CUDA. Las 3 partes (muestras, kit de herramientas, conductor). ¿Tengo que tener instalado este controlador NVIDIA? $ lspci | grep VGA 01:...

30  ¿Cómo puedo obtener NVIDIA CUDA u OPENCL trabajando en una computadora portátil con NVIDIA Discrete Card / Intel integrados gráficos?  ( How can i get nvidia cuda or opencl working on a laptop with nvidia discrete car ) 
Fondo: Soy un artista en 3D (como un hobby) y recientemente ha comenzado a usar Ubuntu 12.04 LTS como un arranque dual con Windows 7. Está ejecutando en mi co...

2  Ubuntu 14.04 no inicia sesión después de la actualización de NVIDIA  ( Ubuntu 14 04 not logging in after nvidia update ) 
Quiero ejecutar un programa CUDA en Ubuntu 14.04 LTS 64bit, pero el error que obtuve fue: La versión del controlador CUDA es insuficiente para CUDA RUNTETE...

58  Instalación y prueba CUDA en Ubuntu 14.04  ( Installing and testing cuda in ubuntu 14 04 ) 
No estoy seguro de cómo instalar CUDA en mi sistema. Mirando a su alrededor, hay muchos tutoriales sobre CUDA en 12.04 LTS y algunos de los 13.04 y 13.10, per...

0  ¿Qué versión de CUDA muestras en GitHub para elegir para NVIDIA-CUDA-TOOLKIT en 20.04?  ( Which version of cuda samples on github to choose for nvidia cuda toolkit in 20 ) 
Estoy usando 20.04 LTS e instalé CUDA de UBUNTU REPO usando ABCDEFGHIJKLMNABCDEFGHIJKLMN2 . La versión mostrada por apt show nvidia-cuda-toolkit es 10.1.24...

3  NVIDIA-SMI muestra la versión de CUDA, pero CUDA no está instalada  ( Nvidia smi shows cuda version but cuda is not installed ) 
Estoy en Ubuntu 18.10. Cuando recibí mi GPU (RTX 2070), hice "Sudo Ubuntu-Drivers AutoInstall". Esto instaló los controladores. Cuando hago "nvidia-smi" en la...

0  No se puede ejecutar Cudaminer en Jetson  ( Unable to run cudaminer on jetson ) 
Después de descargar y ejecutar ./autogen.sh y ./configure la ejecución del comando HACK le da el siguiente error en mi Jetson TK1 gcc -std = gnu99 -dhave_...

7  Compruebe la actividad de la tarjeta de gráficos  ( Check graphics card activity ) 
Tengo una solicitud instalada que puede hacer uso de mi tarjeta gráfica CUDA, pero no estoy seguro de si lo tengo configurado correctamente. ¿Hay alguna forma...

12  ¿Alguien ha instalado con éxito CUDA 7.5 en Ubuntu 14.04.3 LTS X86_64?  ( Has anyone successfully installed cuda 7 5 on ubuntu 14 04 3 lts x86 64 ) 
Mi estación de trabajo tiene dos GPUs (Quadro K5200 y Quadro K2200) con el último controlador NVIDIA instalado (Versión: 352.41). Después de descargar el arch...

0  Actualizaciones automáticas de NVIDIA, CUDA bajo Ubuntu 18.04  ( Automatic updates of nvidia cuda under ubuntu 18 04 ) 
Tengo dos GPUS NVIDIA (RTX 2060 y RTX 2080 TI) que uso con TensorFlow 2 (instalado en un Python VirtualEnv). He instalado CUDA 10.1 (que no es la última versi...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos