La instalación de APT-GET -F falla con Emacs25 Conflicto con Emacs26 -- apt campo con package-management campo con upgrade camp askubuntu Relacionados El problema

apt-get -f install fails with emacs25 conflict with emacs26


5
vote

problema

Español

Al actualizar, recibo un error, pidiéndome que arregle los paquetes rotos. ABCDEFGHIJKLMNABCDEFGHIJKLMN1 Produce

  ... Get:1 http://ppa.launchpad.net/kelleyk/emacs/ubuntu bionic/main amd64 emacs25-common all 25.3~1.gite0284ab-kk1+18.04 [17.5 MB] Fetched 17.5 MB in 2s (7,805 kB/s)          (Reading database ... 265566 files and directories currently installed.) Preparing to unpack .../emacs25-common_25.3~1.gite0284ab-kk1+18.04_all.deb ... Unpacking emacs25-common (25.3~1.gite0284ab-kk1+18.04) ... dpkg: error processing archive /var/cache/apt/archives/emacs25-common_25.3~1.gite0284ab-kk1+18.04_all.deb (--unpack):  trying to overwrite '/usr/share/emacs/site-lisp/subdirs.el', which is also in package emacs26-common 26.3~1.git96dd019-kk1+18.04 dpkg-deb: error: paste subprocess was killed by signal (Broken pipe) Errors were encountered while processing:  /var/cache/apt/archives/emacs25-common_25.3~1.gite0284ab-kk1+18.04_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1)   

aquí es sudo apt-cache policy emacs26-common emacs25-common :

  emacs26-common:   Installed: 26.3~1.git96dd019-kk1+18.04   Candidate: 26.3~1.git96dd019-kk1+18.04   Version table:  *** 26.3~1.git96dd019-kk1+18.04 500         500 http://ppa.launchpad.net/kelleyk/emacs/ubuntu bionic/main amd64 Packages         500 http://ppa.launchpad.net/kelleyk/emacs/ubuntu bionic/main i386 Packages         100 /var/lib/dpkg/status emacs25-common:   Installed: (none)   Candidate: 25.3~1.gite0284ab-kk1+18.04   Version table:      25.3~1.gite0284ab-kk1+18.04 500         500 http://ppa.launchpad.net/kelleyk/emacs/ubuntu bionic/main amd64 Packages         500 http://ppa.launchpad.net/kelleyk/emacs/ubuntu bionic/main i386 Packages      25.2+1-6 500         500 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages         500 http://us.archive.ubuntu.com/ubuntu bionic/main i386 Packages   

Cualquier sugerencia sobre cómo solucionar esto será recibido con gratitud.

Original en ingles

When upgrading I get an error asking me to fix broken packages. apt-get -f install produces

... Get:1 http://ppa.launchpad.net/kelleyk/emacs/ubuntu bionic/main amd64 emacs25-common all 25.3~1.gite0284ab-kk1+18.04 [17.5 MB] Fetched 17.5 MB in 2s (7,805 kB/s)          (Reading database ... 265566 files and directories currently installed.) Preparing to unpack .../emacs25-common_25.3~1.gite0284ab-kk1+18.04_all.deb ... Unpacking emacs25-common (25.3~1.gite0284ab-kk1+18.04) ... dpkg: error processing archive /var/cache/apt/archives/emacs25-common_25.3~1.gite0284ab-kk1+18.04_all.deb (--unpack):  trying to overwrite '/usr/share/emacs/site-lisp/subdirs.el', which is also in package emacs26-common 26.3~1.git96dd019-kk1+18.04 dpkg-deb: error: paste subprocess was killed by signal (Broken pipe) Errors were encountered while processing:  /var/cache/apt/archives/emacs25-common_25.3~1.gite0284ab-kk1+18.04_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1) 

Here is sudo apt-cache policy emacs26-common emacs25-common:

emacs26-common:   Installed: 26.3~1.git96dd019-kk1+18.04   Candidate: 26.3~1.git96dd019-kk1+18.04   Version table:  *** 26.3~1.git96dd019-kk1+18.04 500         500 http://ppa.launchpad.net/kelleyk/emacs/ubuntu bionic/main amd64 Packages         500 http://ppa.launchpad.net/kelleyk/emacs/ubuntu bionic/main i386 Packages         100 /var/lib/dpkg/status emacs25-common:   Installed: (none)   Candidate: 25.3~1.gite0284ab-kk1+18.04   Version table:      25.3~1.gite0284ab-kk1+18.04 500         500 http://ppa.launchpad.net/kelleyk/emacs/ubuntu bionic/main amd64 Packages         500 http://ppa.launchpad.net/kelleyk/emacs/ubuntu bionic/main i386 Packages      25.2+1-6 500         500 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages         500 http://us.archive.ubuntu.com/ubuntu bionic/main i386 Packages 

Any hints on how to fix this will be gratefully received.

        
         
         

Lista de respuestas

7
 
vote
vote
La mejor respuesta
 

Para solucionar temporalmente el problema, puede forzar la instalación del paquete con

  sudo dpkg -i --force-all /var/cache/apt/archives/emacs25-common_25.3~1.gite0284ab-kk1+18.04_all.deb   
 

To temporarily fix the issue you can force package installation with

sudo dpkg -i --force-all /var/cache/apt/archives/emacs25-common_25.3~1.gite0284ab-kk1+18.04_all.deb 
 
 
   
   

Relacionados problema

22  ¿Cuáles son algunas alternativas para actualizar sin usar el sistema de actualización estándar?  ( What are some alternatives to upgrading without using the standard upgrade syste ) 
¿Cuáles son algunas alternativas para actualizar sin usar el sistema de actualización estándar? Supongamos, por ejemplo, que quería actualizar una instalación...

22  Deshabilitar la nueva versión de Ubuntu Update Manager Advertencia  ( Disable ubuntu update managers new version warning ) 
¿Cómo no permitir que Ubuntu se actualice de como 11.10 a 12.04? Sé que es su deseo si desea actualizar, pero no quiero el mensaje en la actualización del a...

2  Netbook Remix 10.04 a 10.10 Actualización usando ISO alternativo  ( Netbook remix 10 04 to 10 10 upgrade using alternate iso ) 
Estoy usando Netbook Remix 10.04 ahora. Estoy teniendo el 10.10 alternativo ISO conmigo. Si utilizo eso, ISO para actualizar, ¿perderé la versión de mi netboo...

5  La instalación se bloquea en "Recuperación del archivo 43 de 105"  ( Installation hangs at retrieving file 43 of 105 ) 
Este es mi segundo intento de instalar Ubuntu. En mi primer intento, seleccioné "Descargar actualizaciones" e "Instalar componentes de terceros"; En mi segund...

0  Problema actualizando 12.04 a 14.04  ( Problem upgrading 12 04 to 14 04 ) 
iR obteniendo el siguiente error al actualizar 12.04 a 14.04 W: Error al buscarla http: //archive.ubuntu .com / Ubuntu / DIST / CUANTAL / PRINCIPAL / BINAR...

2  Lentisa de Internet al actualizar a 15.04  ( Internet slowness upon upgrading to 15 04 ) 
Problema más extraño al actualizar a Ubuntu 15.04: Internet funcionará bien durante unos segundos y luego se volverá extremadamente, notablemente lento. Luego...

15  Ruta sana a las actualizaciones de distribución  ( Sane path to distribution upgrades ) 
Estoy usando Hardy (servidor) en bastantes máquinas y me gustaría actualizar a los últimos LTS. ¿Es seguro editar mi archivo ubuntu-security-status7 para ap...

439  ¿Cómo actualizo a una versión más nueva de Ubuntu?  ( How do i upgrade to a newer version of ubuntu ) 
¿Cuáles son las diferentes maneras en que puedo usar para actualizar Ubuntu de una versión a otra? ...

2  Contraseña incorrecta para sudo y en la pantalla de bloqueo, pero corrija al iniciar sesión justo después de reiniciar  ( Incorrect password for sudo and on screen lock but correct while logging in rig ) 
Tengo este problema extraño que se produzca después de actualizar el sistema operativo de 16 a 18. Al principio, no me dejaría entrar, diciendo que la contr...

1  MyTHBUNTU 16.04 Base de datos falla en Backend MyTHTV 0.28 a 0.29 Actualización  ( Mythbuntu 16 04 database fail in backend mythtv 0 28 to 0 29 upgrade ) 
Actualicé en 16.04 Ubuntu de 0.28 a 0.29 utilizando los repositorios, y creo que la porción de actualización de la base de datos falló. Los clientes no pued...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos