¿Por qué no se puede usar PPA: ONDREJ? -- server campo con ppa campo con php7 camp askubuntu Relacionados El problema

Why cannot use ppa:ondrej?


2
vote

problema

Español

Quiero usar ONDREJ PPA para actualizar la versión PHP en Ubuntu Server. Me he conectado a la conexión a internet.

  sudo apt-get install python-software-properties sudo add-apt-repository ppa:ondrej/php   

Intenté y obtuve un error:

  Cannot add PPA: 'ppa:ondrej/ubuntu/php' 'ondrej' user or team does not exist   

He intentado usar ABCDEFGHIJKLMNABCDEFGHIJKLMN2 en el comando y el error es el mismo.

sobre el entorno proxy, realmente no entiendo. No sé cómo ajustar la configuración de acuerdo con la respuesta en aquí

También probé esto:

  RUN apt-get -y install locales RUN locale-gen en_US.UTF-8 ENV LANG en_US.UTF-8 ENV LANGUAGE en_US:en ENV LC_ALL en_US.UTF-8 RUN add-apt-repository -y ppa:ondrej/php   

Pero el resultado es el mismo, el error no puede agregar PPA: ONDREJ

Gracias

Original en ingles

I want to use ondrej ppa to upgrade php version in ubuntu server. I have connected to internet connection.

sudo apt-get install python-software-properties sudo add-apt-repository ppa:ondrej/php 

I tried and got an error:

Cannot add PPA: 'ppa:ondrej/ubuntu/php' 'ondrej' user or team does not exist 

I had tried using -E in the command and the error is the same.

about the proxy setting, I do not really understand. I do not know how to adjust the setting according the answer in here

I also tried this:

RUN apt-get -y install locales RUN locale-gen en_US.UTF-8 ENV LANG en_US.UTF-8 ENV LANGUAGE en_US:en ENV LC_ALL en_US.UTF-8 RUN add-apt-repository -y ppa:ondrej/php 

but the result is the same, the error cannot add ppa:ondrej

Thank you

        
       
       

Lista de respuestas

1
 
vote

Aparentemente, fue un problema con DNS o el servidor se redujo porque los comandos que publicó ahora funcionan correctamente.

  sudo add-apt-repository ppa:ondrej/php   

Después de la actualización, ABCDEFGHIJKLMNABCDEFGHIJKLMN1 Instaló la última versión de PHP (actualmente 7.3)

 

Apparently it was an issue with DNS or the server was down because the commands you posted are now working successfully.

sudo add-apt-repository ppa:ondrej/php 

After the update, sudo apt install php installed the latest PHP version (currently 7.3)

 
 
0
 
vote

Tal vez el problema es causado por

  • su locale (idioma, etc.)
  • La conexión a Internet de su computadora
  • algunos [Other] instalado PPA o paquete de programa

Intenté con un Ubuntu 16.04.1 LTS en vivo, y podría agregar el repositorio ABCDEFGHIJKLMNABCDEFGHIJKLMN2 .

Hubo una advertencia: 'Add-apt-Repository se rompe con los locales no UTF-8'. y una punta con un trabajo. Ver más abajo.

  ubuntu@ubuntu:~$ sudo add-apt-repository ppa:ondrej/php  Co-installable PHP versions: PHP 5.6, PHP 7.x and most requested extensions  are included. Only Supported Versions of PHP  (http://php.net/supported-versions.php) for Supported Ubuntu Releases  (https://wiki.ubuntu.com/Releases) are provided. Don't ask for end-of-life  PHP versions or Ubuntu release, they won't be provided.  Debian oldstable and stable packages are provided as well: https://deb.sury.org/#debian-dpa  You can get more information about the packages at https://deb.sury.org  BUGS&FEATURES: This PPA now has a issue tracker: https://deb.sury.org/#bug-reporting  CAVEATS: 1. If you are using php-gearman, you need to add ppa:ondrej/pkg-gearman 2. If you are using apache2, you are advised to add ppa:ondrej/apache2 3. If you are using nginx, you are advise to add ppa:ondrej/nginx-mainline    or ppa:ondrej/nginx  PLEASE READ: If you like my work and want to give me a little motivation, please consider donating regularly: https://donate.sury.org/  WARNING: add-apt-repository is broken with non-UTF-8 locales, see  https://github.com/oerdnj/deb.sury.org/issues/56 for workaround:  # LC_ALL=C.UTF-8 add-apt-repository ppa:ondrej/php  More info: https://launchpad.net/~ondrej/+archive/ubuntu/php Press [ENTER] to continue or ctrl-c to cancel adding it  gpg: keyring `/tmp/tmppiurqcxa/secring.gpg' created gpg: keyring `/tmp/tmppiurqcxa/pubring.gpg' created gpg: requesting key E5267A6C from hkp server keyserver.ubuntu.com gpg: /tmp/tmppiurqcxa/trustdb.gpg: trustdb created gpg: key E5267A6C: public key "Launchpad PPA for Ondřej Surý" imported gpg: Total number processed: 1 gpg:               imported: 1  (RSA: 1) OK   
 

Maybe the problem is caused by

  • your locale (language etc)
  • your computer's internet connection
  • some [other] installed PPA or program package

I tried with a live Ubuntu 16.04.1 LTS, and I could add the repository ppa:ondrej/php.

There was a warning: 'add-apt-repository is broken with non-UTF-8 locales.' and a tip with a work-around. See below.

ubuntu@ubuntu:~$ sudo add-apt-repository ppa:ondrej/php  Co-installable PHP versions: PHP 5.6, PHP 7.x and most requested extensions  are included. Only Supported Versions of PHP  (http://php.net/supported-versions.php) for Supported Ubuntu Releases  (https://wiki.ubuntu.com/Releases) are provided. Don't ask for end-of-life  PHP versions or Ubuntu release, they won't be provided.  Debian oldstable and stable packages are provided as well: https://deb.sury.org/#debian-dpa  You can get more information about the packages at https://deb.sury.org  BUGS&FEATURES: This PPA now has a issue tracker: https://deb.sury.org/#bug-reporting  CAVEATS: 1. If you are using php-gearman, you need to add ppa:ondrej/pkg-gearman 2. If you are using apache2, you are advised to add ppa:ondrej/apache2 3. If you are using nginx, you are advise to add ppa:ondrej/nginx-mainline xc2xa0xc2xa0xc2xa0or ppa:ondrej/nginx  PLEASE READ: If you like my work and want to give me a little motivation, please consider donating regularly: https://donate.sury.org/  WARNING: add-apt-repository is broken with non-UTF-8 locales, see  https://github.com/oerdnj/deb.sury.org/issues/56 for workaround:  # LC_ALL=C.UTF-8 add-apt-repository ppa:ondrej/php  More info: https://launchpad.net/~ondrej/+archive/ubuntu/php Press [ENTER] to continue or ctrl-c to cancel adding it  gpg: keyring `/tmp/tmppiurqcxa/secring.gpg' created gpg: keyring `/tmp/tmppiurqcxa/pubring.gpg' created gpg: requesting key E5267A6C from hkp server keyserver.ubuntu.com gpg: /tmp/tmppiurqcxa/trustdb.gpg: trustdb created gpg: key E5267A6C: public key "Launchpad PPA for Ondxc5x99ej Surxc3xbd" imported gpg: Total number processed: 1 gpg:               imported: 1  (RSA: 1) OK 
 
 
 
 

Relacionados problema

3  Haciendo FP7.2 Trabajo bajo Ubuntu 19.10  ( Making php7 2 work under ubuntu 19 10 ) 
Instalé Ubuntu 19.10 y lo usé para el desarrollo web, principalmente con Frameworks PHP. Tenemos algunos proyectos que ejecutan PHP7.2 y PHP7.3. Tengo 7.3 i...

4  Error al instalar PHP7.0-SOAP en Ubuntu  ( Failed to install php7 0 soap on ubuntu ) 
cuando yo sudo apt-get install php7.0-soap Obtengo los siguientes errores: Err http://ppa.launchpad.net/ondrej/php/ubuntu/ wily/main php7.0-soap am...

21  Instale Laravel 5 en Ubuntu 16.04  ( Install laravel 5 on ubuntu 16 04 ) 
¿Alguien instaló Laravel 5 en Ubuntu 16.04? Acabo de cambiar a Ubuntu 16.04 y estoy tratando de instalar Laraver 5 Framework en él usando Composer. Pero cada ...

0  ¿Se admite Oracle XE 11g con Apache2, PHP 7.0 en Ubuntu 16.04 (64 bits)?  ( Does oracle xe 11g support with apache2 php 7 0 on ubuntu 16 04 64 bit ) 
¿El soporte de Oracle XE 11G con Apache2, PHP 7.0 en Ubuntu 16.04? Por favor, ayúdame, ya he instalado Oracle Xe 11g, Apache2 y PHP 7.0 Seguramente debo activ...

5  Obteniendo errores al instalar PHP en Ubuntu16.04  ( Getting errors while installing php on ubuntu16 04 ) 
Comando: ABCDEFGHIJKLMNABCDEFGHIJKLMN1 Salida: Reading package lists... Done Building dependency tree Reading state information... Done php7.0 i...

4  ¿Cómo instalo PHP7 en Ubuntu 14.04? [cerrado]  ( How do i install php7 on ubuntu 14 04 ) 
cerrado. Esta pregunta es off-topic . Actualmente no está aceptando respuestas. ¿Quieres ...

2  ¿Cómo abro PhpMyAdmin? Tengo la salida de script php  ( How do i open phpmyadmin i have php script output ) 
¿Cómo abro PhpMyAdmin? Si abro mi localhost / phpmyadmin, tengo la salida de script PHP pero no la interfaz PHPMyAdmin. (haga clic en la imagen para ampl...

119  ¿Cómo instalar PHP 7?  ( How to install php 7 ) 
php 7 salió ayer y me gustaria Prueba. PHP 7.0.0 viene con una nueva versión del motor Zend, numerosas mejoras y nuevas características, como Rendimie...

2  Actualice con seguridad PHP desde 5.6.38 a PHP 7.2+ en Ubuntu 18.04.1 LTS  ( Safely upgrade php from 5 6 38 to php 7 2 on ubuntu 18 04 1 lts ) 
Estoy ejecutando un servidor de producción en Ubuntu 18.04.1 LTS que tiene instalado PHP 5.6.38. Está sirviendo una aplicación PHP 5x, pero debido a los requi...

4  "CURL: depende: libcurl4 (= 7.61.0-1ubuntu2.2) pero no se va a instalar" en Ubuntu 18.10 con PHP 7.2.10  ( Curl depends libcurl4 7 61 0 1ubuntu2 2 but it is not going to be instal ) 
Estoy luchando con la instalación del módulo de curl en Ubuntu 18.10. Mientras que la actualización de 17.10 a 18.10 se eliminó / eliminó el rizo. Ahora, cuan...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos