Error al construir Zephyr con Cmake -- mpiling campo con cmake camp askubuntu Relacionados El problema

Error while building zephyr with cmake


1
vote

problema

Español

IM usando Ubuntu 18.04 y estoy recibiendo este error al ejecutar el primer programa HelloWorld

                                                                                                               CMake Error at /home/hp/zephyr/cmake/extensions.cmake:1082 (message):  Assertion failed: The detected dtc version is unsupported.The version was found to be 1.4.5 But the minimum supported version is 1.4.6   
Original en ingles

im using ubuntu 18.04 and im getting this error while executing the first program helloworld

                                                                                                             CMake Error at /home/hp/zephyr/cmake/extensions.cmake:1082 (message):  Assertion failed: The detected dtc version is unsupported.The version was found to be 1.4.5 But the minimum supported version is 1.4.6 
     
     
     

Lista de respuestas

0
 
vote

Como sugirió Steeldriver, el compilador de árboles de dispositivo (DTC) está por debajo de la versión mínima que requiere Zephyr. Me enfrenté un problema similar con mi construcción y lo arreglé de la siguiente manera: -

  1. Obtenga la última versión estable de Dispositivo-árbol-compilador ( controlar que dice el desarrollo actual y no activo). Actualmente es 1.4.7-1.
  2. descomprimir el paquete: -

      tar xvf device-tree-compiler_1.4.7.orig.tar.xz   
  3. Instalar las dependencias requeridas: -

      sudo apt-get install flex bison swig python-dev   
  4. Navegue al directorio del proyecto y cree el proyecto: -

      cd dtc-1.4.7 && make   
  5. Reemplace el DTC existente con el último instalado. Puedes hacerlo Al actualizar su ruta $ o mover el DTC instalado a / usr / bin

  6. Asegúrese de que el DTC predeterminado es ahora el último

      ABCDEFGHIJKLMNABCDEFGHIJKLMN3   

Esto debe devolver la versión: DTC 1.4.7. Después de eso, reconstruya su programa HelloWorld y debería ser bueno para ir.

Espero que esto ayude.

 

As steeldriver suggested, device-tree-compiler (dtc) is below the minimum version that zephyr requires. I faced a similar issue with my build and fixed it as follows:-

  1. Get the latest stable version of device-tree-compiler (check that it says current-stable and not active development). Currently it is 1.4.7-1.
  2. Unzip the package:-

    tar xvf device-tree-compiler_1.4.7.orig.tar.xz 
  3. Install required dependencies:-

    sudo apt-get install flex bison swig python-dev 
  4. Navigate to the project directory and build the project:-

    cd dtc-1.4.7 && make 
  5. Replace the existing dtc with the latest installed. You can do this by updating your $PATH or moving the installed dtc to /usr/bin

  6. Ensure that the default dtc is now the latest

    cd ~/ && dtc --version 

This should return Version: DTC 1.4.7. After that, rebuild your HelloWorld program and it should be good to go.

I hope this helps.

 
 

Relacionados problema

10  Cmake Error: ¿No se pudo encontrar cmake_root?  ( Cmake error could not find cmake root ) 
Estoy tratando de construir un proyecto GitHub usando CMAKE y he estado teniendo muchos problemas. Estoy creando un directorio de compilación y llame a cmake ...

2  no se puede cruzar un programa C ++ 11 con multithreads usando CMAKE  ( Cannot cross compile a c11 program with multithreads using cmake ) 
Cuando intenté primero ejecutar el programa, obtuve la siguiente salida: Este archivo requiere compilador y soporte de biblioteca para el próximo estándar I...

1  ¿Cómo instalar un programa en una 'ubicación del sistema'?  ( How to install a program in a system location ) 
Soy bastante nuevo en Linux en general, usando Ubuntu 16.04. Estoy planeando instalar el software Eccodes ( https://softs://software.cmwf.int / Wiki / Pantall...

2  ¿Por qué Pip no instala el último cmake en Ubuntu?  ( Why does pip not install the latest cmake on ubuntu ) 
Como puede ver en https://pypi.org/project/cmake/ , Esta no es la última versión. En Windows, es trabajo como se esperaba. ¿Es un error o algo? root@85aca...

5  Prefijo de instalación predeterminado QT5 / QT5 Widgets Ubuntu  ( Default installation prefix qt5 qt5 widgets ubuntu ) 
Tengo un proyecto CMAke. Estoy tratando de cambiar de QT4 a QT5. find_package(QT5Widgets REQUIRED) EDIT HERE IS A TYPO problem solved (Qt5... instead of Q...

1  Hacer: *** Sin regla para hacer 'instalación' objetivo. Al intentar instalar PLIB-1.8.5  ( Make no rule to make target install when trying to install plib 1 8 5 ) 
Primero, me gustaría decir que soy nuevo en Ubuntu y Linux. Recibí un error con sudo make install mientras sigue las instrucciones para instalar un PLIB-1.8...

128  Cómo instalar Cmake 3.2 en Ubuntu  ( How to install cmake 3 2 on ubuntu ) 
La versión predeterminada de Cmake de 14.04 es 2.8. ¿Cómo puedo instalar CMAKE 3.2 y reemplazar el predeterminado? O ¿cómo puedo actualizar 2.8 a 3.2? ...

0  Problemas para la instalación de OpenCV con CMAKE  ( Problems installing opencv with cmake ) 
Estoy siguiendo un tutorial ( https://www.learnopencv.com / Install-OPENCV3-ON-UBUNTU / ) Para instalar OpenCV 3.0 en Ubuntu 16, pero tengo problemas en el pa...

15  Ctake no puede encontrar Pythonlibs  ( Cmake can not find pythonlibs ) 
Estoy tratando de construir GRAFÍA DE INRIA en mi Ubuntu que se está ejecutando en un simulador de VirtualBox, sigo las instrucciones e instilo los paquetes...

1  Tutorial básico de la Biblioteca de la Nube de Point Cloud (PCL) Clake y haga errores en Ubuntu 16.04  ( Point cloud library pcl basic tutorial cmake and make errors on ubuntu 16 04 ) 
He estado tratando de obtener PCL (1.8) trabajando correctamente en mi sistema (Ubuntu 16.04), pero estoy luchando para que incluso el tutorial básico funcion...




© 2022 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos