¿Cómo abrir aplicaciones independientemente de la versión requerida? -- macos campo con applications camp apple Relacionados El problema

How to open applications regardless of required version?


2
vote

problema

Español

Por lo tanto, descargué esta aplicación en la que estoy relativamente seguro que puede funcionar bien en 10.7.5 (mi versión de OSX), pero cuando intento abrirlo, aparece un mensaje que se aparece diciendo que requiere al menos la versión 10.8. 5. La razón por la que creo que debería trabajar con mi sistema operativo es porque una versión anterior de la aplicación hace, y por lo que puedo decir, no hay contenido real agregado entre esa actualización y este, así que no siento que puedan tener Refactorizado tanto en una actualización algo insignificante que ya no funciona en mi sistema operativo. (Y esta aplicación realmente no le permite degradar, así que se hace decir que debería hacerlo) no se abre y luego se estrella. Cuando intento abrirlo, solo aparece una ventana con el icono del buscador que aparece diciendo que no funciona en la versión actual de mi sistema operativo, y necesito 10.8.5. La aplicación ni siquiera intenta abrir. Así que siento que debe haber una bandera en algún lugar del código o algo que dicte la versión mínima requerida. Entonces, mi pregunta es: ¿Hay alguna manera de ignorar esta bandera y abrir esta aplicación independientemente de la versión mínima requerida?

Original en ingles

So I downloaded this application that I am relatively sure is able to run fine on 10.7.5 (My version of OSX), but when I try to open it, a message pops up saying that it requires at least version 10.8.5. The reason I think it should work with my OS is because an older version of the app does, and as far as I can tell, there is no real content added between that update and this one, so I don't feel they could have refactored it so much in a somewhat insignificant update that it no longer works on my OS. (And this application really doesn't let you downgrade, so done say I should do that) It doesn't open and then crash. When I try to open it, just a window with the Finder icon pops up saying that it doesn't work on the current version of my OS, and I need 10.8.5. The application doesn't even try to open. So I feel that there must be a flag somewhere in the code or something dictating minimum version required. So my question is: Is there a way to ignore this flag and open this application regardless of minimum required version?

     
       
       

Lista de respuestas

3
 
vote

Ese cheque se realiza marcando la plist de la aplicación.

  1. Haga clic derecho en la aplicación y haga clic en "Mostrar contenido del paquete"

  2. abierto "contenidos"

  3. abierto "info.plist"

  4. Desplácese hacia abajo a donde dice "lsminimumsystemVersion" o "versión mínima del sistema", dependiendo del editor que esté usando.

  5. Reemplace la cadena en la siguiente línea que debe ser "10.8.5" (o a la derecha de la tecla, nuevamente, dependiendo del editor) con "10.7.5". Intenta abrir la aplicación de nuevo.

Es posible que tenga que reiniciar después de este cambio.

 

That check is done by checking the application's plist.

  1. Right click on the application and click "Show Package Contents"

  2. Open "Contents"

  3. Open "Info.plist"

  4. Scroll down to where it says "LSMinimumSystemVersion" or "Minimum system version" depending on the editor you're using.

  5. Replace the string on the next line which should be "10.8.5" (or to the right of the key, again, depending on the editor) with "10.7.5". Try to open the app again.

You may have to restart after this change.

 
 
   
   

Relacionados problema

5  ¿Por qué "echo" '"en / etc / bashrc causa scp para colgar?  ( Why does echo in etc bashrc cause scp to hang ) 
Estoy copiando directorios de una máquina de leopardo de nieve a una máquina de tigre usando scp -r y por alguna razón, parece que la línea final del objeti...

2  La máquina del tiempo de león de montaña no puede conectarse de manera confiable a LACIE 2BIG NAS  ( Mountain lion time machine cant reliably connect to lacie 2big nas ) 
He estado usando un ACIE 2BIG NAS para hacer una copia de seguridad de mis Mac por un o dos o dos años, y en general funciona bien. Ahora, sin embargo, tenemo...

3  ¿Cómo puedo asegurar que solo las aplicaciones "blancas" se ejecuten en OS X?  ( How can i ensure only whitelisted applications run on os x ) 
Hay una técnica de seguridad llamada lista blanca (disponible en Windows 7) que garantiza que solo se ejecuten aplicaciones y procesos específicos. Esto es ...

1  Mac App Enterprise Distribution fuera de AppStore con MAPKIT  ( Mac app enterprise distribution outside appstore with mapkit ) 
O bien estoy siendo estúpido (probablemente verdadero) o existe una documentación para abordar la pregunta: ¿Cómo puedo distribuir una aplicación MAC Enterp...

1  Compilación del paquete de descarga de Homebrew  ( Homebrew offloading package compilation ) 
Mi pobre Old 2008 Aluminio MacBook no es la única pieza vieja del kit que tengo en los paquetes de Homebrew, realmente aprecio la capacidad de tener un admini...

3  ¿Ha desaparecido el cuadro de diálogo de copia de archivos en OS X Yosemite?  ( Has file copy dialog disappeared in os x yosemite ) 
Recientemente actualizé a OS X Yosemite, y noté que el cuadro de diálogo de copia de archivos en el buscador parece haber desaparecido. En su lugar, me muestr...

0  ¿Cómo configuro los códigos de acceso para impresoras compartidas?  ( How do i setup access codes for shared printers ) 
Tenemos un Ricoh Afio MP C4501 en nuestra oficina que admite los trabajos de impresión que sostienen que tienen una entrada de código en el teclado (los docum...

1  OS X LEON: ¿Cómo deshabilitar RPC?  ( Os x lion how to disable rpc ) 
Las llamadas remotas de procedimientos se consideran un riesgo de seguridad. ¿Hay alguna manera de deshabilitar RPCS en OS X para hacer que mi Mac sea más s...

2  ¿Cómo editas la lista de Favoritos en Lion Finder?  ( How do you edit the favorites list on lion finder ) 
arrastrar dentro y fuera, no parece estar trabajando para mí, pero puedo ver los que arrastré allí antes de actualizar: ...

2  Evitar que la pantalla se apague con ciertas aplicaciones  ( Prevent display from turning off with certain applications ) 
Tengo un MacBook Pro, y durante las presentaciones de medios, mi pantalla se apaga automáticamente de acuerdo con la aplicación Configuración (que por supuest...

4  ¿Cuánto espacio libre en disco necesito para instalar león, y cuánto perderé al actualizar?  ( How much free disk space do i need to install lion and how much will i lose by ) 
Mi disco duro está empezando a inclinarse un poco, con solo 30 GB disponibles. Estoy sobre la descarga del león y me gustaría saber si necesitaré liberar un e...

60  ¿Hay alguna manera de deshabilitar completamente el muelle?  ( Is there a way to completely disable dock ) 
Quiero que el muelle se haya ido completamente. No lo he usado en las últimas tres lanzamientos de OS X (10.5 a presentar). Quiero que se haya ido por complet...

1  Atajo de teclado para el centro de notificación no funciona  ( Keyboard shortcut for notification center not working ) 
El acceso directo del teclado "Mostrar centro de notificación" Puede configurar debajo de las preferencias del sistema de EM> y GT; Teclado - & gt; Control de...

12  ¿Cómo agregar algunos dominios de búsqueda DNS adicionales sin ignorar los DHCP?  ( How to add some additional dns search domains without ignoring the dhcp ones ) 
¡Solo quiero agregar mi propia lista de dominios de búsqueda, pero sin anular los que devuelven el DHCP? Como cualquiera me imagino que ya intenté agregarlo...

1  Mis preferencias de usuario se han ido tras reinicio  ( My user preferences are gone after restart ) 
Reinicié mi computadora y es como si tuviera una nueva instalación. El sistema me dice que no puede encontrar un archivo de telefonía y mis elementos de ini...




© 2021 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos


Licensed under cc by-sa 3.0 with attribution required.