¿Es posible agregar opciones alternativas SCM en Xcode 3? -- xcode camp apple Relacionados El problema

Is it possible to add alternate SCM options in Xcode 3?


7
vote

problema

Español

¿Es posible agregar opciones de SCM adicionales en Xcode, específicamente mercurial? Sé que es posible afuera con turbio y otros, pero esperaba una integración "Inside Xcode".

Si esto es demasiado así decirlo.

Original en ingles

Is it possible to add additional SCM options in Xcode, specifically Mercurial? I know it is possible outside with Murky and others but I was hoping for a "inside Xcode" integration.

If this is too SOish say so.

  
   
   

Lista de respuestas

3
 
vote

En la última versión beta de Xcode 4, hay un soporte incorporado para GIT, por lo que es posible agregar otros SCM.

Tal vez Apple también incorporará el apoyo mercurial también.

Son varias solicitudes: xcode debería apoyar tanto mercurial como git. , xcode 4 debería soportar mercurial - para poner el soporte mercurial en Xcode.

Entonces, si no puede encontrar una solución ahora, le sugiero que espere hasta que Xcode 4 salga oficialmente.


Por cierto, si necesita o desea un buen cliente Mac OS X para Mercurial, debe intentarlo machg .

 

In the latest beta of XCode 4, there's a built-in support for Git, so it's possible to add other SCM.

Maybe Apple will also incorporate Mercurial support as well.

They are several requests - XCode should support Mercurial as well as Git., Xcode 4 should support Mercurial - to put Mercurial support into XCode.

So if you can't find a solution now, I'd suggest you to wait until XCode 4 goes out officially.


By the way, if you need or want a nice Mac OS X client for Mercurial, you should try MacHg.

 
 
 
 
2
 
vote

La falta de complementos de Xcode se debe al hecho de que Apple no documenta la interfaz de complemento de Xcode en público. Eso hace que la escritura de los complementos Xcode sea muy difícil. Para aumentar la posibilidad de un futuro complemento mercurial, podría presentar un DUPE de Documentación y apertura de la API del plug-in Xcode (. xcplugin y familia) que es Dupe of RDAR: // 3037631.

 

The lack of XCode plugins is due to the fact that apple doesn't document XCode's plugin interface in public. That makes writing XCode plugins very hard. To increase the chance for a future Mercurial plugin you could file a dupe of Documentation and opening of the Xcode plug-in API (.xcplugin and family) which is dupe of rdar://3037631.

 
 
1
 
vote

Por lo que sé, no es posible agregar soporte para Mercurial usando solo XCode. Tienes que usar una herramienta externa (como turbia). El soporte SVN de Xcode es primitivo para decir algo bueno al respecto. Funciona, pero está lejos de ser como "versiones". ;)

 

As far as I know, itxe2x80x99s not possible to add support for mercurial using Xcode alone. You have to use an external tool (Like Murky). Xcodexe2x80x99s SVN support is primitive to say something nice about it. It works, but itxe2x80x99s far from being like xe2x80x9cVersionsxe2x80x9d. ;)

 
 
1
 
vote

uno puede querer evaluarla github para mac como alternativa.

 

One may want to evaluate github for mac as an alternative.

 
 
 
 
0
 
vote

No vas a encontrar una extensión incorporada para agregar otros SCM. La mejor opción es usar otra herramienta (turbia mencionada) o la CLI.

La tercera opción sería construir un conjunto de macros de Xcode que realizan tareas comunes SCM, como cometer y tirar.

 

You're not going to find an built in extension for adding other SCM's. Best bet is to either use another tool (Murky mentioned) or the CLI.

The third option would be to build a set of Xcode macros that performed common SCM tasks, such as commit and pull.

 
 

Relacionados problema

21  No se puede instalar el software porque no está disponible actualmente en el servidor de actualización de software - iPad  ( Cant install the software because it is not currently available from the softwa ) 
Estoy intentando sincronizar mi iPad con mi MacBook Pro, pero cada vez que lo conecto, recibo un mensaje de iTunes ", se requiere una actualización de softwar...

8  ¿Cómo puedo desasociar una sola aplicación (por ejemplo, xcode) de todos los tipos de archivos que se asigna?  ( How can i disassociate a single app e g xcode from all file types its mappe ) 
Cada vez que obtengo una máquina en la que instalo Xcode, se asocia con todo tipo de tipos de archivos. Por ejemplo, .xml , .rb , incluso .java ! Es una mo...

1  ¿El adaptador Lightning to USB 3 me permitirá conectarme a través de Xcode para la depuración a través de la POWER PASSTROURICA?  ( Will the lightning to usb 3 adapter let me connect via xcode for debugging via t ) 
Veo que el Lightning A USB 3 Adaptador de cámara tiene dos 'entradas', el puerto USB y un puerto de rayos adicionales. De la evidencia anecdótica (no he enc...

0  Xcode 10 no siempre salta a la ubicación de la advertencia / error  ( Xcode 10 not always jumps to location of warning error ) 
Después de actualizar a Xcode 10, he notado que para los problemas algunos ( no todos) El editor de código fuente ya no salta a la ubicación de un error de...

0  ¿Puedo recuperar un proyecto XCODE I instalado en mi iPhone?  ( Can i retrieve an xcode project i installed on my iphone ) 
Recientemente ejecuté un estúpido "descartar todos los cambios" en mi proyecto Xcode que resultó en que se eliminó el proyecto. No he encontrado una manera ...

5  Xcode 10 corre realmente lento y disminuye toda la computadora hacia abajo  ( Xcode 10 runs really slow and slows my entire computer down ) 
Actualmente estoy usando Xcode 10.1 y me está volviendo loco, disminuye mi computadora hasta un punto que es inutilizable. Antes de actualizar a Xcode 10, eje...

6  Cómo forzar a Xcode (o cualquier otra aplicación) para estar en el tema oscuro, mientras que la configuración de MacOS Mojave está en modo Light  ( How to force xcodeor any other app to be on dark theme while macos mojaves se ) 
Me encanta Xcode 10 Dark Theme, pero me gustaría mantener todo el sistema operativo en el tema ligero. Pero de forma predeterminada para tener Xcode en el tem...

2  ¿Hay alguna manera de actualizar un IMAC de mediados de 2007 a MacOS Sierra?  ( Is there any way to upgrade a mid 2007 imac to macos sierra ) 
Recientemente obtuve esto IMAC usado, y esperaba poder usarlo para el trabajo de desarrollo. Tuve un disco antiguo de Mac OS X Snow Leopard Instale DISH, que ...

16  No se puede habilitar la opción de corrector ortográfico en Xcode  ( Cant enable spell checker option in xcode ) 
La opción está en gris y no puedo habilitar la corrección ortográfica en Xcode ...

1  ¿Algún escollo en reemplazo de GCC y G ++ con versiones de GNU?  ( Any pitfalls in replacing gcc and g with gnu versions ) 
Entiendo que Clang es el compilador predeterminado y recomendado para MACOS. Por macOS por defecto tiene binarios para gcc y g++ en /usr/bin/ , que son l...

1  Instalación de Error de herramientas de línea de comandos de Xcode: el paquete "desarrollopertoolscli.pkg" no está confiable  ( Installing xcode command line tools error the package developertoolscli pkg i ) 
Cuando intento instalar las herramientas de línea de comandos de Xcode, obtengo el mensaje de error: "El paquete" desarrollarderoolscli.pkg "no está confiable...

38  Determine la versión de Herramientas de línea de comando Xcode  ( Determine xcode command line tools version ) 
¿Cómo puedo determinar qué versión (s) de las herramientas de línea de comandos de Xcode tengo? He intentado hacer $ gcc --version Configured with: --pre...

1  No se puede abrir Firefox y Xcode desde mi última actualización  ( Unable to open firefox and xcode since my last update ) 
Estoy usando OS X EL Captain 10.11.6. Funcionó bien hasta el 14 de diciembre de 2018. De hecho, podría usar Firefox y Xcode (los softwares principales que uso...

0  A partir de marzo de 2019, ¿es necesario construir todas las aplicaciones existentes utilizando iOS 12 SDK y Xcode 10 para que funcione en dispositivos IOS 12?  ( Starting from march 2019 is it necessary to build all existing apps using ios 1 ) 
Esto es lo que dice el sitio web de Apple Developer. A partir de marzo de 2019, todas las nuevas aplicaciones y actualizaciones de la aplicación para iPhon...

7  No se puede compilar el código fuente en Mac  ( Cant compile source code on mac ) 
Ya tengo Xcode instalado en OSX Yosemite. También lo he ejecutado y acepté los términos y condiciones aceptados. También puedo hacer gcc --version y veo ...

Relacionados problema

21  No se puede instalar el software porque no está disponible actualmente en el servidor de actualización de software - iPad 
8  ¿Cómo puedo desasociar una sola aplicación (por ejemplo, xcode) de todos los tipos de archivos que se asigna? 
1  ¿El adaptador Lightning to USB 3 me permitirá conectarme a través de Xcode para la depuración a través de la POWER PASSTROURICA? 
0  Xcode 10 no siempre salta a la ubicación de la advertencia / error 
0  ¿Puedo recuperar un proyecto XCODE I instalado en mi iPhone? 
5  Xcode 10 corre realmente lento y disminuye toda la computadora hacia abajo 
6  Cómo forzar a Xcode (o cualquier otra aplicación) para estar en el tema oscuro, mientras que la configuración de MacOS Mojave está en modo Light 
2  ¿Hay alguna manera de actualizar un IMAC de mediados de 2007 a MacOS Sierra? 
16  No se puede habilitar la opción de corrector ortográfico en Xcode 
1  ¿Algún escollo en reemplazo de GCC y G ++ con versiones de GNU? 
1  Instalación de Error de herramientas de línea de comandos de Xcode: el paquete "desarrollopertoolscli.pkg" no está confiable 
38  Determine la versión de Herramientas de línea de comando Xcode 
1  No se puede abrir Firefox y Xcode desde mi última actualización 
0  A partir de marzo de 2019, ¿es necesario construir todas las aplicaciones existentes utilizando iOS 12 SDK y Xcode 10 para que funcione en dispositivos IOS 12? 
7  No se puede compilar el código fuente en Mac 



© 2021 respuesta.top Reservados todos los derechos. Centro de preguntas y respuestas reservados todos los derechos


Licensed under cc by-sa 3.0 with attribution required.